Download it now!
Bug 136090 - Show the original document without the tracked changes
Summary: Show the original document without the tracked changes
Status: RESOLVED DUPLICATE of bug 116757
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2020-08-24 22:20 UTC by AndyMHancock
Modified: 2020-09-21 13:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AndyMHancock 2020-08-24 22:20:22 UTC
Please provide capability for Writer to show an original document (as opposed to the revised document) without the tracked changes.  See https://ask.libreoffice.org/en/question/253645/libreoffice-writer-show-original-document-without-the-tracked-changes
Comment 1 Dieter 2020-08-25 06:38:26 UTC
Just for clarification: Currently you can see the original document, if you reject all changed. But than of course you change the document. So the idea is an option like "Show document without changes". Is that correct?
Comment 2 AndyMHancock 2020-08-25 14:45:16 UTC
Yes, that is correct. I was motivated to suggest this because the feature is available in MS Word. You can view the final document, with tracked changes applied, or the original document, without any of the tracked changes.  It's a matter of selecting a view, and neither view changes the document or the tracked changes.

What you described as rejecting tracked changes is a work-around for Writer that I never thought about.  I can then undo the rejection to get the tracked changes back.  Thanks.
Comment 3 Dieter 2020-08-25 16:37:53 UTC
Sounds reasonable for me.

cc: Design-Team
Comment 4 Yotam Benshalom 2020-09-06 12:47:13 UTC
I join the request. This is a very useful feature.
Comment 5 Regina Henschel 2020-09-06 13:51:45 UTC
It is not clear to me, what do you want beyond the already available command "Show" in menu Edit > Track Changes.

The standard toolbar in Write has an icon for "Show Track Changes Functions", which shows/hides a toolbar at the bottom. This toolbar has a toggle icon "Show Track Changes", so showing/hiding them is quickly done.
Comment 6 Yotam Benshalom 2020-09-06 14:10:43 UTC
(In reply to Regina Henschel from comment #5)
> It is not clear to me, what do you want beyond the already available command
> "Show" in menu Edit > Track Changes.

When the toggle "show" is disabled, it hides the change marks, and shows the document as it will be if all the changes are *accepted*.

What we need is a way to hide the change marks, and show the document as it will be if all the changes are *rejected*.
Comment 7 Regina Henschel 2020-09-06 14:26:06 UTC
Ah. It might be useful for situations, where you do not have the original document because you have got the document with tracked changes from someone else. Currently making a copy of the file and reject the changes in the copy might be a workaround.

I think, it is a valid feature request.
Comment 8 Heiko Tietze 2020-09-21 12:36:04 UTC
Imagine issues when you edit the "original" document. Could be solved by switching back to the TC mode once you modify the document. MSO has a weird Original: With Markup mode that is pretty similar to the full TC mode but very confusing. Point of the toggle is to temporarily switch back to the original in order to read or verify the actions and not to bring this into the text processing itself.

Michael, is this an (interesting) easyhack maybe?
Comment 9 Timur 2020-09-21 13:52:33 UTC
Looks duplicate.

*** This bug has been marked as a duplicate of bug 116757 ***