Bug 136134 - Easy list of recently used styles for quick applying
Summary: Easy list of recently used styles for quick applying
Status: RESOLVED DUPLICATE of bug 93111
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2020-08-26 06:40 UTC by Telesto
Modified: 2020-09-17 10:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (17.55 KB, application/vnd.oasis.opendocument.text)
2020-08-26 06:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-26 06:40:09 UTC
Description:
Easy list of recently used styles for quick applying. Based on https://www.dedoimedo.com/computers/libreoffice-7-review.html

Steps to Reproduce:
1. Open Writer
2. Search for recently used styles

Actual Results:
Nothing, most om they direction. Applied styles. But relatively unpractical to access 

Expected Results:
Maybe in the drop down in the toolbar or somewhere in the sidebar


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Telesto 2020-08-26 06:42:13 UTC
Created attachment 164696 [details]
Example file
Comment 2 Heiko Tietze 2020-09-08 10:59:35 UTC
You make it really easy for people doing QA. Please don't point at some random website and say "read what this person wrote" but rather bring up a clear use case and support your finding by the referenced url.

I totally disagree with the author on how usable LibreOffice's styles are compared to what Microsoft has. And in particular he is wrong with the advantage of single over double-click. But that's a different topic. 

Question of "recently used styles" is the topic here and he argues: "Say you want to apply STYLE4 to a paragraph (which currently has default settings). You move the keyboard cursor onto the new paragraph, and boom, the styles list jumps to the very beginning." There are plenty of options to filter the list, eg. used styles which makes the scrolling pretty easy. But ultimately he doesn't get the point of paragraph styles and the Next Style attribute. If you create a citation, for example, you definitely don't want to continue in this style but switch back to Text Body for the next paragraph. That renders the request to a WF for me.

Another argument: "Recently used" is a concept we have on various places, for example font name. In case of styles it would spam the list however and break the original sequence. Consider something like Title > Sub title > Heading 1 > Heading 2 > Text Body > Citation > Text Body... and now put these on top of the dropdown list. Alternatively we could introduce another filter for the sidebar which shuffles the styles. Sounds also not like good usability. 

My take => WF
Comment 3 Mike Kaganski 2020-09-08 11:15:48 UTC
Please only focus on the specific issue; viability of other ideas of original article author is irrelevant.

I don't see a problem in a special list of last used styles - either as a special tree view control above the main style list(presumably collapsed until manually expanded), or inside the main list as a "section" above main list - with ability to enable/disable with a new checkbox near the [x] Show Previews.

Yet, I don't see a use case where the proposed "last used" list does a better job than one of current set of options - namely, "used styles" that Heiko mentioned. Is there an evidence that documents are frequent enough with too many used styles to fit into the usual control height, so that the small "last used" list would actually help?

Still, I would consider the "Last used" styles being re-arranged to the top of the list to be fine in *one* mode: namely, "All Styles" that doesn't have the hierarchical structure, and has a big length. That could arguably make this mode more functional.
Comment 4 andreas_k 2020-09-08 11:34:08 UTC
I'd like to have an recently use style also at impress/draw for drawing shapes.
Comment 5 Thomas Lendo 2020-09-08 19:46:36 UTC
Another way of making styles better usable for some users like favorite styles as in bug 93111.

I like the idea. This list should show a set of X styles that were assigned to content recently.

This information will be stored in the user profile and not in the file itself.
Comment 6 Heiko Tietze 2020-09-17 10:52:03 UTC
(In reply to Thomas Lendo from comment #5)
> Another way of making styles better usable for some users like favorite
> styles as in bug 93111.

Not a fan of more filter but it's an acceptable (and not too difficult to implement) solution. So let's take this as duplicate.

*** This bug has been marked as a duplicate of bug 93111 ***