Bug 136348 - Too many ways of setting page styles (to portrait)
Summary: Too many ways of setting page styles (to portrait)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-31 21:42 UTC by Telesto
Modified: 2020-12-18 07:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (13.65 KB, application/vnd.oasis.opendocument.text)
2020-08-31 21:42 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-08-31 21:42:30 UTC
Description:
To many ways of setting page styles

Steps to Reproduce:
1. Open the attached file
2. Select the yellow marked text
3. Format -> Paragraph -> Text flow tab
4. Check Insert Break
5. Check with page style -> Landscape
6. Press OK
7. Press CTRL+ENTER
8. Select the blue header bar -> Edit Page break
9. Text flow tab 
10. Check insert page break -> Check with style -> Select first page
11. Press OK
12. Sidebar -> Default paragraph style -> Right click -> Modify
13. Text flow tab
14. Check insert break
15. Check with page style -> Pick say Index
16. Press OK
17. Place cursor on the second page
18. Format -> page style
19. Organizer tab
20. Select next page style -> To HTML

Not even sure if the end result is intended.. 4 pages?


Actual Results:
Overwhelming amount ways of defining page styles

Expected Results:
Bit more simplistic if possible


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1e0cfd5662d95cea84e80e4fe10d52c3b1101ae6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-08-31 21:42:43 UTC
Created attachment 164944 [details]
Example file
Comment 2 Telesto 2020-08-31 21:44:27 UTC
See bug 136346 where this tends to cause problems
Comment 3 Justin L 2020-09-02 11:09:37 UTC
3.) necessary - it is a paragraph property.
8.) shortcut to paragraph property. Helps people find it who don't know it is a paragraph property. Seems really logical to have it here.
12.) Of course, any paragraph property can also be set in a paragraph style. Especially useful for things like title styles that always want to start on a new page.
20.) This is a completely different kind of thing.  This is a first/follow idea which has completely different uses from a hard-coded page break. This kind of idea is essential for interoperability with MS Formats which can define different page styles pretty much anywhere on the page.

Your biggest failure in this test is setting a page break on the default style (#12). Thus of course every paragraph will be on its own page. So yes, four paragraphs, four pages.
Comment 4 Telesto 2020-09-02 19:41:35 UTC
(In reply to Justin L from comment #3)
> 3.) necessary - it is a paragraph property.

-> A topic which will keep confusing me for ever ;-). As I don't grasp they concept of paragraph style regulating page style. Do get the concept if I want to use it. However I sometimes simple intend to rotate the page (where I don't need it to be regulated by the paragraph). But he, that's me  

The whole page style business is even more confusing for the first page, where the blue bar is missing (in my mental idiotic mental world the blue header bar is linked 'page setting'. See 8. So setting page style for page 1 has always been even more problematic.  

Format -> Page Style only allows to configure the next page. And inserting a page break at the first and single page with a page style sounds kind of silly. I'm this might make sense in developer reasoning/logic. It's kind of counter intuitive if you ask me. And is of course partly a dialog problem. Same dialog reused over and over.. So I do understand where this coming from.

> 8.) shortcut to paragraph property. Helps people find it who don't know it
> is a paragraph property. Seems really logical to have it here.

-> It need to be there.. see before :-). And 

> 12.) Of course, any paragraph property can also be set in a paragraph style.
> Especially useful for things like title styles that always want to start on
> a new page.

Me complaining about amount of dialogs; isn't saying there an not useful :-). It's more the 'same'/ similar setting is being distributed all over the place. 

> 20.) This is a completely different kind of thing.  This is a first/follow
> idea which has completely different uses from a hard-coded page break. This
> kind of idea is essential for interoperability with MS Formats which can
> define different page styles pretty much anywhere on the page.

This may be a total different concept, however they "with page style" setting (say Index) lands in "Organizer tab" next page style. When pressing CTRL+Enter a new page will be added with page style 'Index' based on "Organizer tab" which inherited by "with page style" paragraph setting. So those concepts are linked. 

If you change the Next Page Style in the organizer tab to say Default Page, a new page will be introduced. The page style isn't defined in 'paragraph style'  with page style (not enabled). Not based on "with page style" of the previous page, but based on the Page style in the "Organizer tab".

They most counter intuitive part being page style being set on the previous page. This probably works working from bottom to top. However if you intend insert some say landscape somewhere, later on.. What should I use. Page Style Next style? Or Paragraph Style with style?

This maybe might make all sense in a developer point of view, but at some point I'm losing track :-)
Comment 5 Justin L 2020-09-03 04:57:24 UTC
The key to understanding is to focus on the content.

The blue bar is a "force a page break right now" based on my content, regardless of how full the page is. So the blue bar itself has nothing to do with page styles necessarily. The "right now" needs to be tied to something - and that something is a paragraph. (And it logically makes sense to allow a different page style to be defined on the command that starts a new page, so thus you can also define a page style change with this.)

First/follow is used when you don't have a "right now" point where the page needs to change. You just want it to change whenever this first page is full - regardless of the content.

In the end, this isn't something driven by developer logic, but simply document layout logic. With only two page-change mechanisms, it isn't terribly confusing.

Although I will admit (since I also experience it) that until you grasp this it is terribly confusing when you try to mix and match the two.
1.) set Landscape page style to use default style as next. 
2.) create a four page document (all using the default page style).
3.) put your cursor somewhere in page 3 and then double-click on Landscape page style

Result? Page one becomes Landscape, and pages 2-4 are Default style (portrait).

Ultimately, that DOES make sense because there are no hard page breaks defined, so page style changes apply to a "section" and not to a cursor point. If you really want to have Landscape start on page 3, you need to first need to make a hard-page-break (Ctrl-break) to indicate where page 3 must start (defining content flow), and then apply a style to it.

So I think it really helps if you look at this as a two-piece problem.  First is where do I want my pages to start (ctrl-break) and then what should the page look like.
Comment 6 Justin L 2020-09-03 08:37:06 UTC
(In reply to Telesto from comment #4)
> Format -> Page Style only allows to configure the next page.

OK - true as long as you are thinking of this "section" of pages. If you are thinking in relation to a specific paragraph, then you will get confused by the results. This has nothing to do with "where the cursor currently is" next page.

> > 12.) Of course, any paragraph property can also be set in a paragraph style.
> > Especially useful for things like title styles that always want to start on
> > a new page.
> 
> Me complaining about amount of dialogs. It's more the 'same'/ similar setting is being distributed all over the place. 

I don't see this being any different than setting bold - via direct formatting, via character styles, or via paragraph style. It is all the same concept, so it should use the same dialog.

The main difference from a comparison with "bold" is that there are two ways to define a page-style change - the paragraph's page break and the page style's one-page-follows-the-next-page - which is the same idea as one-paragraph-styles switches to the next like Header changes to TextBody on a CR. 

> > 20.) This is a completely different kind of thing.  This is a first/follow
> > idea which has completely different uses from a hard-coded page break. This
> > kind of idea is essential for interoperability with MS Formats which can
> > define different page styles pretty much anywhere on the page.
> 
> This may be a total different concept, however they "with page style"
> setting (say Index) lands in "Organizer tab" next page style. When pressing
> CTRL+Enter a new page will be added with page style 'Index' based on
> "Organizer tab" which inherited by "with page style" paragraph setting. So
> those concepts are linked.

Sure. One defines WHAT will happen and the other defines WHEN it happens.

> The most counter intuitive part being page style being set on the previous
> page. This probably works working from bottom to top. However if you intend
> insert some say landscape somewhere, later on.. What should I use. Page
> Style Next style? Or Paragraph Style with style?

Yup - I agree. This is the hardest to wrap the mind around - although it makes perfect sense. This works top-to-bottom, with top being defines as the most recent hard-page-break.

In your example, you want to change the layout at a specific location based on the content, so that by definition means a hard page break. (paragraph property break with style)

P.S. Never use the page-style's first/follow for compatibility reasons.
Comment 7 Telesto 2020-09-03 10:18:54 UTC
(In reply to Justin L from comment #5)
For the record, 'wrap the mind around" or "Ultimately, that DOES make sense" is for equivalent for someone needs think about this again. If there is a way to 'make this more' natural. 

Ideally a mental exercise should be avoided. I have certainly already spend 5 minutes on figuring out how to rotate a single page in a document. Which I my exception should be a single mouse click away. So my mood deteriorates pretty quickly.

Secondly I don't rotate pages all day; not routine action. So I tend to 'forget' how it should be done. So those 5 minutes tend to repeat itself.

And I start to dislike software which doesn't do what I want it to do.

So yes, the current implementation makes sense in ultimo. However, someone needs re-think this. Are there a few tweaks possible to make it work more natural at 85% of cases.. Maybe reducing the comfort for 15% of the actions. It would be still a benefit. 

Of course we are lacking an UX research department (with same budget as at Microsoft). So there is no way of knowing if people having issues with this. I assume so, as 'we' even tend to write 'wrap the mind around". And that's bad omen.

Proposing alternatives is however an different topic, as we get on the 'brilliant' idea topic; of not getting the model. As this tends to be rather wired to number of cases. And overseeing all/most likely scenario's is already hard. And there are mostly multiple directions to go; with advantages an disadvantages. Some times multiple 'tweaks' must be made. 

But getting to a acceptable outcome is quite a thing.. Like me 'fulminating' at workflow for PS/CS/DF  (or more specific the fight against how DF functioning). 
Maybe my taste; maybe looking from the wrong perspective. But there is certainly something not as it "supposed to be". Or phrase it differently: there is certainly room for improvement. As it's simple frustrating to use. Less flexible/ tolerant/ easy to work with compared to what it could be; IMHO
Comment 8 Justin L 2020-09-03 11:09:46 UTC
The only enhancement I could see would be implementing something that fits Word's concept of a continuous section break - which allows random placement of page changes that will occur at the next soft page break. But I'm afraid that will be the complete opposite of "simplifying" the users ability to figure out what is going on.

So for example if you rotate a page, then on the previous page - somewhere - it would insert an attribute that says that when it is time to go to another page, then use this page style.
Comment 9 Telesto 2020-09-04 08:10:17 UTC
@Justin
My proposal at bug 136412. In search for some feedback; Mostly why this can't be done :-)

Double Clicking a Page Style (Sidebar -> Styles -> Page Style) should insert a (new) page break if not already present (the other case being already present with a style set) and apply the they Page Style (in this case Landscape) to only that page. 

The page is followed by already existing pages. A page break should be added on top and below. So simple the page in question would be rotated. If more pages a selected, a page break should be insert at top and bottom of the selection (of couse)
Comment 10 Justin L 2020-12-18 07:12:53 UTC
(In reply to Telesto from comment #9)
> Double Clicking a Page Style (Sidebar -> Styles -> Page Style) should insert
> a (new) page break if not already present 

So then how would you go about changing all of the pages to a different style in a large document? No, the only logical way is to have the human insert page breaks where they are desired.

The current implementation is not wrong, and it is logical. Any change to it would be considered a bug. WONTFIX.