Bug 136518 - Search toolbar (Ctrl+F) should search by "Values" instead of "Formulas" by default
Summary: Search toolbar (Ctrl+F) should search by "Values" instead of "Formulas" by de...
Status: RESOLVED DUPLICATE of bug 102506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Toolbar
  Show dependency treegraph
 
Reported: 2020-09-06 15:17 UTC by reikenberg
Modified: 2020-09-07 14:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example (8.13 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-09-06 15:17 UTC, reikenberg
Details
More detailed example (10.78 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-09-07 11:33 UTC, reikenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description reikenberg 2020-09-06 15:17:10 UTC
Description:
If you use vlookup to get a text and try to search for the text the search find nothing.


Steps to Reproduce:
1. Use vlookup to get text from a source
2. Search for the given text
3. The search didnt find the vlookup results

Actual Results:
Searching did not find text from vlookup.

Expected Results:
The search should find the vlookup results


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 reikenberg 2020-09-06 15:17:57 UTC
Created attachment 165201 [details]
Example
Comment 2 reikenberg 2020-09-06 15:22:27 UTC
Search and replace work if you turn on search "values".
This should be default for the normal search or give the option to switch to values too.
Comment 3 Ming Hua 2020-09-06 16:49:16 UTC
(In reply to reikenberg from comment #2)
> This should be default for the normal search or give the option to switch to
> values too.
There is already an option.

In the "Search and Replace" dialog, on the bottom right, there is a drop-down list labelled "Search in:", and the options are: Formulas, Values, and Notes.  The default choice is Formulas.

Changing it to Values make it possible to search for the VLOOKUP() results in your example file for me.  Does it work for you?
Comment 4 [REDACTED] 2020-09-06 21:53:44 UTC
No repro using:
Version: 6.0.7.3, Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group

No repro using:
Version: 7.0.1.2, Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US, Calc: threaded

No repro using:
Version: 6.4.6.2,Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded



Remark: Sample file uploaded by reporter doesn't use absolute addressing in VLOOKUP, hence the lookup range shifts due to copy&paste of the formula. It reads =VLOOKUP(A1;H1:I3;2;0) for the first row while it should use absolute addressing at least for the row numbers and read =VLOOKUP(A1;H$1:I$3;2;0) to assure the same lookup array being referred.
Comment 5 reikenberg 2020-09-07 11:33:22 UTC
Created attachment 165227 [details]
More detailed example

Search via CTRL+f find the yellow hits but not the from vlookup in red
CTRL+ALT+f has an option to set so you can find vlookup values to.

Search via CTRL+f should be find anything you see in the sheet by default.
This is what a normal user would expect.
Specially if a formula like =“test“ is found, but vlookup is not.
Comment 6 reikenberg 2020-09-07 11:39:56 UTC
(In reply to Ming Hua from comment #3)
> (In reply to reikenberg from comment #2)
> > This should be default for the normal search or give the option to switch to
> > values too.
> There is already an option.
> 
> In the "Search and Replace" dialog, on the bottom right, there is a
> drop-down list labelled "Search in:", and the options are: Formulas, Values,
> and Notes.  The default choice is Formulas.
> 
> Changing it to Values make it possible to search for the VLOOKUP() results
> in your example file for me.  Does it work for you?

Yes, i know this option for "Search and Replace", but the normal "Search" should find anything you can see. That is what you expect if you use the normal search function.
Comment 7 Ming Hua 2020-09-07 12:20:41 UTC
(In reply to reikenberg from comment #5)
> Search via CTRL+f should be find anything you see in the sheet by default.
> This is what a normal user would expect.
You and I apparently have very diffrent ideas about what a normal user would expect.

But I'm not a developer.  Let's try to get some developers' opinion.
Comment 8 [REDACTED] 2020-09-07 13:47:45 UTC
seems to be a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=102615
Comment 9 V Stuart Foote 2020-09-07 14:56:25 UTC
Yes a clear duplicate of bug 102506

*** This bug has been marked as a duplicate of bug 102506 ***