Bug 136682 - Delete all comments not working after using Format All Comments
Summary: Delete all comments not working after using Format All Comments
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: needUITest
Depends on:
Blocks:
 
Reported: 2020-09-11 19:01 UTC by Telesto
Modified: 2020-09-28 17:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (12.19 KB, application/vnd.oasis.opendocument.text)
2020-09-11 19:01 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-09-11 19:01:27 UTC
Description:
Delete all comments not working after using Format All Comments

Steps to Reproduce:
1. Open the attached file
2. Click on the 'arrow down' menu at a comment
3. Select Format all comments
4. Choose a different highlight color
5. Press OK
6. Try to reopen Format all comments or to delete all comments

Actual Results:
Not orking

Expected Results:
Should work


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: ed4f610f4a3de12016f8308a17b6ad4f86e9d67a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-09-11 19:01:38 UTC
Created attachment 165406 [details]
Example file
Comment 2 Telesto 2020-09-11 19:07:45 UTC
Also in
6.0

and in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

and in
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba


feature didn't exist in 4.2

Simplified
1. Open the attached file
2. Click on the 'arrow down' menu at a comment
3. Select Format all comments
4. Press OK
5. Click on the 'arrow down' menu at a comment
6. Select Format all comments
Comment 3 Telesto 2020-09-11 19:09:13 UTC
@Caolan
You might be interested in this one. The dialog refuses to reopen, after the initial opening (and blocking some more functions)

Current: Status Unconfirmed
Comment 4 BogdanB 2020-09-11 19:28:20 UTC
Tested by info from description

Confirmed with
Version: 7.1.0.0.alpha0+
Build ID: 3a22f5a589e822e7ca8bbb00e38a3aff93ed7ba5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 5 Caolán McNamara 2020-09-17 10:24:33 UTC
I think the initial dialog is in the main document context and a sidebar window is designated as an active one by the document context on seeing this command (and restored back to its original unset state when the dialog completes). After the first dialog is gone the context is now a sidebar window but it's not set as the active sidebar. The next attempt to launch the dialog is dismissed because there isn't an active sidebar context according to the sidebar context.

Setting the context belonging to the button as active when the button is used to launch something seems a sensible solution to me
Comment 6 Commit Notification 2020-09-17 13:05:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1b672e44c234f7ca396f7d593abfa74d766a2774

tdf#136682 set the sidebar of the menubutton as active on execute command

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2020-09-17 13:06:41 UTC
fix in master, backport to 7-0 in gerrit
Comment 8 BogdanB 2020-09-23 15:19:49 UTC
Verified. Fixed in Version: 7.1.0.0.alpha0+
Build ID: 121771e37f7e2de41cd5643475861062bf25627b
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 9 Commit Notification 2020-09-28 03:20:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/730b66f96431a1469ac280eccdc2d24d9d41e4fe

tdf#136682 set the sidebar of the menubutton as active on execute command

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.