Download it now!
Bug 136985 - Crash after resolving comment, undoing and opening redo steps
Summary: Crash after resolving comment, undoing and opening redo steps
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.3 target:6.4....
Keywords: haveBacktrace
: 136804 (view as bug list)
Depends on:
Blocks: Undo-Redo Writer-Comments
  Show dependency treegraph
 
Reported: 2020-09-23 21:09 UTC by Aron Budea
Modified: 2020-10-01 08:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (20.31 KB, text/plain)
2020-09-25 23:36 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2020-09-23 21:09:29 UTC
- Open attachment 165691 [details] from bug 136895,
- Resolve one of the comments,
- Undo twice (normally it should only be possible to undo once, the undo list only shows one step, too),
- Open the Redo steps.

-> Crash.

Observed using LO 7.1.0.0.alpha0+ (121771e37f7e2de41cd5643475861062bf25627b) / Ubuntu.
No crash with LO 7.0.0.3.

This is a regression that started from the commit listed below, identified using repo bibisect-linux-64-7.1. Not sure if it's related to resolving comments not having proper undo steps (what bug 136895 is about), but it wasn't crashing before this commit. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1b672e44c234f7ca396f7d593abfa74d766a2774
author		Caolán McNamara <caolanm@redhat.com>	2020-09-17 11:24:37 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-09-17 15:05:03 +0200

tdf#136682 set the sidebar of the menubutton as active on execute command
Comment 1 Caolán McNamara 2020-09-25 13:22:02 UTC
If you click in the commit before you resolve it and repeat the how to reproduce steps then it will also crash without my change. The problem is preexisting.
Comment 2 Commit Notification 2020-09-25 18:48:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e2cea687d4275c31b780bfe8307daed552e45da0

Related: tdf#136985 comment select all adds an undo action to the stack

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Aron Budea 2020-09-25 21:03:41 UTC
Indeed, I could reproduce this in 6.4.0.3 as well with the modified steps.
Comment 4 Aron Budea 2020-09-25 23:36:42 UTC
Created attachment 165858 [details]
Backtrace
Comment 5 Commit Notification 2020-09-26 20:21:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a352e8fe658143c30c9e6093c71cab9c06b42e6a

Related: tdf#136985 SfxStringListItem::GetString() crash in empty case

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-09-28 12:07:39 UTC
*** Bug 136804 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2020-09-28 15:00:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2c771c0552bfab8d97ec5c35b363a3e4eda0b6dc

Related: tdf#136985 apparent phantom redo entries with cursor in comment

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-09-28 15:05:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/fdcbf9b65e8ebffde270bf0a5486f1505bd58e26

Related: tdf#136985 comment select all adds an undo action to the stack

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-09-28 15:07:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/071e31fdb77b34ea90fbfa0e0001669500395119

Resolves: tdf#136985 bogus undo steps added by comment manipulation

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-09-28 15:10:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/7c8f997321e136208e8983ab6ad78cc33891125f

Related: tdf#136985 SfxStringListItem::GetString() crash in empty case

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-09-28 19:11:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/091f244d4d68ea9973a502632c6aeee19d702139

Related: tdf#136985 restore focus to doc it wasn't initially in the comment

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2020-09-28 19:25:50 UTC
Nasty knot of problems here, but it seems to be crash free now. I may have fixed one or two of the cluster at https://bugs.documentfoundation.org/show_bug.cgi?id=106179 "by accident" along the way if someone would like to check those.
Comment 13 Commit Notification 2020-09-29 08:57:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0451222f307e00ce688c564c10f39e894973c91e

Related: tdf#136985 SfxStringListItem::GetString() crash in empty case

It will be available in 6.4.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-09-29 09:25:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-7":

https://git.libreoffice.org/core/commit/e88369905f04ad22e424b03358450b584fdeaebe

Related: tdf#136985 SfxStringListItem::GetString() crash in empty case

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-09-29 10:01:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/4677f06baff2ac3d667f74d84d85de45f8c35849

Related: tdf#136985 apparent phantom redo entries with cursor in comment

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-09-29 10:04:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/45096d16b82678873964802fd21922368a25296d

Resolves: tdf#136985 bogus undo steps added by comment manipulation

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-09-29 10:05:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-2":

https://git.libreoffice.org/core/commit/60723da529bbbac7067a86715752e4dbe7c6a291

Related: tdf#136985 SfxStringListItem::GetString() crash in empty case

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Xisco Faulí 2020-09-29 11:41:03 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cd85546a2fbdade42f80fd3b6bd650791db9f32d
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: tr-TR (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 19 Commit Notification 2020-10-01 08:00:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/b1574603d61914fc2eb498e99b199ca81d0bf578

Related: tdf#136985 restore focus to doc it wasn't initially in the comment

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.