Bug 136683 - LibreOffice crashes Windows to bluescreen on startup
Summary: LibreOffice crashes Windows to bluescreen on startup
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-09-11 19:57 UTC by BDF
Modified: 2021-07-10 14:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The blue screen I get after opening LibreOffice (6.38 MB, image/jpeg)
2020-09-11 20:01 UTC, BDF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BDF 2020-09-11 19:57:15 UTC
Description:
When I startup LibreOffice it crashes my system to a bluescreen (see image).
I recently updated from version 6.4.4.2 to 7.0.1.
I uninstalled the old release and installed the new release. Now LibreOffice crashes my system everytime on startup.

Steps to Reproduce:
1. Start LibreOffice (open a file, start the the component (eg. Calc or Writer) directly, start the LibreOffice app directly)

Actual Results:
Blue Screen of Death

Expected Results:
A bit less blue screen and a bit less crash would be nice


Reproducible: Always


User Profile Reset: No



Additional Info:
Not sure if that matters:
I had my browser open when I uninstalled LibreOffice. The uninstaller told me that I had to close the browser or my restart my PC. I did neither. I installed the new version. The installer told me the same thing. I did not do it again. I wanted to open a file and got a crash right away. I installed new versions of LibreOffice the same way a few times before without any problems.

I tried to restart/shutdown the PC to check if that helps when it does not crash for once (it does not).

- - - - - - - - - - - - - - - - - - - - - - - - -

I installed the new version on a PC with Windows 7 and I used the x64.msi installer for it.

I did not try to uninstall and reinstall the programm or reset any config files yet (maybe there is somebody who has an idea for a test before I do that and it works)

I obviously can't copy any version information from the programm.
Comment 1 BDF 2020-09-11 20:01:44 UTC
Created attachment 165409 [details]
The blue screen I get after opening LibreOffice
Comment 2 Julien Nabet 2020-09-11 20:12:57 UTC
Do you reproduce this in safe mode?
Could you also give a try at https://wiki.documentfoundation.org/QA/FirstSteps?
Comment 3 Telesto 2020-09-11 20:26:52 UTC
And if not, please check Force Skia Software rendering (in the Safe mode wizard)

Looks like a driver issue
Comment 4 BDF 2020-09-12 12:48:24 UTC
@ Julien Nabet:
What I tested:
 - Open regular LibreOffice with Windows 7 in safe mode (it worked)
 - Open safe mode LibreOffice with Windows 7 in regular mode (it worked)
   > I guess that safe mode in LibreOffice does the same thing as regular LibreOffice with Windows 7 in safe mode
   > When I opened LibreOffice in safe mode and use the pop-up window to switch to regular mode I get the BSOD again
 - Reset User profile (did not help)
 - Look at OpenGL rendering mode (I added the system stats at the bottom, by the text of the wiki "UI render: default" should not make any problems)

@ Telesto:
*educating myself about skia*

How (and where) would I force the Skia Software rendering?
By looking at the 'About LibreOffice'-image on https://www.collaboraoffice.com/success-story/implementing-vulkan-capable-libreoffice-user-interface-using-the-skia-library/ I would say it is disabled on my machine, isn't it?

I tried to turn off hardware acceleration in the pop-up menu at the start of safe-mode before I switched to the regular LibreOffice. The result was the usual BSOD.

- - - - - - - - - - - - - - - - - - - - - - - - -

o) LibreOffice Info:

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: de-AT (de_AT); UI: de-DE
Calc: threaded

o) System Info:
The crashing system is an older MSI GX60 laptop.
It includes an AMD A10-4600M APU. This APU has an AMD Radeon HD 7660G IGP.
The system also has a dedicated GPU: AMD Radeon HD 7970M
The driver is the ATI/AMD Catalys 15.201.1151.1010 (which is the latest driver that still works on my system).

I used Linux on this machine at some point (like 6 years ago), but for a very long time I had problems with this IGP+dedicated GPU setup. Maybe this is the same thing here as well.

+   +   +   +   +   +   +   +   +   +   +   +   +   +   +

o) LibreOffice info of a second machine:

I updated a second machine to LibreOffice 7.0

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU-Threads: 6; BS: Windows 6.1 Service Pack 1 Build 7601; UI-Render: Skia/Raster; VCL: win
Locale: de-AT (de_AT); UI: de-DE
Calc: CL

On this machine I NEVER had any crash related to LibreOffice.
Comment 5 Julien Nabet 2020-09-12 16:13:31 UTC
Since I don't have more questions, I'll put it back to UNCONFIRMED.

I can't help here so uncc myself.
Comment 6 BDF 2020-10-11 09:23:04 UTC
I downloaded and tested the latest update (Version: 7.0.2.2 (x64), Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994). This version still crashes my PC
Comment 7 BDF 2020-10-31 22:59:41 UTC
I again downloaded and tested the latest update (Version: 7.0.3.1 (x64), Build ID: d7547858d014d4cf69878db179d326fc3483e082). This version also still crashes my PC

I would really love to know if there is anything I can do/test for this bug.
Comment 8 BDF 2020-11-07 07:25:34 UTC
.I tested the 7.1.0 Alpha (Version: 7.1.0.0.alpha1 (x64),
Build ID: 987671387712c4f9061d6216ff2f001a7bb9e57b) and this one also crashed my system
Comment 9 Fabio 2021-03-31 15:22:39 UTC
This issue is happening to me too.

This morning I was using LibreOffice like any other day. Then a few hours ago, I tried to open a .odt file that is available on my private network and this is when the first blue screen happened to me.
Now every time I open LibreOffice, Windows 10 crashes.

I had LibreOffice 7.0.4.2 installed on Windows 10 Home Build 19042.867.
I've uninstalled LibreOffice, removed the user data folder and install LibreOffice 7.1.1, but the same issue happens.
Comment 10 BDF 2021-04-04 09:10:42 UTC
@ Fabio: have you tried in reinstall an older version? For my old system I was not able to use any 7.x version. But the latest 6.x worked fine for me.
Comment 11 Xisco Faulí 2021-07-07 11:15:22 UTC
Hello BDF, Fabio,
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 12 BDF 2021-07-10 11:15:56 UTC
@ Xisco Faulí: I have tested the issue with LibreOffice 7.1.4.2 and it still crashes my system.

At thie point I have no idea how I could help with the issue any longer. Is there a BSOD report I could provide?

General Note:
The crash only occurs on my Windows 7 Laptop that is +8 years old. Since I had to replace it and it's already waiting to be recycled, I will not be able to test new LO updates in the future.
Since nobody else seems to have this problem and it seems to be something in between unfixable and not worth the effort (since I am the only one effected and I already have a new system) I'm fine if you want to close the issue.
Comment 13 V Stuart Foote 2021-07-10 14:03:42 UTC
OP was working on an unsupport Windows 7 SP1 build which has been taken out of service.

User profile is very suspect, but seems it was never reset and allowed to rebuild from defaults.  Safemode would not crash/bluescreen.

A WinDbg stacktrace of an attached soffice.bin process might have been helpful in identifying the issue (possibly Skia rendering relateed). But with system gone this is not actionable.