Bug 136818 - Calc crashes when I try open a file (Very large table option is enabled)
Summary: Calc crashes when I try open a file (Very large table option is enabled)
Status: RESOLVED DUPLICATE of bug 133748
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-09-16 20:55 UTC by Roman Kuznetsov
Modified: 2021-09-06 11:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
i get this error and LO crash (1.79 MB, image/png)
2020-09-21 09:53 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-09-16 20:55:34 UTC
Description:
Calc crashes when I try open a file (Very large table option is enabled)

This report follows from bug 133748 and its attach

Steps to Reproduce:
1. Make sure you enabled Very large table option
2. Try open https://bugs.documentfoundation.org/attachment.cgi?id=161712
3. Calc crashes

Actual Results:
Calc crashes

Expected Results:
Calc opens that file


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Mac OS X 10.15.6; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-09-17 12:10:17 UTC
Not reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 6f1e02c96b887750f974c187a82ecd6236e6a435
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Roman Kuznetsov 2020-09-17 17:07:07 UTC
no crash in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 8c18cd6823ddf4ef5ba67801a84cee26c9b5a9a6
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL

I should retest it in macOS, set NEEDINFO myself
Comment 3 QA Administrators 2020-09-18 04:07:49 UTC Comment hidden (obsolete)
Comment 4 BogdanB 2020-09-21 09:53:12 UTC
Created attachment 165714 [details]
i get this error and LO crash
Comment 5 BogdanB 2020-09-21 09:55:00 UTC
I get this error and crash only when scrolling down it the sheet with many rows.
Comment 6 BogdanB 2020-09-21 09:55:17 UTC
Confirm with
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 7 Terrence Enger 2020-09-24 00:15:17 UTC Comment hidden (obsolete)
Comment 8 BogdanB 2020-09-24 04:17:06 UTC Comment hidden (obsolete)
Comment 9 BogdanB 2020-09-24 04:56:29 UTC
LibreOffice 7.1 Calc - Tools - Options - Advanced - Enable Experimental Features

after that

LibreOffice 7.1 Calc - Tools - Options - LibreOffice Calc - Defaults - and check "Enable very large spreadsheets (16m rows, 16384 cols)"
Comment 10 Terrence Enger 2020-09-24 13:55:38 UTC
Thank you, BogdanB.  I do not know how I missed that.

I fail to reproduce the bug in a local build on debian.buster.
Comment 11 Timur 2021-09-06 11:20:19 UTC
Repro 7.1 oldest for scroll (as comment 5), but not 7.1 master nor 7.3+. WFM.
Comment 12 Timur 2021-09-06 11:33:35 UTC
Same commit fixed it.

*** This bug has been marked as a duplicate of bug 133748 ***