Bug 136902 - printing garbage from Libreoffice writer on Brother printer
Summary: printing garbage from Libreoffice writer on Brother printer
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print Qt5
  Show dependency treegraph
 
Reported: 2020-09-20 20:23 UTC by realtime
Modified: 2021-04-23 04:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description realtime 2020-09-20 20:23:43 UTC
Possible problem printing LibreOffice textfiles using my Brother MFC-L2710DW.  I have had the problem for several months and assumed it was my printer.  I solved it by copying the text file into an ascii editor like Featherpad or Notepad and printing from that software.  I do not print much and thought if Brother modified their software it would be solved if I reinstalled a newer version, but I recently re-installed a newer version and it just prints jibberish and there are only a few alpha numeric characters.  It will print PDF files also.  It would be nice if I could print to a file, which used to exist.  After I re-installed Libreoffice that option does exist.

I re-installed the Libreoffice suite and the printing problem still exists.

Version: 6.4.5.2
Build ID: 1:6.4.5-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 BogdanB 2020-09-21 12:41:20 UTC
Could you print Ok from any other software?...

Try to print a JPG file, try to print a PDF file. If just LibreOffice deson't print correct please came back with your answer.
Comment 2 realtime 2020-09-22 18:49:56 UTC
I found a workaround which is faster for me than documenting bugs.  I found I could print PDF files and since I could not convert an ODT file to a PDF in LibreOffice ( I got a few red boxes and red lines when I tried)  and the more I looked into it the more bugs I found.  I tried a few times to convert to PDF format.  I did not want to document any more bugs.  I imported an ODT file into Google Drive, converted it to a PDF, and printed it, and it worked.  The Brother printer has very good quality and there is an apparent loss of quality, but I do not want to study it. I am having trouble scanning with the printer and to document it I might have to scan the document unless I can print to a file, which I tried a couple of times and did not want to work on that problem.
Comment 3 Michael Weghorn 2020-09-23 06:03:41 UTC
(In reply to realtime from comment #0)
> I re-installed the Libreoffice suite and the printing problem still exists.
> 
> Version: 6.4.5.2
> Build ID: 1:6.4.5-0ubuntu0.20.04.1
> CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5; 
> Locale: en-US (en_US.UTF-8); UI-Language: en-US
> Calc: threaded

This is using the plain qt5 VCL plugin, which is experimental and not meant for production use, and is never used by default unless you (or your distro) sets environment variable SAL_USE_VCPLUGIN=qt5. What distro and desktop environment are you using?

Does it work if you start LibreOffice with the environment variable SAL_VCL_QT5_USE_CAIRO=1 set in addition? (That should give you an experience similar to using the kf5 VCL plugin.)

Your issue sounds sounds similar to tdf#132569, tdf#128470 and tdf#125234, so might already be fixed in the current development version, "master". Can you please retry with a current daily build from [1], which you can install in parallel as described at [2]?

[1] https://dev-builds.libreoffice.org/daily/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 4 QA Administrators 2021-03-23 04:21:47 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2021-04-23 04:01:42 UTC
Dear realtime,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp