Bug 136982 - copy/paste and bulleted text
Summary: copy/paste and bulleted text
Status: RESOLVED DUPLICATE of bug 105550
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: LG
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-23 16:54 UTC by LG
Modified: 2021-04-26 09:55 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
a part of my text file (89.24 KB, application/vnd.oasis.opendocument.text)
2020-10-09 10:08 UTC, LG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LG 2020-09-23 16:54:29 UTC
Description:
I defined a style named "puce-1" as bullet+indentation (before text = 3 cm and first line = -0.4 cm).
It works fine when I enter text from the keyboard but if I copy and paste a previous text of this style, the new text is aligned with the left margin of the page. Applying the style again doesn't change anything.

After investigation, the copied text style has changed : the value of before text is set to 0.40 cm instead of 3 cm, the value of first line remains at -0.40 cm.

I used the InsideClipboard tool from Nirsoft to verify the clipboard content : the HTML version of the content seems to be correct : 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>
	<meta http-equiv="content-type" content="text/html; charset=utf-8"/>
	<title></title>
	<meta name="generator" content="LibreOffice 7.0.0.2 (Windows)"/>
	<meta name="created" content="00:00:00"/>
	<meta name="changed" content="00:00:00"/>
	<style type="text/css">
		@page { size: 21cm 29.7cm; margin: 2cm }
		p.puce-1 { margin-left: 3cm; text-indent: -0.4cm; direction: inherit; line-height: 120% }
		p.paragraphe { text-indent: 1.3cm; direction: inherit; line-height: 120% }
		p { margin-bottom: 0.25cm; line-height: 115%; text-align: justify; background: transparent }
		a:visited { color: #800000; so-language: zxx; text-decoration: underline }
		a:link { color: #000080; so-language: zxx; text-decoration: underline }
	</style>
</head>
<body lang="fr-FR" link="#000080" vlink="#800000" dir="ltr">
<ul><li><p class="puce-1">Fixer le HPA à 10 Go de manière volatile
	(perdu au redémarrage)</p>
</ul>
</body>
</html>

I don't know if it is the same problem but I can't increase or decrease the indent of this text with the toolbar buttons : only the bullet changes. I have to click on the Toggled Bulleted List button to take the control of the text... When the text is manually bulleted, the style cannot be applied = no effect.

When I made a test from a new file in order to write a procedure to reproduce the problem, many problems occurs with bullets but sometimes it works... I was able to reproduce the problem without creating a style but only by changing the paragraph settings.

Finally it's hard to write a procedure to reproduce the problem but I see a general problem : what properties are really apply when a style is applied. On a bulleted text, you can apply "text body" style as so many times you want without being able to remove the bullet... Even the clear formatting has no effect


Steps to Reproduce:
1.create a new file
2.type "example text" on first line
3.right click on the text and open the paragraph properties window.
4.set before text to 3 cm and first line to -0.4 cm
5.set numbering style to the bullet
6.click on ok
7.the text is misaligned
8.open the paragraph properties window : before text is set to 0.4 cm



Actual Results:
"before text" is set to 0.4 cm instead of 3 cm

Expected Results:
"before text" = 3 cm


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 7.0.0.2 (x64)
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: en-US
Calc: CL
Comment 1 Timur 2020-09-25 18:56:51 UTC
Rule of thumb is search before report, did you find an existing bug?
Comment 2 LG 2020-09-26 13:56:59 UTC
I plead guilty: no ...
But in my defense, these problems do not date from today.
Comment 3 LG 2020-09-26 14:12:06 UTC
OK. The indentation bug was report as Bug 77651.
Comment 4 Timur 2020-10-07 09:56:26 UTC
Please write if this is a duplicate or there's something else? 
If there is please attach the minimal sample.
Comment 5 LG 2020-10-09 10:08:43 UTC
Created attachment 166231 [details]
a part of my text file
Comment 6 LG 2020-10-09 10:15:15 UTC
Now I use libreoffice for my technical documentations.

It's difficult because I see many little issues with styles : when I try to find a reproductible way to describe the problem, I get another problem... 

I upgraded LO to 7.0.1.2 few days ago.

The uploaded file is a little part of a file where I see the problem :
1. Open the file
2. triple-click on the first bulleted text "Corruption du MBR"
3. ctrl-c
4. put the cursor at the end of the list
5. enter to add a new bullet entry
6. ctrl-v
7. the text is misaligned
Comment 7 QA Administrators 2020-10-10 04:18:57 UTC Comment hidden (obsolete)
Comment 8 Amanda 2020-10-29 12:51:32 UTC Comment hidden (spam)
Comment 9 Timur 2020-10-29 13:41:39 UTC
I confirm Comment 6, not clear why not marked duplicate, I do it.

*** This bug has been marked as a duplicate of bug 77651 ***
Comment 10 Timur 2021-04-26 09:55:46 UTC
Repro 7.2+ so not a duplicate of bug 77651. Let's duplicate to another.

*** This bug has been marked as a duplicate of bug 105550 ***