Bug 77651 - Highlight, cut & paste from a bullet list to same list changes indent of pasted line (moving line)
Summary: Highlight, cut & paste from a bullet list to same list changes indent of past...
Status: RESOLVED DUPLICATE of bug 101534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: Paste Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2014-04-18 17:06 UTC by bugcatcher1
Modified: 2021-04-26 09:47 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Bullet list from document where this problem was first observed (35.75 KB, application/vnd.oasis.opendocument.text)
2014-04-18 17:06 UTC, bugcatcher1
Details
writer document containing styled paragraphs which get deformed upon past operation (11.51 KB, application/vnd.oasis.opendocument.text)
2020-10-12 09:21 UTC, Christian Lehmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugcatcher1 2014-04-18 17:06:31 UTC
Created attachment 97567 [details]
Bullet list from document where this problem was first observed

Not the same as Bug 64744.

I have a bullet list. I want to move one line in that list to another position in that list. 

1. First insert a blank line at the top of the paragraph:
2. Take the desired line: highlight it, cut it, and paste it into the blank line.
3. Indentation is changed for that line (indentation decreased, and cannot be fixed by using standard "decrease indentation" command.

See attached document for actual bullet list and results
Comment 1 tommy27 2014-04-23 12:43:43 UTC
reproducible in Win7x64 using LibO 4.2.3.3
status --> NEW 
platform --> ALL
Comment 2 QA Administrators 2016-02-21 08:38:21 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2017-03-06 16:13:52 UTC Comment hidden (obsolete)
Comment 4 Dieter 2018-01-02 15:05:34 UTC
Still reproducible in

Version: 5.4.3.2 (x64)
Build-ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 5 Buovjaga 2018-01-07 14:59:45 UTC
Also repro in
Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: e1fb3d95ac6d58b60448981e82d90621cad7fea5
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on January 7th 2018

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

(I was testing another bullets + pasting bug)
Comment 6 jn 2018-07-14 08:10:53 UTC
I have this problem, on Linux Mint, some versions of Writer later (I have 6.0.5.2), four years later, and it seems to be that this problem is elementary and gross and is a major blow against Writer's usability.
Comment 7 QA Administrators 2019-07-15 02:48:07 UTC Comment hidden (obsolete)
Comment 8 Heiko Tietze 2020-03-16 13:18:58 UTC
*** Bug 105550 has been marked as a duplicate of this bug. ***
Comment 9 Heiko Tietze 2020-03-16 13:21:24 UTC
Xisco, please have a look at this topic. I raised the importance because many user face this issue with a good likelihood. There might be some more reports, didn't check everything.
Comment 10 Xisco Faulí 2020-03-19 15:41:12 UTC
This issue seems similar to bug 128046. is it still reproducible in a master build ?
Comment 11 Ulrich Gemkow 2020-03-19 20:05:32 UTC
At least Bug 105550 is still reproducible in todays master

Version: 7.0.0.0.alpha0+
Build ID: 2ecb785cd5a455367ea70662f95067e1bfba7bfc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: de-DE (en_US.utf-8); UI-Language: en-US
Calc: threaded
Comment 12 Christian Lehmann 2020-10-12 09:21:21 UTC
Created attachment 166292 [details]
writer document containing styled paragraphs which get deformed upon past operation
Comment 13 Christian Lehmann 2020-10-12 09:22:38 UTC
Months ago, I had submitted a test file to show that this bug has persisted through versions 6 and 7 of LO. I append the file here again; please convince yourselves.

It is just another symptom of the more basic design mistake of not distinguishing between properties of blocks and properties of elements contained in them: Under unclear conditions, the former are - mistakenly - stored as properties of the latter. I had reported on this long ago; but that report can no longer be found in the bugs list, nor has anybody attended to it.
Comment 14 Buovjaga 2020-10-12 09:30:01 UTC
(In reply to Christian Lehmann from comment #13)
> Months ago, I had submitted a test file to show that this bug has persisted
> through versions 6 and 7 of LO. I append the file here again; please
> convince yourselves.
> 
> It is just another symptom of the more basic design mistake of not
> distinguishing between properties of blocks and properties of elements
> contained in them: Under unclear conditions, the former are - mistakenly -
> stored as properties of the latter. I had reported on this long ago; but
> that report can no longer be found in the bugs list, nor has anybody
> attended to it.

Reports are not deleted. All the reports you created or commented on are here: https://bugs.documentfoundation.org/buglist.cgi?email1=christianw_lehmann%40arcor.de&emailassigned_to1=1&emaillongdesc1=1&emailreporter1=1&emailtype1=substring&list_id=1214392&query_format=advanced
Comment 15 Christian Lehmann 2020-10-12 16:20:28 UTC
Thanks for taking this up. This is not the list that I get when pressing 'My Bugs'. I apparently had unrealistic expectations about the function of this button.
Comment 16 Timur 2020-10-29 13:41:39 UTC
*** Bug 136982 has been marked as a duplicate of this bug. ***
Comment 17 Timur 2021-04-26 09:42:59 UTC
Fixed ago in 6.1. 
This was first report but now I'll mark as a duplicate of the one where fixed, regardless it's later.

*** This bug has been marked as a duplicate of bug 101534 ***
Comment 18 Timur 2021-04-26 09:47:24 UTC
I bisected for a bug with the fix. 
I'll check duplicates here.