Bug 64744 - EDITING: Indentation corrupted after copy -> paste
Summary: EDITING: Indentation corrupted after copy -> paste
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-18 21:07 UTC by Ulf Zibis
Modified: 2015-05-18 00:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example Document (11.52 KB, application/rtf)
2013-05-18 21:07 UTC, Ulf Zibis
Details
character after the enumeration digit is not correctly displayed (4.60 KB, image/png)
2014-01-09 21:29 UTC, Ulf Zibis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulf Zibis 2013-05-18 21:07:59 UTC
Created attachment 79506 [details]
Example Document

Problem description: 

Steps to reproduce:
1. open attached document
2. mark red highlighted "Heizkostenverbrauchsmessgeräte" by double-click + Ctrl-C
3. go to end of text anf Ctrl-V

Current behavior:
Whole paragraph becomes indented +0.32 cm.

Expected behavior:
Existing indentation should not be corrupted.
              
Operating System: Windows XP
Version: 4.0.3.3 release
Comment 1 Cor Nouws 2013-05-18 23:16:02 UTC
thanks for reporting Ulf.

Quite 'interesing' to test this file over various versions of LibreOffice...

- In 3.3.0 and 3.4.x there were other special effects;
- Any word that is copied-pasted at the end, gives the same behaviour
  looks as if the indent (of numbering or such) is copied as well and added with the paste

- workaround: Ctrl-Z (Undo) directly after the paste.
Comment 2 Jacek Wolszczak 2013-05-30 11:23:43 UTC
There is a difference between how Word and Writer handle copy/pasting of bullet items.

In Word, depending on how bullet item is copy/pasted:
- When you copy the whole bullet item (along with line break character), the pasted text will also be a bullet item;
- If you copy only a piece of bullet item (without line break character) and paste it, the text will retain the original formatting (font size, undelined, italics, etc.) but will not be a bullet item anymore. 

I understand that in Word when copying bullet item without line break character some "bullet item flag" is automatically set to false.

In LibreOffice no matter how you copy bullet item (with line break character or without it) the "bullet item flag" is not changed (is always true). So I'm guessing that while pasting the text, LO tries to set the "bullet item flag" true (which it already is) and as a result also unnecessarily increases indent.
Comment 3 Ulf Zibis 2014-01-09 21:29:55 UTC
Created attachment 91784 [details]
character after the enumeration digit is not correctly displayed

(In reply to comment #1)
> - workaround: Ctrl-Z (Undo) directly after the paste.

I tried again with 4.1.4.2 on Ubuntu 12.04 x64.
UnDo does not help here, it undo's the complete paste.

(I can also reproduce the erroneous behaviour with ODT file.)

Additionally, the supplemental character after the enumeration digit is not correctly displayed at Ubuntu.
Comment 4 tommy27 2014-04-23 12:40:49 UTC
reproducible in Win7x64 using LibO 4.2.3.3
platform --> ALL
Comment 5 Gordo 2015-05-18 00:48:49 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

4.3.6.2

Bug present in 4.2.8.2.

Changed to RESOLVED WORKSFORME.