Bug 137301 - PDF export cannot embed OpenType CFF2 (Variable PostScript / .otf) fonts
Summary: PDF export cannot embed OpenType CFF2 (Variable PostScript / .otf) fonts
Status: RESOLVED DUPLICATE of bug 103596
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering PDF-Export
  Show dependency treegraph
 
Reported: 2020-10-07 00:49 UTC by João Paulo
Modified: 2021-07-29 04:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Small Writer document formatted with Source Serif Variable (34.17 KB, application/vnd.oasis.opendocument.text)
2020-10-07 00:49 UTC, João Paulo
Details
PDF made with the attached Writer document and Export to PDF function (15.06 KB, application/pdf)
2020-10-07 00:50 UTC, João Paulo
Details
PDF made with the attached Writer document and print with Microsoft Print to PDF virtual printer (277.54 KB, application/pdf)
2020-10-07 00:51 UTC, João Paulo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description João Paulo 2020-10-07 00:49:18 UTC
Created attachment 166140 [details]
Small Writer document formatted with Source Serif Variable

Running LibreOffice 6.4.6.2 64 bits and LibreOffice Portable 7.0.1.2 32 bits, both on Windows 10, version 2004, 64 bits:

Versão: 6.4.6.2 (x64)
ID de compilação: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
Threads da CPU: 8; SO: Windows 10.0 Build 19041; Realizador da interface: padrão; VCL: win; 
Local: pt-BR (pt_BR); Idioma de IU: pt-BR
Calc: threaded

Version: 7.0.1.2 (x86)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: pt-BR (pt_BR); UI: en-US
Calc: CL

On Windows, install Adobe Source Serif OpenType Variable CFF2 fonts (.otf extension), Version 3.001, available at "https://github.com/adobe-fonts/source-serif-pro/releases".  They are at "source-serif-pro-3.001R.zip\source-serif-pro-3.001R\VAR\*.otf" and they appear on the typeface selection menu as "Source Serif Variable", not as "Source Serif Pro".

Create a new Writer document and format it with Source Serif Variable, then try to export it as PDF.  The glyphs from Source Serif Variable, CFF2 fonts (.otf extension), are not exported to the PDF file.

Printing with Microsoft Print to PDF virtual printer works fine, but then all bookmarks, tagging and nice things with "Export to PDF" such as Hybrid PDF don't work.

There is a workaround:  Remove the OpenType Variable CFF2 fonts (.otf extension) and install the OpenType Variable TrueType fonts (.ttf extension).  However, TrueType fonts aren't as good for printing than the CFF2 (PostScript outlines / .otf extension), so the exported PDF isn't as good for printing or reading on very high DPI screens as those on eBook readers and mobile phones (unless printed with Microsoft Print to PDF virtual printer, and then they lose all the nice options the PDF export can do with the PDF).

Please enhance PDF export to also work with OpenType Variable CFF2 (PostScript outlines / .otf extension).  OpenType with TrueType outlines (quadratic bezier curves) may be good for low DPI screens, but OpenType with PostScript outlines (cubic bezier curves) are better for printing and very high DPI screens found on mobile phones and specialized eBook readers.
Comment 1 João Paulo 2020-10-07 00:50:53 UTC
Created attachment 166141 [details]
PDF made with the attached Writer document and Export to PDF function
Comment 2 João Paulo 2020-10-07 00:51:52 UTC
Created attachment 166142 [details]
PDF made with the attached Writer document and print with Microsoft Print to PDF virtual printer
Comment 3 João Paulo 2020-10-09 19:10:54 UTC
I have to add that OpenType with TrueType outlines can be losslessly converted to OpenType with PostScript outlines, but the reverse is not true.  That's another reason why PDF Export should be able to embedd OpenType CFF2/Variable Fonts.
Comment 4 V Stuart Foote 2021-07-28 13:05:44 UTC
There is no LibreOffice support for OTF Variable fonts -- see also bug 103596

IMHO => NAB
Comment 5 V Stuart Foote 2021-07-28 14:26:21 UTC

*** This bug has been marked as a duplicate of bug 103596 ***