Bug 137393 - Add New Noto CJK font names(V2.001) in front of the previous Noto CJK font names for CJK locale on VCL.xcu
Summary: Add New Noto CJK font names(V2.001) in front of the previous Noto CJK font na...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Kevin Suo
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords:
Depends on:
Blocks: CJK Fonts-Locale
  Show dependency treegraph
 
Reported: 2020-10-11 13:51 UTC by DaeHyun Sung
Modified: 2020-10-18 03:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
System and font information Fedora 32 (12.77 KB, text/plain)
2020-10-12 07:53 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DaeHyun Sung 2020-10-11 13:51:41 UTC
Description:
Update Noto CJK fonts for CJK locale

Following my issue tdf#137392  
In Korean situation, I follow up New Noto CJK fonts(v2.001)

New Noto Sans CJK V2.001 released on 10 Apr 2019.

At that version, It supported SC(Simplified Chinese), TC(Traditional Chinese), JP(Japanese), KR(Korean)  and new HK(Hong Kong) Version.
e.g. 'Noto Sans Mono CJK {HK, JP, KR, SC, TC}'.
At that version support Japanese new era 令和 (reiwa) & Unicode 12.1.

Also, Font file names changed,
For example)
Noto Sans CJK KR => Noto Sans KR
Noto Serif CJK KR => Noto Serif KR
Noto Sans CJK JP => Noto Sans JP
Noto Serif CJK JP => Noto Serif JP
Noto Sans CJK SC => Noto Sans SC
Noto Serif CJK SC => Noto Serif SC
Noto Sans CJK TC => Noto Sans TC
Noto Serif CJK TC => Noto Serif TC
New)
Noto Sans HK, Noto Serif HK

Nowadays, New Linux distributions includes Noto CJK font V2.0.
In Korean Linux environments, Noto CJK font v2.0 'Noto Sans KR' & 'Noto Serif KR' are already set default.
So, In my opinion, CJK Linux environments, Noto CJK font v2.0 is default 
(Noto Sans JP, Noto Sans SC, Noto Sans TC, Noto Sans HK, Noto Serif JP, Noto Serif SC, Noto Serif TC, Noto Serif HK etc.)  

When I modified the file `officecfg/registry/data/org/openoffice/VCL.xcu`, 
Many of CJK font locale only supported Noto CJK v1 file names.
For example) Noto Serif CJK SC, Noto Serif CJK JP, Noto Sans CJK TC Noto Sans CJK JP, etc.

So, I suggest to add New Noto CJK Fonts on the `officecfg/registry/data/org/openoffice/VCL.xcu` in CJK Locale settings


Actual Results:
In Japanese Environment on LibreOffice 
      <prop oor:name="CJK_HEADING" oor:type="xs:string" oor:op="replace">
        <value>Noto Sans CJK JP;游ゴシック;MS ゴシック;MS Pゴシック;ヒラギノ角ゴシック;ヒラギノ角ゴ ProN;ヒラギノ角ゴ Pro;IPA ゴシック;IPA Pゴシック;Gothic;MS 明朝;Mincho;MS P明朝;Gothic</value>
      </prop>

In Simplified Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang SC;华文细黑;STXihei;Arial Unicode MS;Tahoma</value>
      </prop>
In Traditional Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑體;Source Han Sans TC;Noto Sans CJK TC;蘋方-繁;PingFang TC;儷黑 Pro;LiHei Pro;微軟正黑體;Microsoft JhengHei;新細明體;PMingLiU;Arial Unicode MS;Tahoma</value>
      </prop>

Expected Results:
      <prop oor:name="CJK_HEADING" oor:type="xs:string" oor:op="replace">
        <value>Noto Sans JP;Noto Sans CJK JP;游ゴシック;MS ゴシック;MS Pゴシック;ヒラギノ角ゴシック;ヒラギノ角ゴ ProN;ヒラギノ角ゴ Pro;IPA ゴシック;IPA Pゴシック;Gothic;MS 明朝;Mincho;MS P明朝;Gothic</value>
      </prop>
In Simplified Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans SC;Noto Sans CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang SC;华文细黑;STXihei;Arial Unicode MS;Tahoma</value>
      </prop>
In Traditional Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑體;Source Han Sans TC;Noto Sans TC;Noto Sans CJK TC;蘋方-繁;PingFang TC;儷黑 Pro;LiHei Pro;微軟正黑體;Microsoft JhengHei;新細明體;PMingLiU;Arial Unicode MS;Tahoma</value>
      </prop>


Reproducible: Always


User Profile Reset: No



Additional Info:
Google Noto CJK fonts Repository: https://github.com/googlefonts/noto-cjk
Comment 1 Kevin Suo 2020-10-12 01:01:07 UTC
+1

I am not quite sure, but the code seems to be located at:
path: root/officecfg/registry/data/org/openoffice/VCL.xcu
Comment 2 Ming Hua 2020-10-12 01:18:02 UTC
Kevin, when adding needsUXEval keyword, please also add the UX mailing list to CC (see https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Keywords#needsUXEval), otherwise the UX team won't see it.
Comment 3 Heiko Tietze 2020-10-12 07:23:52 UTC
Noto fonts from https://www.google.com/get/noto/ (all) contain ttf's from Sep/20 2017. And the fonts in our list have the same data. Plus, I don't see any *CJK fonts there. Not sure what exactly we can have to update.
Comment 4 Kevin Suo 2020-10-12 07:47:31 UTC
(In reply to Heiko Tietze from comment #3)

Heiko: This ticket is talking about Noto {Sans, Serif} CJK {SC, TC, KR, JP} fonts, as listed in: https://www.google.cn/get/noto/ . I do see google has issued various fonts named Noto.

DaeHyun Sung: The reason you propose the update is that, in the new font version the font names are changed (i.e., the string "CJK" is removed). However, I do not see this change on my Fedora 32 system, see the attached. Could you please give a link showing the change of font names? I am not sure whether the change was due to the fontconfig settings on your Linux distribution, or the change in the font itself.
Comment 5 Kevin Suo 2020-10-12 07:53:28 UTC
Created attachment 166288 [details]
System and font information Fedora 32
Comment 6 Heiko Tietze 2020-10-12 08:59:24 UTC
(In reply to Kevin Suo from comment #4)
> (In reply to Heiko Tietze from comment #3)
> 
> Heiko: This ticket is talking about Noto {Sans, Serif} CJK {SC, TC, KR, JP}
> fonts, as listed in: https://www.google.cn/get/noto/ . 

I'm talking about what we have at the source code, which is this https://dev-www.libreoffice.org/src/noto-fonts-20171024.tar.gz
Comment 7 Ming Hua 2020-10-12 09:26:41 UTC
(In reply to Heiko Tietze from comment #6)
> (In reply to Kevin Suo from comment #4)
> > (In reply to Heiko Tietze from comment #3)
> > 
> > Heiko: This ticket is talking about Noto {Sans, Serif} CJK {SC, TC, KR, JP}
> > fonts, as listed in: https://www.google.cn/get/noto/ . 
> 
> I'm talking about what we have at the source code, which is this
> https://dev-www.libreoffice.org/src/noto-fonts-20171024.tar.gz
I don't believe DaeHyun was talking about the Noto fonts bundled with LO, but about references to other fonts that's commonly installed on various OSes, which LO users prefer (usually because that's the default UI font for the whole OS of their language).  For example:

(In reply to DaeHyun Sung from comment #0)
> In Simplified Chinese Environment on LibreOffice
>       <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
>         <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans
> CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang SC;华文细黑;STXihei;Arial
> Unicode MS;Tahoma</value>
>       </prop>
Here it mentions "Microsoft Yahei", which is the default S-Chinese font for Windows, and I assume "PingFang SC" or "STXihei" is for macOS.

As for the "Noto Sans CJK {KR,JP,SC,TC}" font this bug is about, it's the only open source font available with pretty much universal coverage for all CJK characters, so I assume it's packaged and installed in most Linux distros these days.
Comment 8 Heiko Tietze 2020-10-12 09:28:53 UTC
(In reply to Ming Hua from comment #7)
> ... so I assume it's packaged and installed in most Linux
> distros these days.

Meaning NOTOURBUG.
Comment 9 Ming Hua 2020-10-12 10:33:26 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Ming Hua from comment #7)
> > ... so I assume it's packaged and installed in most Linux
> > distros these days.
> 
> Meaning NOTOURBUG.
No.

If the Noto CJK fonts installed on Linux systems changed their name (still not clear if that's the case, per comment #4), it is defintely our bug -- well, our enhancement request to be exact -- to make sure our references match the new font name, isn't it?
Comment 10 Kevin Suo 2020-10-12 11:13:57 UTC
The VCL.xcu settings was modified to fix an enhacenent request (bug 114768, bug 114751, bug 125481, etc.) to use better default opensouce fonts for CJK environment some years ago.

If the upstream font names did change, then our VCL.xcu should be adjusted accordingly as well. However, the first thing is to confirm that the font names did change, as discussed in comment 4 above.

Awaiting DaeHyun Sung's feedback. If it really changed, then one proposal is to add the new font names in the list (I can prepare a patch and submit to gerrit), rather than delete the old ones, to make sure the settings work in both old and new environments.
Comment 11 DaeHyun Sung 2020-10-12 15:42:54 UTC
(In reply to Kevin Suo from comment #10)
> The VCL.xcu settings was modified to fix an enhacenent request (bug 114768,
> bug 114751, bug 125481, etc.) to use better default opensouce fonts for CJK
> environment some years ago.
> 
> If the upstream font names did change, then our VCL.xcu should be adjusted
> accordingly as well. However, the first thing is to confirm that the font
> names did change, as discussed in comment 4 above.
> 
> Awaiting DaeHyun Sung's feedback. If it really changed, then one proposal is
> to add the new font names in the list (I can prepare a patch and submit to
> gerrit), rather than delete the old ones, to make sure the settings work in
> both old and new environments.

Your opinion is good well.
> If it really changed, then one proposal is to add the new font names in the list 

In my opinion, To clarify the meaning, I have to change the bug title, 'update' to 'add' on my issue title


change the Title: add New Noto CJK fonts(V2.001) in front of the previous Noto CJK font for CJK locale on VCL.xcu 

I'm openSUSE Tumbleweed user.

openSUSE Tumbleweed's google noto sans cjk fonts & google noto serif cjk fonts are updated new Version (V2.001)
The new version changed some font names, "Noto {Sans, Serif} CJK {SC, TC, KR, JP} fonts" to  "Noto {Sans, Serif} {SC, TC, HK, KR, JP} fonts".

Noto CJK Font's repository link is here: 
https://github.com/googlefonts/noto-cjk
and latest Noto Sans CJK release version is V2.001
https://github.com/googlefonts/noto-cjk/releases/tag/NotoSansV2.001 

below links are Google Noto CJK fonts for openSUSE Tumbleweeds
google-noto-sans-cjk-fonts 
- Update version to 2.001(20190410) (forwarded request 795506 from hillwood)
https://build.opensuse.org/package/show/openSUSE%3AFactory/google-noto-sans-cjk-fonts
google-noto-serif-cjk-fonts 
- updated by OSRT tools (host ani)
https://build.opensuse.org/package/show/openSUSE:Factory/google-noto-serif-cjk-fonts


These packages includes new Noto CJK Fonts (v2.001)
and changed names and split HK fonts
"Noto {Sans, Serif} CJK {SC, TC, KR, JP} fonts" to  "Noto {Sans, Serif} {SC, TC, HK, KR, JP} fonts"
These are Noto CJK Font's change logs
https://build.opensuse.org/package/view_file/openSUSE:Factory/google-noto-sans-cjk-fonts/google-noto-sans-cjk-fonts.changes?expand=1
https://build.opensuse.org/package/view_file/openSUSE:Factory/google-noto-serif-cjk-fonts/google-noto-serif-cjk-fonts.changes?expand=1

So, Add "Noto {Sans, Serif} {SC, TC, HK, KR, JP} fonts" in front of  "Noto {Sans, Serif} CJK {SC, TC, KR, JP} fonts"  on VCL.xcu

Below is my suggestions.
 In Japanese Environment on LibreOffice 
      <prop oor:name="CJK_HEADING" oor:type="xs:string" oor:op="replace">
        <value>Noto Sans CJK JP;游ゴシック;MS ゴシック;MS Pゴシック;ヒラギノ角ゴシック;ヒラギノ角ゴ ProN;ヒラギノ角ゴ Pro;IPA ゴシック;IPA Pゴシック;Gothic;MS 明朝;Mincho;MS P明朝;Gothic</value>
      </prop>

In Simplified Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang SC;华文细黑;STXihei;Arial Unicode MS;Tahoma</value>
      </prop>
In Traditional Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑體;Source Han Sans TC;Noto Sans CJK TC;蘋方-繁;PingFang TC;儷黑 Pro;LiHei Pro;微軟正黑體;Microsoft JhengHei;新細明體;PMingLiU;Arial Unicode MS;Tahoma</value>
      </prop>

Expected Results:
      <prop oor:name="CJK_HEADING" oor:type="xs:string" oor:op="replace">
        <value>Noto Sans JP;Noto Sans CJK JP;游ゴシック;MS ゴシック;MS Pゴシック;ヒラギノ角ゴシック;ヒラギノ角ゴ ProN;ヒラギノ角ゴ Pro;IPA ゴシック;IPA Pゴシック;Gothic;MS 明朝;Mincho;MS P明朝;Gothic</value>
      </prop>
In Simplified Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans SC;Noto Sans CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang SC;华文细黑;STXihei;Arial Unicode MS;Tahoma</value>
      </prop>
In Traditional Chinese Environment on LibreOffice
      <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
        <value>思源黑體;Source Han Sans TC;Noto Sans TC;Noto Sans CJK TC;蘋方-繁;PingFang TC;儷黑 Pro;LiHei Pro;微軟正黑體;Microsoft JhengHei;新細明體;PMingLiU;Arial Unicode MS;Tahoma</value>
      </prop>
Comment 12 DaeHyun Sung 2020-10-12 15:50:46 UTC
Several Linux distros, Windows and MacOS users already use old Noto CJK Fonts.
I think The new Noto CJK fonts(V2.001) seems to only apply to Linux rolling release distros such as openSUSE Tumbleweeds, Arch Linux, Manjaro, Gentoo, etc.

So, Add "Noto {Sans, Serif} {SC, TC, HK, KR, JP} fonts"(New Noto CJK Fonts, V2.001) in front of the previous  "Noto {Sans, Serif} CJK {SC, TC, KR, JP} fonts"(Default Noto CJK fonts)  on VCL.xcu.

(In reply to DaeHyun Sung from comment #11)
> (In reply to Kevin Suo from comment #10)
> > The VCL.xcu settings was modified to fix an enhacenent request (bug 114768,
> > bug 114751, bug 125481, etc.) to use better default opensouce fonts for CJK
> > environment some years ago.
> > 
> > If the upstream font names did change, then our VCL.xcu should be adjusted
> > accordingly as well. However, the first thing is to confirm that the font
> > names did change, as discussed in comment 4 above.
> > 
> > Awaiting DaeHyun Sung's feedback. If it really changed, then one proposal is
> > to add the new font names in the list (I can prepare a patch and submit to
> > gerrit), rather than delete the old ones, to make sure the settings work in
> > both old and new environments.
> 
> Your opinion is good well.
> > If it really changed, then one proposal is to add the new font names in the list 
> 
> In my opinion, To clarify the meaning, I have to change the bug title,
> 'update' to 'add' on my issue title
> 
> 
> change the Title: add New Noto CJK fonts(V2.001) in front of the previous
> Noto CJK font for CJK locale on VCL.xcu 
> 
> I'm openSUSE Tumbleweed user.
> 
> openSUSE Tumbleweed's google noto sans cjk fonts & google noto serif cjk
> fonts are updated new Version (V2.001)
> The new version changed some font names, "Noto {Sans, Serif} CJK {SC, TC,
> KR, JP} fonts" to  "Noto {Sans, Serif} {SC, TC, HK, KR, JP} fonts".
> 
> Noto CJK Font's repository link is here: 
> https://github.com/googlefonts/noto-cjk
> and latest Noto Sans CJK release version is V2.001
> https://github.com/googlefonts/noto-cjk/releases/tag/NotoSansV2.001 
> 
> below links are Google Noto CJK fonts for openSUSE Tumbleweeds
> google-noto-sans-cjk-fonts 
> - Update version to 2.001(20190410) (forwarded request 795506 from hillwood)
> https://build.opensuse.org/package/show/openSUSE%3AFactory/google-noto-sans-
> cjk-fonts
> google-noto-serif-cjk-fonts 
> - updated by OSRT tools (host ani)
> https://build.opensuse.org/package/show/openSUSE:Factory/google-noto-serif-
> cjk-fonts
> 
> 
> These packages includes new Noto CJK Fonts (v2.001)
> and changed names and split HK fonts
> "Noto {Sans, Serif} CJK {SC, TC, KR, JP} fonts" to  "Noto {Sans, Serif} {SC,
> TC, HK, KR, JP} fonts"
> These are Noto CJK Font's change logs
> https://build.opensuse.org/package/view_file/openSUSE:Factory/google-noto-
> sans-cjk-fonts/google-noto-sans-cjk-fonts.changes?expand=1
> https://build.opensuse.org/package/view_file/openSUSE:Factory/google-noto-
> serif-cjk-fonts/google-noto-serif-cjk-fonts.changes?expand=1
> 
> So, Add "Noto {Sans, Serif} {SC, TC, HK, KR, JP} fonts" in front of  "Noto
> {Sans, Serif} CJK {SC, TC, KR, JP} fonts"  on VCL.xcu
> 
> Below is my suggestions.
>  In Japanese Environment on LibreOffice 
>       <prop oor:name="CJK_HEADING" oor:type="xs:string" oor:op="replace">
>         <value>Noto Sans CJK JP;游ゴシック;MS ゴシック;MS Pゴシック;ヒラギノ角ゴシック;ヒラギノ角ゴ
> ProN;ヒラギノ角ゴ Pro;IPA ゴシック;IPA Pゴシック;Gothic;MS 明朝;Mincho;MS P明朝;Gothic</value>
>       </prop>
> 
> In Simplified Chinese Environment on LibreOffice
>       <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
>         <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans
> CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang SC;华文细黑;STXihei;Arial
> Unicode MS;Tahoma</value>
>       </prop>
> In Traditional Chinese Environment on LibreOffice
>       <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
>         <value>思源黑體;Source Han Sans TC;Noto Sans CJK TC;蘋方-繁;PingFang TC;儷黑
> Pro;LiHei Pro;微軟正黑體;Microsoft JhengHei;新細明體;PMingLiU;Arial Unicode
> MS;Tahoma</value>
>       </prop>
> 
> Expected Results:
>       <prop oor:name="CJK_HEADING" oor:type="xs:string" oor:op="replace">
>         <value>Noto Sans JP;Noto Sans CJK JP;游ゴシック;MS ゴシック;MS
> Pゴシック;ヒラギノ角ゴシック;ヒラギノ角ゴ ProN;ヒラギノ角ゴ Pro;IPA ゴシック;IPA Pゴシック;Gothic;MS
> 明朝;Mincho;MS P明朝;Gothic</value>
>       </prop>
> In Simplified Chinese Environment on LibreOffice
>       <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
>         <value>思源黑体;Source Han Sans SC;思源黑体 CN;Source Han Sans CN;Noto Sans
> SC;Noto Sans CJK SC;微软雅黑;Microsoft Yahei;新宋体;NSimSun;萍方-简;PingFang
> SC;华文细黑;STXihei;Arial Unicode MS;Tahoma</value>
>       </prop>
> In Traditional Chinese Environment on LibreOffice
>       <prop oor:name="CJK_DISPLAY" oor:type="xs:string" oor:op="replace">
>         <value>思源黑體;Source Han Sans TC;Noto Sans TC;Noto Sans CJK
> TC;蘋方-繁;PingFang TC;儷黑 Pro;LiHei Pro;微軟正黑體;Microsoft
> JhengHei;新細明體;PMingLiU;Arial Unicode MS;Tahoma</value>
>       </prop>
Comment 13 Kevin Suo 2020-10-13 02:55:44 UTC
Patch submitted on gerrit for review:
https://gerrit.libreoffice.org/c/core/+/104222
Comment 14 Kevin Suo 2020-10-13 11:40:55 UTC
DaeHyun Sung:

Would you please download the following to see if the patch works for you?
https://go.suokunlong.cn:88/dl/libreoffice/dbg/2020-10-13/libreoffice-master-linux64-dbgutil-kevin-2020-10-13.zip

This version has zh-CN, zh-TW, and ja enabled. To test, just unzip and run "./instdir/program/soffice". It should work on your openSUSE Tumbleweed.
Comment 15 Commit Notification 2020-10-17 14:38:17 UTC
Kevin Suo committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2d1b5ecdf81d19993f2d9dd4f07521361fac4570

tdf#137393: Add "Noto {Sans, Serif} {SC,TC,HK,JP}" to the default font list

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-10-18 03:12:25 UTC
Kevin Suo committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/2de9e1afb81ab00167017f916b7a771653fc7eb6

tdf#137393: Add "Noto {Sans, Serif} {SC,TC,HK,JP}" to the default font list

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.