Bug 137781 - Image frame still present after cut (with tracking changes enabled)
Summary: Image frame still present after cut (with tracking changes enabled)
Status: RESOLVED DUPLICATE of bug 138253
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: Shape-Textbox
  Show dependency treegraph
 
Reported: 2020-10-26 22:11 UTC by Telesto
Modified: 2020-12-01 16:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (171.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-10-26 22:11 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-10-26 22:11:06 UTC
Description:
Image frame still present after cut (with tracking changes enabled)

Steps to Reproduce:
1. Open the attached file
2. Scroll to page 2
3. Select image frame 2
4. CTRL+X
5. CTRL+Z
6. CTRL+X again -> Text moves up image still visible

Got also 2 crashes.. when doing this.. but not proper STR

Actual Results:
Image still visible

Expected Results:
Not so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 94e6e140491de31c0788c91af855a75a3bb12709
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-10-26 22:11:24 UTC
Created attachment 166748 [details]
Example file
Comment 2 Telesto 2020-10-26 22:14:01 UTC
Also in 
6.3
Comment 3 Telesto 2020-10-26 22:14:49 UTC
Similar also in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 4 Telesto 2020-10-26 22:18:14 UTC
Crashes with 4.3
Comment 5 NISZ LibreOffice Team 2020-10-29 17:28:01 UTC
This got changed recently, in:

Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

Only one cut is enough to trigger the separation of shape and its textframe (since it's docx import, basically we have a shape + a textframe containing the image and its caption text: somehow the second cut does not affect the textframe).

About crashing the document; these steps seem to work in many cases (but not always... strange.):
* Select the first image+ frame, Cut, Undo, Cut
* File - Reload - No save
* Select the first images frame, Cut -> Crash

in: 
Version: 7.1.0.0.alpha1+ (x64)
Build ID: f27c4ec5c864395f4cdaec32d7e95ff24e4f43c8
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 6 NISZ LibreOffice Team 2020-10-29 18:23:07 UTC
Current behavior of cut-undo-cut started at:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=da4f9b77a6cd39b1ae5babdd476d1575c8b9371c

author	Miklos Vajna <vmiklos@collabora.com>	2020-09-07 21:23:07 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2020-09-08 09:11:24 +0200

tdf#135149 sw: fix deleting textbox of as-char shapes

However I would not call this a regression, was somewhat worse before. Just... still not perfect.

The instability seems to have a different source too, this commit does not crash like above in the 7.1 bibisect repo.
Comment 7 Xisco Faulí 2020-12-01 16:15:12 UTC
This issue got fixed by https://git.libreoffice.org/core/commit/42e8e16cf93dcf944e5c1106f76aaa32057c0397
Closing as dupe of bug 138253

*** This bug has been marked as a duplicate of bug 138253 ***