Bug 137808 - Rename "Track Changes" under "View" to "Tracked Changes"
Summary: Rename "Track Changes" under "View" to "Tracked Changes"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium enhancement
Assignee: Ayhan Yalçınsoy
URL:
Whiteboard: target:7.1.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2020-10-28 01:21 UTC by John
Modified: 2020-11-18 22:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2020-10-28 01:21:09 UTC
Description:
In Writer's menu bar, the option View > Track Changes is actually toggles the visibility of changes recorded using Edit > Track Changes

So I think that Track Changes under View should be renamed to Tracked Changes.

Currently, its name is misleading. At least to me. It looks like an option to enable/disable the recording of changes.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Heiko Tietze 2020-10-28 09:04:48 UTC
Rather "Show tracked changes". But we have two UNO commands defined, .uno:ShowTrackedChanges (FN_REDLINE_SHOW) and .uno:ViewTrackChanges that forwards to the other command but uses the short label. 

It was introduced with https://gerrit.libreoffice.org/c/core/+/23976 for bug 91781. But I don't see any good reason. Maybe "View" is the implicit action. And in fact, we do not use any "Show" in the menu items. 

IMHO, it's a good practice to use verbs. (Show/Edit) TC is a good example how the approach of short labels fails. OTOH, these repeated Show * looks also bad.
Comment 2 Roman Kuznetsov 2020-10-28 09:16:24 UTC
We have

Edit-Track changes-Show  
and
View-Track changes

and it's the same control.

I agree with John, but I suggest rename it to "View-Show Track changes"

From another side all items in the View menu toggle show-hide something...

Other opinions?
Comment 3 Adolfo Jayme 2020-11-04 10:18:17 UTC
Let’s consider that making everything “verb + noun” has implications on the way we translate these options to other languages.

Just having “Tracked Changes” instead of the current, awkward “Track Changes” would be a win for the Romance-language versions of LibreOffice, which currently have an idiomatic, not literal translation (because the English doesn’t make much sense) but is quite long, making the menus wider than usual.
Comment 4 Heiko Tietze 2020-11-09 16:22:22 UTC
We discussed the topic in the design meeting and decided to use "Show Tracked Changes" (for View > TC).

Code pointer:
officecfg/registry/data/org/openoffice/Office/UI/WriterCommands.xcu
Comment 5 Buovjaga 2020-11-09 17:46:40 UTC
I am unable to find occurrences of 'View - Track Changes' in Help, so it is a good moment in time to do the change. Preferably before Seth adds the old string into Help.
Comment 6 Commit Notification 2020-11-13 20:57:17 UTC
Ayhan Yalçınsoy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/471f2bf1ee9256f5b8196b6cc713666729654e59

tdf#137808: Renamed Track Changes as Show Tracked Changes

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.