Bug 137930 - Options: Apply button changes values to previous ones
Summary: Options: Apply button changes values to previous ones
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-11-02 11:03 UTC by Xisco Faulí
Modified: 2020-12-01 13:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-11-02 11:03:13 UTC
Steps to reproduce:
1. Open writer
2. Go to Tools - Options - LibreOffice Writer - General
3. Change measurement to something else.( e.g. Point )
4. Click on 'Apply'

-> Measurement units changes to the previous value

Reproduced in

Version: 7.1.0.0.alpha1+
Build ID: 35f7d9a18fa7f559a1427e1b8a0f094f864f945a
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-11-02 11:04:03 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=78c6e88e163f50eccc1cebdb2defe9ec4af248ce

author	Caolán McNamara <caolanm@redhat.com>	2020-10-29 16:56:54 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-10-29 21:22:25 +0100
commit	78c6e88e163f50eccc1cebdb2defe9ec4af248ce (patch)
tree	f47c86583210c0d16e5fed75eef32793cecd7d9e
parent	806c696ccdac69e274cbfeac0cb45ea59555c01d (diff)
have just the one handler for ok/apply options

Bisected with: bibisect-linux64-7.1

Adding Cc: to Caolán McNamara
Comment 2 Xisco Faulí 2020-11-06 16:46:28 UTC
Hi Caolán,
not sure if you are aware of this issue...
Comment 3 Xisco Faulí 2020-11-10 10:42:49 UTC
A similar issue caused by the same commit:

1. Open writer
2. Go to Tools - Options - Advanced
3. Check Enable experimental features
4. Click on 'Apply'
5. Restart now

-> Nothing happens
Comment 4 Commit Notification 2020-11-17 08:55:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/75bada928cf08d2afc6efe52ba99b45088bc9eec

tdf#137930 Apply button changes values to previous ones

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-11-17 12:02:45 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/52eb3091f5303c4f57e8d79cfa7bf0b973b68d1d

tdf#137930: uitest: Add assert to check values are not reset

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-11-17 16:51:35 UTC
Verified in

Version: 7.1.0.0.alpha1+
Build ID: 0979798658ff536defe537f57cc6b32278d32414
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!