Bug 137976 - Undo does not remove pasted images in Calc
Summary: Undo does not remove pasted images in Calc
Status: RESOLVED DUPLICATE of bug 39217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-04 03:37 UTC by tom
Modified: 2020-11-11 03:43 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tom 2020-11-04 03:37:18 UTC
Description:
When you copy/paste content from the web which includes text and images into Calc and then undo the last move, the images remain in calc.

Steps to Reproduce:
1. Copy the entire table from https://en.wikipedia.org/wiki/Red_states_and_blue_states#Table_of_presidential_elections_by_states_since_1972
2. Paste it into Calc. It will paste the text plus the images of the state flags
3. Undo by pressig CTRL-Z or by clicking the undo tile in the menu

Actual Results:
The pasted text is removed but the images with the state flags remain in the sheet.

Expected Results:
Everything that the last step did, which was pasting things into the sheet, should be removed again 100% after undoing the last step.


Reproducible: Always


User Profile Reset: No



Additional Info:
N/A
Comment 1 wingednova 2020-11-11 03:40:42 UTC
Reproduced, 
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-IN (en_IN); UI: en-US
Calc: threaded
Comment 2 wingednova 2020-11-11 03:43:43 UTC

*** This bug has been marked as a duplicate of bug 39217 ***