Bug 138040 - Libreoffice Writer Object : QR Code does not recognise "Line Break" nor “Column Break” which results in wrong QR code
Summary: Libreoffice Writer Object : QR Code does not recognise "Line Break" nor “Colu...
Status: RESOLVED DUPLICATE of bug 128718
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-06 14:15 UTC by Stijn J.L.L
Modified: 2020-11-14 17:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example : Object QR Code does not recognizse Line Break (245.14 KB, application/pdf)
2020-11-06 14:17 UTC, Stijn J.L.L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stijn J.L.L 2020-11-06 14:15:32 UTC
Description:
To create a QR for a european payment : https://en.wikipedia.org/wiki/EPC_QR_code
You need several lines of text, separated by "Line Break"
The LibreOffice object “QR Code” does not recognise “Line Break” after each line of text. It results in wrong QR. Every Line Break is ignored.
Banking-app-scan results in “General Error”.
The workaround "using the add-in extension goQR.me" also has a bug itself(places a space character in front of the text). And can not be automated in a macro.

It is important to recognise other characters like "New Line" to make it possible to create qr code for : Vcard, businescard, Configuration/installation options etc.
see : https://github.com/zxing/zxing/wiki/Barcode-Contents


Steps to Reproduce:
1. Select several lines of text separated by "Line Break" 
2. Click on Insert - Object - Qr Code
3. click OK
4. results in wrong QR

Actual Results:
Wrong QR

Expected Results:
Right QR


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Example in attachement
Comment 1 Stijn J.L.L 2020-11-06 14:17:39 UTC
Created attachment 167065 [details]
Example : Object QR Code does not recognizse Line Break

An example
Comment 2 Roman Kuznetsov 2020-11-14 17:15:15 UTC

*** This bug has been marked as a duplicate of bug 128718 ***