Bug 128718 - Accept texts with multiple line in the QR Code Generator
Summary: Accept texts with multiple line in the QR Code Generator
Status: RESOLVED DUPLICATE of bug 146395
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 135527 138040 (view as bug list)
Depends on:
Blocks: QR-code
  Show dependency treegraph
 
Reported: 2019-11-11 17:22 UTC by Volga
Modified: 2022-02-09 10:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Object "QR Code" does not recognise line breaks (245.14 KB, application/pdf)
2020-11-06 14:06 UTC, Stijn J.L.L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2019-11-11 17:22:29 UTC
Description:
LibreOffice added QR Code Generator in version 6.4, but the URL/Text field support only single line. It would be nice if this field support texts with more than one line.

See: https://helpx.adobe.com/indesign/using/generate-qr-code.html

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-11-13 11:23:05 UTC
Agree. But I think it's an enhancement
Comment 2 Volga 2019-11-13 13:55:45 UTC
Yeah with this support it’s possible to accept one of following content formats:
https://github.com/zxing/zxing/wiki/Barcode-Contents
Comment 3 Mike Kaganski 2020-08-07 10:50:39 UTC
*** Bug 135527 has been marked as a duplicate of this bug. ***
Comment 4 rim 2020-08-14 07:43:36 UTC
(In reply to Volga from comment #2)
> Yeah with this support it’s possible to accept one of following content
> formats:
> https://github.com/zxing/zxing/wiki/Barcode-Contents

Agree, but don't limit the options to only these formats.
E.g. SEPA SCT als a standard format for European payment requests.
Comment 5 Stijn J.L.L 2020-11-06 14:06:15 UTC
Created attachment 167064 [details]
Object "QR Code" does not recognise line breaks

example of QR use for european SEPA mobile payment. Which can not be created with libreoffice object "QR Code"
Comment 6 Volga 2020-11-08 09:50:06 UTC
It’s necessary to implement this feature now.
Comment 7 Roman Kuznetsov 2020-11-14 17:15:15 UTC
*** Bug 138040 has been marked as a duplicate of this bug. ***
Comment 8 Caolán McNamara 2022-02-09 10:21:08 UTC

*** This bug has been marked as a duplicate of bug 146395 ***