Bug 138173 - Find and Replace dialog default should other options be closed, unless diacritics is off or any other option is on
Summary: Find and Replace dialog default should other options be closed, unless diacri...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-12 21:57 UTC by andreas_k
Modified: 2020-12-16 15:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Find and Replace dialog by default (43.17 KB, image/png)
2020-11-12 21:57 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2020-11-12 21:57:53 UTC
Created attachment 167242 [details]
Find and Replace dialog by default

As Diacritic-sensitive was selected the Other Options expander is always on. I suggest to change the Diacritic-sensitive options that way that the checkbox is not selected by default and the Find & Replace dialog was shown by default in the simple mode.
Comment 1 andreas_k 2020-11-12 22:00:50 UTC
In BUG 129629 comment 4 is written, that the default setting for Search and Replace dialog should be collapsed.

As there is one checkbox selected expand is the default setting. As Diacritic-sensitive is in addition not that easy to understood, I suggest to change the checkbox behavior (off by default) so that the Search and Replace dialog will be collapsed by default.
Comment 2 Heiko Tietze 2020-11-13 07:20:40 UTC
(In reply to andreas_k from comment #1)
> In BUG 129629 comment 4 is written...

Isn't this a clear duplicate? If you have more information we could handle it on the other ticket.
Comment 3 V Stuart Foote 2020-11-13 13:59:59 UTC
See bug 116242 and commits for it

The diacritics-sensitive check box is *required* for correct ICU lib based search. It needs to remain enabled for all language flavors (Western, CJK, CTL)

Maybe something can be done during work for bug 104318, but near term would think the 'Other options' state could be decoupled from the diacritics-sensitive checked enabled state.
Comment 4 Roman Kuznetsov 2020-11-14 17:03:37 UTC
I like when I see all available options at once if the dialog allows it

So -1 from me
Comment 5 andreas_k 2020-11-14 17:54:21 UTC
But what's the reason to have an expander when the dialogue is always expanded, no more options is needed
Comment 6 Cor Nouws 2020-11-18 15:27:59 UTC
(In reply to andreas_k from comment #5)
> But what's the reason to have an expander when the dialogue is always
> expanded, no more options is needed
Possibly the dialog remembers what the user chose last?
But the decision to have it visible, was a deliberate one after a long.... fight, since the Options may have settings from a previous session that do influence the behavior and so that you must see right in your face.
(You'll be able to find all past discussions, I guess ;) )
Comment 7 Thomas Lendo 2020-11-18 21:51:46 UTC
This is a difficile issue. In 2017, Bug 111846 was implemented to have a positive wording in all settings and to have no checked option in the default F&R dialog.

Then in 2018 with Bug 98544 it was implemented that the F&R dialog should remember the 'other options' state. If something is checked then the dialog should stay open.

Also in 2018 the diacritic setting was changed so that it's checked by default. This reversed parts of the initial idea of Bug 111846.

I think Bug 98544 must be re-implemented in a smarter way. The F&R dialog should be collapsed at it's first opening. After that the user's choice and/or the checkboxes' status should be considered to decide if it's collapsed or not. If a user or a program function changes a checkbox status then the dialog should open in it's full extent. With this no one will oversee a setting. Overseen settings hidden in the collapsed dialog could harm the search function in a user's point of view.
Comment 8 Heiko Tietze 2020-11-19 13:28:55 UTC
Let's do it and collapse unless diacritics is off or any other option is on.
Comment 9 Justin L 2020-11-28 13:57:18 UTC
Or you could just move the diacritics option into the upper part - above the more options, so that it can never be hidden.
Comment 10 V Stuart Foote 2020-11-28 17:10:41 UTC
(In reply to Justin L from comment #9)
> Or you could just move the diacritics option into the upper part - above the
> more options, so that it can never be hidden.

It does not need to be moved (but if so, the other ICU transliteration controls would need to be kept with it).

Otherwise the expose/display logic for expanding the 'Other options' panel in the dialog is what needs to be adjusted.

The expanded state is because the 'Diacritics-sensitive' is required to be enabled by default [1], disabling it is non-performant. And a change from that default, to unchecked, is what should trigger exposing the 'Other options'--not the presence of a single checked option as now. 

That could be a test for each of the options for each of the language modes--but that seems excessive. So probably keep it simple and just check the state of the diacritic-sensitive (all modes) and the kashida-sensitive (for CTL mode).

Eike included some comments in the ref commit.

=-ref-=
[1] https://gerrit.libreoffice.org/c/core/+/51382/
Comment 11 Commit Notification 2020-12-16 15:13:12 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e4c21a3c1fa8acd0078029d7a42f304ff2b40773

Resolves tdf#138173 - Keep options collapsed in F&R dialog

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.