Bug Hunting Session
Bug 98544 - Find & Replace dialog should remember the 'other options' state
Summary: Find & Replace dialog should remember the 'other options' state
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Nickson Thanda
URL:
Whiteboard: target:6.1.0
Keywords: needsDevEval, topicUI
Depends on:
Blocks: UX Dialog-Remember-Settings Find&Replace-Dialog
  Show dependency treegraph
 
Reported: 2016-03-09 09:46 UTC by Cor Nouws
Modified: 2019-01-22 15:17 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-03-09 09:46:54 UTC
To reproduce:

Open e.g. text document with text ( :) )
Ctrl+H
add some text
set Regular expressions under the Options
Find
  (nothing done, OK...)

Now in the same session open F&R again in Writer.
section Options is closed
However... Regular expressions is still set.

Same applies for other settings, depending on whatever logic.

This is confusing, at the least
Comment 1 Cor Nouws 2016-03-09 09:48:26 UTC
of course this is 'new'

(strange thing: I would have sworn that I had filed this before. Must have been in OpenOffice.org times than :) )
Comment 2 Yousuf Philips (jay) (retired) 2016-03-09 10:16:28 UTC
It should likely remember the state of whether 'Other Options' was open or closed and keep that state.
Comment 3 Timur 2016-04-26 18:05:22 UTC
I suggest you rename the title per Yousuf's advice.
Comment 4 Cor Nouws 2016-04-26 20:36:53 UTC
(In reply to Yousuf (Jay) Philips from comment #2)
> It should likely remember the state of whether 'Other Options' was open or
> closed and keep that state.

I'm a bit undecided. But think that too is in any way an improvement over the current situation. So fine..
Comment 5 Paolo Benvenuto 2016-05-11 14:28:30 UTC
User case:

I want to replace "...." with "..". If I don't remember that "regular expression" checkbox is selected, I will get a result which I don't expect, and it's not easy to understand what happened.

I think that what is proposed in this bug must be implemented!
Comment 6 Yousuf Philips (jay) (retired) 2016-09-25 22:40:54 UTC
(In reply to Paolo Benvenuto from comment #5)
> I want to replace "...." with "..". If I don't remember that "regular
> expression" checkbox is selected, I will get a result which I don't expect,
> and it's not easy to understand what happened.

Well one possible fix for such an issue might be to display which checkboxes are enabled when the dialog opens. We have an empty label field under the 'match case' checkbox that is used as a status label.

> I think that what is proposed in this bug must be implemented!

Dont think its illogical that a setting should stay set if a user sets it, or else another group of users would come and say, that they set the checkbox and it didnt stay checked after reopening. Users will definitely feel frustrated that it didnt work because they forgot to uncheck it, but the app shouldnt guess what the user wants to do.
Comment 7 Thomas Lendo 2017-02-14 09:26:44 UTC
Is this bug handling what is explained in https://bz.apache.org/ooo/show_bug.cgi?id=88714 ?

If you use the "Find & Replace" dialog and if you select an item of "More Options" (backwards, regular expressions, etc.), next time you open the "F&R" dialog the "More Options" part will be not shown - but the item will be still selected. It is not visible to the user that the "More Options" item is still selected, so it can (and will) be forgotten. Therefore the user can't find what s/he wants and doesn't know why.
Suggestion: Keep the whole "Find & Replace" dialog open as long as an item of the "More Options" part is selected. This issue occurs in all applications.
Comment 8 Cor Nouws 2017-02-14 10:02:53 UTC
(In reply to Thomas Lendo from comment #7)
> Is this bug handling what is explained in
> https://bz.apache.org/ooo/show_bug.cgi?id=88714 ?

Indeed.

> Suggestion: Keep the whole "Find & Replace" dialog open as long as an item
> of the "More Options" part is selected. This issue occurs in all
> applications.

Makes sense.
Comment 9 Xisco Faulí 2017-09-07 10:04:56 UTC Comment hidden (obsolete)
Comment 10 Commit Notification 2018-05-21 14:04:04 UTC
manujvashist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=813397885356c0d63271472adb7d3800e4ac2ca8

tdf#98544 Other Options remain expanded if any checkbox is checked.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2018-05-22 16:27:45 UTC
With master, first time I open F&R Other option is already shown because "Diacritic-sensitive" is checked. Bug 111846.
Even if I turn that option off, for test, and close the dialog, next time Other option is again expanded.
So, looks like "open small and if there's an option open big" turns to "open big always".
Comment 12 Thomas Lendo 2018-07-03 11:56:35 UTC
(In reply to Timur from comment #11)
I confirm what Timur has reported. The F&R dialog window always opens expanded now regardless if a checkbox is checked or not.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 5fce97a58b8f764e35bf98128591c9a89537da05
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-02_23:04:53
Comment 13 V Stuart Foote 2018-07-03 12:39:56 UTC
Actually, think the always enabled CTL checkbox got tweaked for work on bug 116242

And, this impact on the Find Replace -> Other Options would go away with CTL - CJK - Western language option refactoring needed to resolve bug 104318
Comment 14 Nickson Thanda 2018-07-17 03:00:52 UTC
I believe this is resolved. When checkboxes aren't ticked, other options won't be expanded and when checkboxes are ticked, other options are expanded.
Comment 15 Heiko Tietze 2018-07-19 12:58:16 UTC
On my build the other options are always expanded whether an option is checked or not.

Version: 6.2.0.0.alpha0+
Build ID: 9f01dca60e6539f48cd529180f0d64c2131e0ea1
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 16 Xisco Faulí 2019-01-21 18:53:53 UTC
(In reply to Heiko Tietze from comment #15)
> On my build the other options are always expanded whether an option is
> checked or not.
> 
> Version: 6.2.0.0.alpha0+
> Build ID: 9f01dca60e6539f48cd529180f0d64c2131e0ea1
> CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
> Locale: en-US (en_US.UTF-8); Calc: group threaded

Not reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 3fa4674615b747e219afe5bf0a9b689df3840439
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: 

@Heiko, could you please try on master again ?
Comment 17 Heiko Tietze 2019-01-22 09:59:06 UTC
(In reply to Xisco Faulí from comment #16)
> (In reply to Heiko Tietze from comment #15)
> > On my build the other options are always expanded whether an option is
> > checked or not.
> > 
> > Version: 6.2.0.0.alpha0+
> > Build ID: 9f01dca60e6539f48cd529180f0d64c2131e0ea1
> > CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
> > Locale: en-US (en_US.UTF-8); Calc: group threaded
> 
> Not reproduced in
> 
> Version: 6.3.0.0.alpha0+
> Build ID: 3fa4674615b747e219afe5bf0a9b689df3840439
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: 
> 
> @Heiko, could you please try on master again ?

Yes, "Options" are still expanded and "Regular expression" is checked. Not sure about the original issue. Cor, please check.

Version: 6.3.0.0.alpha0+
Build ID: 63ab0873f2a64a66212f6d0e8aa73575416e0a54
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 18 Xisco Faulí 2019-01-22 12:53:23 UTC
Hi Heiko,
What happens if you uncheck all the options, if options then closed ?
Comment 19 Heiko Tietze 2019-01-22 13:01:45 UTC
(In reply to Xisco Faulí from comment #18)
> Hi Heiko,
> What happens if you uncheck all the options, if options then closed ?

That might do the trick. Unchecking all closes the options and perhaps I had another checkbox activated. Still, I think the original issue is something else.
Comment 20 Xisco Faulí 2019-01-22 13:08:21 UTC
(In reply to Heiko Tietze from comment #19)
> (In reply to Xisco Faulí from comment #18)
> > Hi Heiko,
> > What happens if you uncheck all the options, if options then closed ?
> 
> That might do the trick. Unchecking all closes the options and perhaps I had
> another checkbox activated. Still, I think the original issue is something
> else.

Please see the commit in comment 10. That's what the commit is meant to do
Comment 21 Cor Nouws 2019-01-22 15:17:20 UTC
Interesting.
thanks for all the work on this.
The real problem is solved.

When one uses an option, the next time the dialog is used, the Options section is open. So you see the option is checked. Check! Nice.

Slight issue on my PC:
- with Options section closed
- do some Replace All
  > In the end the Options section opens :)
Different problem I guess.

This issue is fixed, AFAIC.
Version: 6.3.0.0.alpha0+
Build ID: b8e450a54936560cdac00ab4c70ef80c20cfaf99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-18_06:04:42
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded