Bug 138271 - FORMS: Some values are not saved (gen)
Summary: FORMS: Some values are not saved (gen)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.4 target:7.2.0
Keywords: bibisected, bisected, needUITest, regression
: 138464 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-16 20:56 UTC by Xisco Faulí
Modified: 2021-02-24 22:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-11-16 20:56:53 UTC
Steps to reproduce:
1. Open Writer
2. Forms - More Fields - Numerical Fields
3. Draw it and double click on it
4. Change Value min or Value max
5. Close the dialog and open it again

-> The changes done in step 4 are lost

Reproduced in

Version: 7.1.0.0.alpha1+
Build ID: 548d77d0c06f7088dd3eb408797aa1fc1d7eb277
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-11-16 20:57:53 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1efeb17837c22499f00299c033ae59ba3910f7d7

author	Caolán McNamara <caolanm@redhat.com>	2019-11-04 13:06:04 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-09 13:28:35 +0100
commit	1efeb17837c22499f00299c033ae59ba3910f7d7 (patch)
tree	a8db0b758e942b3b14fba26129dc51a95ff5c10c
parent	4da3e0a0e5b2260c26186890724978bfd00f796c (diff)
weld Property Browser

Bisected with: bibisect-linux64-7.0

Adding Cc: to Caolán McNamara
Comment 2 Xisco Faulí 2020-11-17 14:47:22 UTC
Affecting 7.0 users, bumping importance
Comment 3 Commit Notification 2020-11-18 14:07:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2a9e6792b85bd7f747f74da62d575720469485f3

Resolves: tdf#138271 flag formatted spinbuttons as modified on any entry change

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-11-18 14:08:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7f5a87c501ba1291a93bf330cc1a1de19ea1d89c

tdf#138271 send value-changed on FormattedSpinButton losing focus

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2020-11-18 14:09:23 UTC
fixed in master, backport to 7-0 in gerrit
Comment 6 Commit Notification 2020-11-19 01:21:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/acddc14fef3f3d34c9f2218545364ff37815b507

Resolves: tdf#138271 flag formatted spinbuttons as modified on any entry change

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Justin L 2020-11-28 06:53:26 UTC
*** Bug 138464 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2020-12-02 20:44:10 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 79ec66700266a22966d9e308a716be56c9c3a4a7
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!

Adding needUITest keyword. I tried to create a UItest in https://gerrit.libreoffice.org/c/core/+/106150 but the changes are not saved after closing and reopening the control properties dialog using the UI testing framework
Comment 9 Commit Notification 2021-02-24 22:24:07 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/af64bc49d872d8a040d66387303def98eae5cd51

tdf#138271: sw: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.