Bug 138350 - Wrong colors used in icon-themes/colibre/svx/res/frmsel*.png
Summary: Wrong colors used in icon-themes/colibre/svx/res/frmsel*.png
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.2.0 target:7.0.4 target:7.1....
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2020-11-19 19:38 UTC by Heiko Tietze
Modified: 2021-01-02 23:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (13.78 KB, image/png)
2020-11-19 19:38 UTC, Heiko Tietze
Details
Colibre vs KJ image color (52.65 KB, image/png)
2020-12-16 10:22 UTC, Rizal Muttaqin
Details
Pixelate the arrowhead (179.62 KB, image/png)
2021-01-02 23:05 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-11-19 19:38:23 UTC
Created attachment 167406 [details]
Screenshot

These icons have three colors with exact RGB values that are dynamically replaced [1]. It has to be black ( 0, 0, 0 ) for the foreground, magenta ( 255, 0, 255 ) for transparency/background, and green ( 0, 255, 0 ) for other foreground stuff. 

Karasa Jaga seems to do right and uses excludively the exact colors- but it keeps the magenta background as well. Could also be some issue with the color replacement function.

Tested with 

Version: 7.1.0.0.alpha1+
Build ID: 3f8d9566cdf278d3412207aa15ac5a8c6a3757b4
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: x11 (and kf5/gtk3)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[1] svx/source/dialog/frmsel.cxx -> FrameSelectorImpl::InitArrowImageList()
Comment 1 Rizal Muttaqin 2020-11-23 06:07:09 UTC
Karasa Jaga use exact copied file from legacy Galaxy, while Colibre are drawn manually using MS Office monoline color. It should tell which one the issue is.

Assigned myself to update the colors
Comment 2 Commit Notification 2020-11-23 21:38:17 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c5fa6b299b1736bd37c7f0d901418b4a9401df0

Colibre: tdf#138350 fix wrong color from monoline color to these HEX

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-11-24 06:21:25 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/20582984b010cc78822cb48ba58c3d8c9a7d7460

Colibre: tdf#138350 fix wrong color from monoline color to these HEX

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-11-24 06:21:39 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/e2cffcf55b04838abc7497f6c18518c7600b670b

Colibre: tdf#138350 fix wrong color from monoline color to these HEX

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Rizal Muttaqin 2020-12-16 10:22:20 UTC
Created attachment 168216 [details]
Colibre vs KJ image color

Notice that Colibre are still showing magenta color while Karasa Jaga are not. I guess I need to update again Colibre?


Version: 7.2.0.0.alpha0+
Build ID: d9ccee2231a8d8984302e1b2f578bf73b4d60c35
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-12-15_03:50:32
Calc: threaded
Comment 6 Heiko Tietze 2020-12-16 12:08:16 UTC
(In reply to Rizal Muttaqin from comment #5)
> Notice that Colibre are still showing magenta color while Karasa Jaga are
> not. I guess I need to update again Colibre?

Yes, the exact RGB value is used for transparency.
Comment 7 Ming Hua 2020-12-16 16:53:23 UTC
It seems that Karasa Jaga (and likely the theme it copied from) didn't bother with SVG at all for these icons, and only has PNG versions.  There is even a icon_themes/karasa_java/svx/res/frmsel.bmp file with all 16 icons together.

Considering the strict requirements of the RGB values for these icons, maybe that's a good idea?  Or at least make sure not to use intermediate colors for transitions when making PNG icons from the SVG originals, which looks like the cause of the current magenta arrowheads.
Comment 8 Rizal Muttaqin 2021-01-02 23:05:24 UTC
Created attachment 168636 [details]
Pixelate the arrowhead

(In reply to Ming Hua from comment #7)
> It seems that Karasa Jaga (and likely the theme it copied from) didn't
> bother with SVG at all for these icons, and only has PNG versions.  There is
> even a icon_themes/karasa_java/svx/res/frmsel.bmp file with all 16 icons
> together.
> 
> Considering the strict requirements of the RGB values for these icons, maybe
> that's a good idea?  Or at least make sure not to use intermediate colors
> for transitions when making PNG icons from the SVG originals, which looks
> like the cause of the current magenta arrowheads.

Finally I have found the root cause of current magenta arrowheads.

I had to pixelated (I am not sure the process name) the diagonal part of arrowhead and I got perfect result!