Download it now!
Bug 138549 - CRASH: Undoing comment hovering (steps in comment 11)
Summary: CRASH: Undoing comment hovering (steps in comment 11)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.beta1+
Hardware: All All
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.0.4 target:7.1....
Keywords: bibisected, bisected, regression
: 138766 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-29 15:52 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2020-12-09 10:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
test document to reproduce the bug (1.01 MB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-29 15:52 UTC, Stefan_Lange_KA@T-Online.de
Details
zip file with 4 screenshots of crashes in Safe Mode (900.16 KB, application/x-zip-compressed)
2020-11-30 20:27 UTC, Stefan_Lange_KA@T-Online.de
Details
simpliflied document (7.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-12-01 08:35 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2020-11-29 15:52:41 UTC
Created attachment 167645 [details]
test document to reproduce the bug

In some cases Undo of filters results in  crashes of LibreOffice.

Reproduce the behavior:
- open attached document "altix_Nummern_Test_Undo_Filter_V1_klein.ods"
- go to sheet "Altix IV und V"
- set a filter on column R by entering e.g. "Tom " or "Steve " in the search field and selecting all results
- set a filter on column Q by entering e.g. "408" in the search field and selecting all results
- Undo two times
--> LO crashes

The behavior was reproduced with
Version: 7.1.0.0.beta1+ (x64)
Build ID: 0c1736f2dff63f2ac4a08c2b0e4c0d9c20d693cb
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
from 2020-11-29

Because of the similarity I first thougt it is a duplicate of Bug 138428 but because this bug is already patched and verified in LO 7.1.0.0 beta1+ I think it isn't.

The behavior was also reproduced as well with
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 5abb1890ffafe5a2212076208a1c6e226f1ffa4e
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
from 2020-11-29
as with
Version: 7.0.4.0.0+ (x64)
Build ID: 5f159d4f8524cd466e124ca8366d71566cb883c4
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
from 2020-11-25
as with
Version: 7.0.5.0.0+ (x64)
Build ID: 7f2828aa84f87c85c92969a9b0eace4df75870df
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
from 2020-11-28,

but not with
------------
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL.
Comment 1 Xisco Faulí 2020-11-30 14:58:05 UTC
is this a duplicate of bug 138428 ??
Comment 2 Martin Srdoš 2020-11-30 18:45:21 UTC
Hello Stefan,

Thank you for reporting the bug. I can confirm that the bug is present in master. But in safe mode it works ok for me.

Version: 7.1.0.0.beta1 (x64)
Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-GB
Calc: CL


In last release it works ok.
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: cs-CZ (cs_CZ); UI: en-US
Calc: CL
Comment 3 Martin Srdoš 2020-11-30 19:03:55 UTC
Stefan, can you try it in the beta in safe mode? HELP -> RESTART IN SAFE MODE and write, if it is work or not.
Comment 4 Xisco Faulí 2020-11-30 19:39:12 UTC
(In reply to srdosm from comment #2)
> Hello Stefan,
> 
> Thank you for reporting the bug. I can confirm that the bug is present in
> master. But in safe mode it works ok for me.
> 
> Version: 7.1.0.0.beta1 (x64)
> Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
> CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL:
> win
> Locale: cs-CZ (cs_CZ); UI: en-GB
> Calc: CL

That builds also contains bug 138428. I really think this is a dupe of bug  bug 138428
Comment 5 Stefan_Lange_KA@T-Online.de 2020-11-30 19:45:39 UTC
(In reply to Xisco Faulí from comment #1)
> is this a duplicate of bug 138428 ??

I am not sure, if it is a duplicate or not:

I have tested with several documents with recent builds of LO and LOdev (LOdev 7.0.5.0, LOdev 7.1.0.0.beta1, LOdev 7.2.0.0.alpha0 and rc1 LO 7.0.4.1). Not always LO crashes, but the chance for a crash is about 4:1. 

Indication for a duplicate is the fact that occasionally LO still crashes (chance 50:50) when I make tests as you have described in your description of bug 138428, although this bug should be fixed already.
Comment 6 Stefan_Lange_KA@T-Online.de 2020-11-30 20:26:43 UTC
(In reply to srdosm from comment #3)
> Stefan, can you try it in the beta in safe mode? HELP -> RESTART IN SAFE
> MODE and write, if it is work or not.

I have tested in safe mode (default settings + reset UI and User profile) with LO 7.0.4.1 and with LOdev 7.1.0.0beta: In both tests I have reproduced the crash, see attached screenshots!

Version: 7.0.4.1 (x64)
Build ID: e3cebc55238632eae061a3da668963d484a71147
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

Version: 7.1.0.0.beta1+ (x64)
Build ID: 0c1736f2dff63f2ac4a08c2b0e4c0d9c20d693cb
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 7 Stefan_Lange_KA@T-Online.de 2020-11-30 20:27:56 UTC
Created attachment 167697 [details]
zip file with 4 screenshots of crashes in Safe Mode
Comment 8 Stefan_Lange_KA@T-Online.de 2020-11-30 21:06:43 UTC
(In reply to Xisco Faulí from comment #1)
> is this a duplicate of bug 138428 ??

I have made further tests with both LO 7.0.4.1 and LOdev 7.1.0.0.beta1. In Standard Mode and in Safe Mode I can reproduce crashes on a simple way:
- open attached test document "altix_Nummern_Test_Undo_Filter_V1_klein.ods"
- move mouse cursor over a cell with a comment that comment is be shown
--> Undo is available although nothing was changed (!)
- Undo --> LO crashes

Maybe this is a hint that the bug is a duplicate and also a hint that bug 138428 still isn't fixed completely.

In LO 7.0.3.1 the problem "Undo activated when comment is shown by mouse move" doesn't exist.
Comment 9 Stefan_Lange_KA@T-Online.de 2020-11-30 21:09:02 UTC
(In reply to Stefan_Lange_KA@T-Online.de from comment #5)
> (In reply to Xisco Faulí from comment #1)
> > is this a duplicate of bug 138428 ??
> 
> I am not sure, if it is a duplicate or not:
> 
> I have tested with several documents with recent builds of LO and LOdev
> (LOdev 7.0.5.0, LOdev 7.1.0.0.beta1, LOdev 7.2.0.0.alpha0 and rc1 LO
> 7.0.4.1). Not always LO crashes, but the chance for a crash is about 4:1. 
> 
> Indication for a duplicate is the fact that occasionally LO still crashes
> (chance 50:50) when I make tests as you have described in your description
> of bug 138428, although this bug should be fixed already.

I have made further tests with both LO 7.0.4.1 and LOdev 7.1.0.0.beta1. In Standard Mode and in Safe Mode I can reproduce crashes on a simple way:
- open attached test document "altix_Nummern_Test_Undo_Filter_V1_klein.ods"
- move mouse cursor over a cell with a comment that comment is be shown
--> Undo is available although nothing was changed (!)
- Undo --> LO crashes

Maybe this is a hint that the bug is a duplicate and also a hint that bug 138428 still isn't fixed completely.

In LO 7.0.3.1 the problem "Undo activated when comment is shown by mouse move" doesn't exist.
Comment 10 raal 2020-11-30 22:12:16 UTC
(In reply to Stefan_Lange_KA@T-Online.de from comment #9)
> I have made further tests with both LO 7.0.4.1 and LOdev 7.1.0.0.beta1. In
> Standard Mode and in Safe Mode I can reproduce crashes on a simple way:
> - open attached test document "altix_Nummern_Test_Undo_Filter_V1_klein.ods"
> - move mouse cursor over a cell with a comment that comment is be shown
> --> Undo is available although nothing was changed (!)
> - Undo --> LO crashes
> 

bisected to c06327b2cfa710864ed42e998fa06e5409b98e0f is the first bad commit
commit c06327b2cfa710864ed42e998fa06e5409b98e0f
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 19 01:06:13 2020 -0800

    source sha:2f7b5634487ac3d27777ab12a57089e71ea5216d

https://gerrit.libreoffice.org/c/core/+/106069
Resolves: tdf#114956 skip broadcast optimization for ScPostIts

Adding CC to Caolán McNamara
Comment 11 Xisco Faulí 2020-12-01 08:35:25 UTC
Created attachment 167704 [details]
simpliflied document

Steps to reproduce:
1. Open 'simplified document'
2. Hover comment dot -> Comment is displayed
3. Undo

-> Crash
Comment 12 Xisco Faulí 2020-12-01 08:40:07 UTC
(In reply to raal from comment #10)
> bisected to c06327b2cfa710864ed42e998fa06e5409b98e0f is the first bad commit
> commit c06327b2cfa710864ed42e998fa06e5409b98e0f
> Author: Norbert Thiebaud <nthiebaud@gmail.com>
> Date:   Thu Nov 19 01:06:13 2020 -0800
> 
>     source sha:2f7b5634487ac3d27777ab12a57089e71ea5216d
> 
> https://gerrit.libreoffice.org/c/core/+/106069
> Resolves: tdf#114956 skip broadcast optimization for ScPostIts
> 
> Adding CC to Caolán McNamara

I do confirm the issue is introduced by the mentioned commit
Comment 13 Caolán McNamara 2020-12-01 09:08:12 UTC
even with undo disabled while setting the name, undo info will still be generated later on to enforce unique object names. So using a name to identify these special calc postits isn't working for us, but it looks like GetSpecialTextBoxShadow() could be used instead with these side effects.
Comment 14 Commit Notification 2020-12-01 11:15:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/4795e8ac3ed56b2f1ff93b0ac870a45be2428bca

Resolves: tdf#138549 use GetSpecialTextBoxShadow to identify ScPostIt

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-12-01 13:40:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9c94bae963ef5019f6ca0394d076b1288969aa53

Resolves: tdf#138549 use GetSpecialTextBoxShadow to identify ScPostIt

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-12-01 14:58:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0-4":

https://git.libreoffice.org/core/commit/77670f84c1148d15ab9a34c4db150e87ad9949eb

Resolves: tdf#138549 use GetSpecialTextBoxShadow to identify ScPostIt

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Stefan_Lange_KA@T-Online.de 2020-12-02 08:08:32 UTC
I have tested several cases with
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded

All were OK, no crash occured.
Many thanks for fast fixing the bug!

Now I still wait for a new build of LO 7.0 with the fix.
Comment 18 Stefan_Lange_KA@T-Online.de 2020-12-02 12:38:15 UTC
The same tests as this morning I have repeated now with the just published version
Version: 7.0.5.0.0+ (x64)
Build ID: 6edd9b477d0653596b200590e750edbd9aa47c62
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

All these tests were OK too.
Comment 19 Commit Notification 2020-12-02 13:19:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/49f0410cafcc2bd3b417427d3d17de8abb8ea3b4

Resolves: tdf#138549 use GetSpecialTextBoxShadow to identify ScPostIt

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Stefan_Lange_KA@T-Online.de 2020-12-03 13:34:08 UTC
Last but not least also the tests with
Version: 7.1.0.0.beta1+ (x64)
Build ID: 62c0d42e179476da5fcad02722a9d3c6f83ef258
CPU threads: 4; OS: Windows 10.0 Build 20262; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
were OK, man thanks!
Comment 21 Mike Kaganski 2020-12-09 10:44:29 UTC
*** Bug 138766 has been marked as a duplicate of this bug. ***