Bug 138701 - Entering text in the data field combo box in Base Control Properties is backwards
Summary: Entering text in the data field combo box in Base Control Properties is backw...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0.0.beta2 target:7.2.0 tar...
Keywords: bibisected, bisected, regression
: 139312 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-06 22:48 UTC by David Bauguess
Modified: 2021-02-24 18:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture of reverse entry (7.69 KB, image/png)
2020-12-06 22:50 UTC, David Bauguess
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Bauguess 2020-12-06 22:48:20 UTC
Description:
In Libre Office Base, if I bring up the properties of a control, and try to enter text into the Data Field entry unter the Data tab, i.e. "hello", it comes in as "olleh".  Any attempt to delete a character returns the cursor to the beginning of the entry box.

Steps to Reproduce:
1.Create a control and open the controls properties and click the Data tab
2.Try to type anything in the Data Field entry box
3.

Actual Results:
All entries are backwards

Expected Results:
Forwards typing, editing and deleting.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Anything entered fails to work even if it is copied and pasted from a working control.
Comment 1 David Bauguess 2020-12-06 22:50:58 UTC
Created attachment 167886 [details]
Screen capture of reverse entry
Comment 2 Robert Großkopf 2020-12-07 19:41:49 UTC
Could confirm the buggy behavior for the "Datafield" in the properties "Data" of a formatted control. Seems to be the same in every control only for this entry.

Tested this with OpenSUSE 15.1 64bit rpm Linux, LO 7.0.4.1 and VCL: kf5 . 
This buggy behavior doesn't happen with VLC: gtk3.
Comment 3 Xisco Faulí 2020-12-11 16:43:25 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1efeb17837c22499f00299c033ae59ba3910f7d7

author	Caolán McNamara <caolanm@redhat.com>	2019-11-04 13:06:04 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-09 13:28:35 +0100
commit	1efeb17837c22499f00299c033ae59ba3910f7d7 (patch)
tree	a8db0b758e942b3b14fba26129dc51a95ff5c10c
parent	4da3e0a0e5b2260c26186890724978bfd00f796c (diff)
weld Property Browser

Bisected with: bibisect-linux64-7.0

Adding Cc: to Caolán McNamara
Comment 4 Commit Notification 2020-12-15 17:37:13 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/402316c8df19ec9714a39ff5d7863d03dbe93720

tdf#138701 leave current combobox cursor valid if the contents won't change

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-12-15 20:13:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7763692e50191e2074f56e9bf698c843eed0ad00

tdf#138701 leave current combobox cursor valid if the contents won't change

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-12-15 20:13:50 UTC
fixed in master and 7-1, backport to 7-0 in gerrit
Comment 7 Xisco Faulí 2020-12-17 13:07:19 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 4484accf4d331a95ebf8475d6cd91950f4c27bcc
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 8 Commit Notification 2020-12-17 13:08:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/4cc753b6b9a7011da3ea50a1c90ed10870b9a2e0

tdf#138701 leave current combobox cursor valid if the contents won't change

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Robert Großkopf 2020-12-30 08:40:09 UTC
*** Bug 139312 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2021-02-24 18:49:50 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a0cc84e63cd3bcc028aca093335c5528f7c4de6a

tdf#138701: sw: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.