Bug 138780 - FILESAVE: DOCX: numbering list style is gone in MSO
Summary: FILESAVE: DOCX: numbering list style is gone in MSO
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, filter:docx, regression
: 139089 (view as bug list)
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2020-12-09 15:32 UTC by Xisco Faulí
Modified: 2021-01-26 09:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (91.00 KB, application/msword)
2020-12-09 15:32 UTC, Xisco Faulí
Details
Comparison before and after RT ( MSO 2010) (118.21 KB, image/png)
2020-12-09 15:33 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-12-09 15:32:10 UTC
Created attachment 168007 [details]
sample file

Steps to reproduce:
1. Open attached document
2. Save it as DOCX
3. Open it in MSO Word ( I'm using Word 2010 )

-> The numbers and the tabs in the numbering list are gone. See screenshot

Reproduced in

Version: 7.2.0.0.alpha0+
Build ID: 84af20ef3ea72190784e9e7be820684c2558ba8c
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-12-09 15:33:46 UTC
Created attachment 168008 [details]
Comparison before  and after RT ( MSO 2010)
Comment 2 Xisco Faulí 2020-12-09 15:34:57 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9e455724e50bf512683b1cddfeb7493e047c19ae

author	Michael Stahl <Michael.Stahl@cib.de>	2020-10-19 19:41:36 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-10-20 09:00:25 +0200
commit	9e455724e50bf512683b1cddfeb7493e047c19ae (patch)
tree	b507f6432fd85202c893e2b2a217eb893798592e
parent	aa99b57cdc8cb3763aa935ed84e7d80c4e56a172 (diff)
sw: DOCX export: don't export numPr to style from outline numrule

Bisected with: bibisect-linux64-7.1

Adding Cc: to Michael Stahl
Comment 3 Xisco Faulí 2020-12-11 15:30:27 UTC
hi Michael Stahl,
should 9e455724e50bf512683b1cddfeb7493e047c19ae be reverted? I found other files with the same problem mentioned in this issue ?
Comment 4 Justin L 2021-01-25 07:21:45 UTC
(In reply to Xisco Faulí from comment #3)
> hi Michael Stahl,
> should 9e455724e50bf512683b1cddfeb7493e047c19ae be reverted? I found other
> files with the same problem mentioned in this issue ?

Michael is probably much braver than I am, but anytime there is a problem with numbering, I would revert and start over again - numbering is way too goofy to be sure about anything. Better to just start again from a clean slate.

Proposed revert at https://gerrit.libreoffice.org/c/core/+/109864

P.S. I got the same results testing with Word 2016.
Comment 5 Justin L 2021-01-25 07:22:10 UTC
*** Bug 139089 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2021-01-25 09:52:44 UTC
Reverted in https://cgit.freedesktop.org/libreoffice/core/commit/?id=32d11fb200d45cdacb973b625488d0b8bbee6d81
Closing as RESOLVED FIXED
Comment 7 Commit Notification 2021-01-25 13:45:55 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ec7ea311671928d0b66989aaa0542be902d85c3c

tdf#138780: sw_ooxmlexport12: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.