Bug 139089 - Chapter numbering gone after DOCX export for custom heading style
Summary: Chapter numbering gone after DOCX export for custom heading style
Status: RESOLVED DUPLICATE of bug 138780
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2020-12-20 10:32 UTC by Telesto
Modified: 2021-01-25 22:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.53 KB, application/vnd.oasis.opendocument.text)
2020-12-20 10:32 UTC, Telesto
Details
The example file and its docx version in current master (77.61 KB, image/png)
2020-12-22 19:14 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-20 10:32:38 UTC
Description:
Chapter numbering gone after DOCX export for custom heading style

Steps to Reproduce:
1. Open the attached file
2. Save as DOCX
3. File reload

Actual Results:
No chapter numbering

Expected Results:
Chapter numbering


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

still ok with
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-12-20 10:32:50 UTC
Created attachment 168355 [details]
Example file
Comment 2 Gabor Kelemen 2020-12-22 19:12:33 UTC
Confirming with:

Version: 7.2.0.0.alpha0+
Build ID: e57665ea6f812aff9fc87073ce947f40a8b26e9d
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3
Locale: hu-HU (hu_HU.UTF-8); UI: en-US
Calc: threaded

Seems to have started with:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9e455724e50bf512683b1cddfeb7493e047c19a

author	Michael Stahl <Michael.Stahl@cib.de>	2020-10-19 19:41:36 +0200
committer	Michael Stahl <michael.stahl@cib.de>	2020-10-20 09:00:25 +0200

sw: DOCX export: don't export numPr to style from outline numrule

Adding CC to: Michael Stahl
Comment 3 Gabor Kelemen 2020-12-22 19:14:15 UTC
Created attachment 168427 [details]
The example file and its docx version in current master
Comment 4 Justin L 2021-01-25 07:22:10 UTC

*** This bug has been marked as a duplicate of bug 138780 ***