Bug 139214 - LibreOffice crashes when I try open DOCX file
Summary: LibreOffice crashes when I try open DOCX file
Status: RESOLVED DUPLICATE of bug 138973
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2020-12-24 19:22 UTC by Roman Kuznetsov
Modified: 2020-12-25 09:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-12-24 19:22:54 UTC
Description:
LibreOffice crashes when I try open DOCX file

Steps to Reproduce:
1. Try open http://bugs.documentfoundation.org/attachment.cgi?id=136317
2. LO crashes


Actual Results:
LO crashes

Expected Results:
LO opens the DOCX file as normal


Reproducible: Always


User Profile Reset: No



Additional Info:
repro in current 7.2 master but not in 7.1.0.1 => regression


I bisected it in win64-7.2 bisect repo and found

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((oldest))
$ git bisect start master oldest
Bisecting: 472 revisions left to test after this (roughly 9 steps)
[3110cb2d39aea352b34f6a35273026db1cf7ee8c] source sha:520a2819fa6030ec11175d82dd42cfcdb2e92634

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((3110cb2d...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((3110cb2d...)|BISECTING)
$ git bisect good
Bisecting: 236 revisions left to test after this (roughly 8 steps)
[69f077e9544b807152d20ebf73adc3624e3ded8c] source sha:b4365b985178e1866c74afd757a104aad1d405a9

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((69f077e9...)|BISECTING)
$ instdir/program/soff
bash: instdir/program/soff: No such file or directory

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((69f077e9...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((69f077e9...)|BISECTING)
$ git bisect good
Bisecting: 118 revisions left to test after this (roughly 7 steps)
[e98bebe5a0b38b139a7cd26711a4fa43a0c73c3f] source sha:723a2623bd11c51d506873862893ee4009caaab1

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((e98bebe5...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((e98bebe5...)|BISECTING)
$ git bisect bad
Bisecting: 58 revisions left to test after this (roughly 6 steps)
[ce0649e587ad47b8e8b829b0292e9451f4a05d21] source sha:10cf4d5193df2f804176c05a843e801077dbf2ce

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((ce0649e5...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((ce0649e5...)|BISECTING)
$ git bisect good
Bisecting: 29 revisions left to test after this (roughly 5 steps)
[4a6cd74f8025e722a1a5fa840b0bcaa83c754630] source sha:6f0fd67831b9c5f1bbacf7025e292f733c30c3cd

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((4a6cd74f...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((4a6cd74f...)|BISECTING)
$ git bisect bad
Bisecting: 14 revisions left to test after this (roughly 4 steps)
[d1b8de0836024e171e403ea4a3548016f5f273c0] source sha:1f066313218449cac494a887eb209311efbaa405

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((d1b8de08...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((d1b8de08...)|BISECTING)
$ git bisect good
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[1b6c28fe7934e4e8165f4a9a9fd4826602d57b39] source sha:1c38093b9214b2d417d12cc091cfc1f211a49777

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((1b6c28fe...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((1b6c28fe...)|BISECTING)
$ git bisect good
Bisecting: 3 revisions left to test after this (roughly 2 steps)
[519c1c955fe3abfefa02ee9b23645a35d0025e58] source sha:def3a581639840d39466327b4853c043bd662437

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((519c1c95...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((519c1c95...)|BISECTING)
$ git bisect bad
Bisecting: 1 revision left to test after this (roughly 1 step)
[9f53db5a7c17b6e3589b3e5a516acc0a77c46bcc] source sha:d98cf29aa4e5ce14f0c96a18be563f5ce36879df

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((9f53db5a...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((9f53db5a...)|BISECTING)
$ git bisect good
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[791f93f9b4fa45281aa06ca3c92e5ad9d558c3ab] source sha:c521e614359d236405754134a54e8a05bdb1c44c

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((791f93f9...)|BISECTING)
$ instdir/program/soffice

Домовой@▒▒▒▒▒▒▒-▒▒ MINGW64 /d/LO_bisect/bibisect-win64-7.2 ((791f93f9...)|BISECTING)
$ git bisect bad
791f93f9b4fa45281aa06ca3c92e5ad9d558c3ab is the first bad commit
commit 791f93f9b4fa45281aa06ca3c92e5ad9d558c3ab
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon Dec 14 06:07:07 2020 -0800

    source sha:c521e614359d236405754134a54e8a05bdb1c44c


https://git.libreoffice.org/core/+/c521e614359d236405754134a54e8a05bdb1c44c^!

Added to CC: Noel Grandin
Comment 1 Aron Budea 2020-12-25 03:31:17 UTC
Not getting a crash in the 12-24 daily build (7.2.0.0.alpha0+, ed54542e7237c9e519b75464af55094e578aefdc). Since there's no identification which build you tried, I'm going to assume this is the dupe of bug 138973, and is fixed since 12-19. If your build is newer, please reopen.

*** This bug has been marked as a duplicate of bug 138973 ***
Comment 2 Roman Kuznetsov 2020-12-25 09:02:00 UTC
(In reply to Aron Budea from comment #1)
> Not getting a crash in the 12-24 daily build (7.2.0.0.alpha0+,
> ed54542e7237c9e519b75464af55094e578aefdc). Since there's no identification
> which build you tried, I'm going to assume this is the dupe of bug 138973,
> and is fixed since 12-19. If your build is newer, please reopen.
> 
> *** This bug has been marked as a duplicate of bug 138973 ***

It was a build from 18.12.2020, yes. I checked in build from 25.12.2020 and the bug is gone