Download it now!
Bug 138973 - Sidebar Gallery deck crashing
Summary: Sidebar Gallery deck crashing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 138956 139086 139118 139214 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2020-12-16 15:46 UTC by V Stuart Foote
Modified: 2020-12-25 03:35 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDbg stack trace of crashing SB Gallery deck (14.74 KB, text/plain)
2020-12-16 15:46 UTC, V Stuart Foote
Details
crash stack trace of STR from dupe bug 138956 changing area fill from bitmap to pattern SB Properties deck, similar with Area fill dialog (11.98 KB, text/plain)
2020-12-18 16:06 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2020-12-16 15:46:11 UTC
Created attachment 168234 [details]
WinDbg stack trace of crashing SB Gallery deck

Sidebar Gallery deck is crashing on launch, all modules.

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 15e4427e8fb56a143caa28b8a3120f3761fc77a5
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Was OK through the 2020-12-06 build, but crashes 2020-12-15

https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=ecb916667b633f8647790e040226b093760e6cfe..15e4427e8fb56a143caa28b8a3120f3761fc77a5

WinDbg Stack trace attached.
Comment 1 V Stuart Foote 2020-12-16 16:03:47 UTC
The ReadDIBBitmapEx call suggests maybe

https://gerrit.libreoffice.org/c/core/+/107287

Tomaž?
Comment 2 V Stuart Foote 2020-12-16 18:48:48 UTC
(In reply to V Stuart Foote from comment #1)
> The ReadDIBBitmapEx call suggests maybe
> 
> https://gerrit.libreoffice.org/c/core/+/107287
> 
> Tomaž?


On another system, came in between the 2020-12-13 and the 2020-12-15 TB77 nightlies, which includes the (def31e1) commit.

https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=368c56144aab5794c39d5bc2082d9b3d6d7cebdb..15e4427e8fb56a143caa28b8a3120f3761fc77a5
Comment 3 Telesto 2020-12-16 21:28:57 UTC
Confirm
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 15e4427e8fb56a143caa28b8a3120f3761fc77a5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 4 Aron Budea 2020-12-18 04:40:04 UTC
This only occurs with Skia for me.
Comment 5 V Stuart Foote 2020-12-18 07:20:16 UTC
Ouch, not sure how I missed checking that but sure enough. The crash is only when Skia (Vulkan or raster) rendering is enabled. Default GDI rendering (CPU only or with Hardware Acceleration) does not crash.
Comment 6 Aron Budea 2020-12-18 15:22:53 UTC
Bibisected to the following commit using repo bibisect-linux-64-7.2. Adding CC: to Noel Grandin.

I've used the following command to start LO with Skia on Linux:
SAL_USE_VCLPLUGIN=gen SAL_ENABLESKIA=1 ./soffice

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c521e614359d236405754134a54e8a05bdb1c44c
author		Noel <noelgrandin@gmail.com>	2020-12-14 13:55:49 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-12-14 14:34:06 +0100

loplugin:unusedenumconstants
Comment 7 Aron Budea 2020-12-18 15:24:45 UTC
*** Bug 138956 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2020-12-18 16:06:44 UTC
Created attachment 168301 [details]
crash stack trace of STR from dupe bug 138956 changing area fill from bitmap to pattern SB Properties deck, similar with Area fill dialog


As with OP here, STR of bug 138956 do not crash with default GDI rendering, but do crash with Skia (Vulkan or raster).
Comment 9 Commit Notification 2020-12-18 20:20:47 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/29c5b99832d731071dd201e88d6631c805efe91a

fix incorrect array access after a removed enum (tdf#138973)

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 V Stuart Foote 2020-12-19 18:00:01 UTC
Confirmed fixed with
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Both sets of STR no longer crash, opening the SB Gallery or changing area fill to a Pattern fill.
Comment 11 V Stuart Foote 2020-12-20 15:24:47 UTC
*** Bug 139086 has been marked as a duplicate of this bug. ***
Comment 12 Aron Budea 2020-12-25 03:31:17 UTC
*** Bug 139214 has been marked as a duplicate of this bug. ***
Comment 13 Aron Budea 2020-12-25 03:35:06 UTC
*** Bug 139118 has been marked as a duplicate of this bug. ***