Bug 139086 - 7.2.0.0 Microsoft Windows version of LO Draw crashes upon opening a file whose background is set to a bitmap
Summary: 7.2.0.0 Microsoft Windows version of LO Draw crashes upon opening a file whos...
Status: RESOLVED DUPLICATE of bug 138973
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-20 05:31 UTC by mwtjunkmail
Modified: 2021-01-04 17:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Interface capture (8.29 KB, image/png)
2020-12-20 11:56 UTC, mwtjunkmail
Details
PNG export using hardware only (8.83 KB, image/png)
2020-12-20 12:09 UTC, mwtjunkmail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mwtjunkmail 2020-12-20 05:31:09 UTC
Description:
Color background seem to be fine, but opening a Draw document whose background has been set to a bitmap crash upon opening.

Note: Sometimes on a brand new file, you don't even need to follow the steps below, just select bitmap for a background on a brand new LO Draw file and LO crashes, even after having just reset the user profile.

Steps to Reproduce:
1. Launch LO Draw using Dev 7.2.0.0 in Microsoft Windows Version 10
2. Set the background to a bitmap (you can use the default bitmap that appears)
3. Save the file
4. Close the file
5. Close out of LO draw completely
6. Open the file using File, Open...
7. Wait approximately 30 seconds (do absolutely nothing at all, don't even move the mouse)

Actual Results:
LO crashes hard


Expected Results:
LO doesn't crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Microsoft Windows 10.

Version: 7.2.0.0.alpha0+ (x64)
Build ID: cb22636a56b35d4e118446cc3c9fe606db6f46b0
CPU threads: 8; OS: Windows 10.0 Build 21277; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

I reset the user profile.
Comment 1 Julien Nabet 2020-12-20 10:15:58 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
But perhaps it's Windows only or Skia specific.

Could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28Skia.29 ?
Comment 2 mwtjunkmail 2020-12-20 11:41:23 UTC
(In reply to Julien Nabet from comment #1)
> On pc Debian x86-64 with master sources updated today, I don't reproduce
> this.
> But perhaps it's Windows only or Skia specific.
> 
> Could you give a try at
> https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.
> 28Skia.29 ?

1. I have the latest nVidia graphics driver, hotfix 460.97:

ProductName=LibreOffice
Version=7.2.0.0
BuildID=cb22636a56b35d4e118446cc3c9fe606db6f46b0
URL=https://crashreport.libreoffice.org/submit/
VulkanVendor=0x10de
VulkanDevice=0x1c82
VulkanAPI=1.2.155
VulkanDriver=460.388.0
VulkanDeviceType=discrete
VulkanDeviceName=GeForce GTX 1050 Ti
UseSkia=true
Language=en-US

2. I did not modify the default option for rendering, it's still set to the default of Skia/Rendering, including where Skia rastering is checked as forced.
Comment 3 mwtjunkmail 2020-12-20 11:42:11 UTC
Correction: Where skia rastering is NOT checked as forced. I'll switch and try it as forced.
Comment 4 mwtjunkmail 2020-12-20 11:46:09 UTC
(In reply to mwtjunkmail from comment #3)
> Correction: Where skia rastering is NOT checked as forced. I'll switch and
> try it as forced.

Exact same result when forcing Skia software rendering
Comment 5 Julien Nabet 2020-12-20 11:50:24 UTC
Could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps#Corrupted_user_profile ?

For the moment Skia rendering has been blacklisted in Windows for Nvidia cards, see https://cgit.freedesktop.org/libreoffice/core/commit/?id=f8d6eb6f171dbcf7e3aa4afa0da32bd504f473dc

"author	Luboš Luňák <l.lunak@collabora.com>	2020-09-28 10:01:46 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2020-09-29 09:57:42 +0200
commit	f8d6eb6f171dbcf7e3aa4afa0da32bd504f473dc (patch)
tree	93e67a81a000bd9a749079ac139a785d3ecaafb0
parent	cb82e82228b7486844a02ff964c68025558523dc (diff)
blacklist Windows/nVidia for Skia/Vulkan (tdf#135370, tdf#136036, tdf#136407)
The bugreports all appear to be specific to Vulkan on Windows
with nVidia drivers, and I do not have that OS/HW combination to
debug this. So disable Vulkan use there until somebody can do
something about it.
"

So if you start LO from a brand new profile, Skia shouldn't be used.
Comment 6 Julien Nabet 2020-12-20 11:52:00 UTC
Just re read the first comment, you indicated "Skia/Vulkan" whereas you reset your LO profile?! Do you confirm?
If yes, it means Skia isn't blacklisted in your case for an unknown reason.
Comment 7 mwtjunkmail 2020-12-20 11:56:25 UTC
Created attachment 168357 [details]
Interface capture

This is what I see from a brand new profile. Nothing prevents me from selecting the checkbox to force Skia software rendering, if that's what you mean.
Comment 8 mwtjunkmail 2020-12-20 12:00:55 UTC
NOT using Vulkan creates its own set of problems, which are still listed in the bug tracker under my user name as New, like a 1-pixel line top and left on black backgrounds, slow scrolling and zooming, all sorts of things. I can see if life's different now, but with none of those bugs addressed, I doubt it.

I'll try to test for this particular bug using hardware only.
Comment 9 Julien Nabet 2020-12-20 12:04:39 UTC
Luboš: any idea why Skia is enabled here whereas the user uses a brand new profile and is on Windows with a Nvidia card?
Comment 10 mwtjunkmail 2020-12-20 12:09:31 UTC
Created attachment 168358 [details]
PNG export using hardware only

The attached is why I don't use hardware only settings. That line top and left is absolutely unacceptable as output (this is a PNG, which I use everywhere). That's just one of the issues.

To avoid this long-standing bug (117160) as well as others, I'm glad I can use Vulkan rendering, even if everything thinks I'm not supposed to be able to in Windows.
Comment 11 mwtjunkmail 2020-12-20 12:11:19 UTC
To clarify, the crashing bug does not occur with hardware rendering.
Comment 12 mwtjunkmail 2020-12-20 12:26:48 UTC
And if it's only help, I download and use daily builds from 7.2.x fairly regularly, it was only the 2020.12.18 build when I first noticed the problem. I don't keep old daily builds, but this crashing bug probably crept into the plumbing very recently.
Comment 13 mwtjunkmail 2020-12-20 12:28:53 UTC
And there is no crash when using 7.2.x and Skia rendering when the background is set to a color, which is the majority of what I do anyway. I only noticed it on the bitmap (bitmap & color are the only background options I use). Hope this helps.
Comment 14 Julien Nabet 2020-12-20 12:47:29 UTC
Just my opinion but if Luboš blacklisted Skia for Nvidia cards on Windows, knowing that he's the only dev on LO working on Skia support in Windows, I'd put this one to WONTFIX and rather focus on tdf#117160.
Comment 15 mwtjunkmail 2020-12-20 13:57:53 UTC
(In reply to Julien Nabet from comment #14)
> Just my opinion but if Luboš blacklisted Skia for Nvidia cards on Windows,
> knowing that he's the only dev on LO working on Skia support in Windows, I'd
> put this one to WONTFIX and rather focus on tdf#117160.

You're saying for the of this product, no one will be able to export a PNG in hardware mode from LO Draw without having to then import the result to another program to clean up?
Comment 16 mwtjunkmail 2020-12-20 13:59:01 UTC
(In reply to mwtjunkmail from comment #15)
> (In reply to Julien Nabet from comment #14)
> > Just my opinion but if Luboš blacklisted Skia for Nvidia cards on Windows,
> > knowing that he's the only dev on LO working on Skia support in Windows, I'd
> > put this one to WONTFIX and rather focus on tdf#117160.
> 
> You're saying for the of this product, no one will be able to export a PNG
> in hardware mode from LO Draw without having to then import the result to
> another program to clean up?

Or are you saying for the life of this product, no one on Windows can use a bitmap background with Skia?
Comment 17 Julien Nabet 2020-12-20 14:38:57 UTC
I'm just saying Skia on machines with Windows + Nvidia cards are not supported by LO.
So if something doesn't work on the quoted config: png export, use of BMP background, whatever, ... I don't think it'll be fixed if it happens only on this config.
For example, if png export fails on Windows with Nvidia cards but not with Skia or on Windows with Skia but not with Nvidia cards, it might be fixed I suppose.

Is it more clear?
Of course I may be wrong of course since I'm not expert of Skia or LO.
Comment 18 V Stuart Foote 2020-12-20 15:24:47 UTC
Confirmed, but only with Skia rendering.

Current skia Vulkan denylist [1] allows nVidia GPU with drivers > 457.36.0

But, this is a dupe of bug 138973 and has been patched [2]. Affecting builds from 2020-12-15 -> 2020-12-18

=-ref-=

[1] https://opengrok.libreoffice.org/xref/core/vcl/skia/skia_denylist_vulkan.xml

[2] https://gerrit.libreoffice.org/c/core/+/107961

*** This bug has been marked as a duplicate of bug 138973 ***
Comment 19 Luboš Luňák 2020-12-21 12:56:36 UTC
(In reply to mwtjunkmail from comment #8)
> NOT using Vulkan creates its own set of problems, which are still listed in
> the bug tracker under my user name as New, like a 1-pixel line top and left
> on black backgrounds, slow scrolling and zooming, all sorts of things. I can
> see if life's different now, but with none of those bugs addressed, I doubt
> it.

I am not aware of any such Skia problems, and do not see them listed in the #129062 metabug. Can you add them there to the dependency list, or at least list them here? Unless you meant 'not using Skia', which is different from 'not using Vulkan'.


(In reply to Julien Nabet from comment #9)
> Luboš: any idea why Skia is enabled here whereas the user uses a brand new
> profile and is on Windows with a Nvidia card?

It's Vulkan use that's blacklisted with nVidia, not Skia itself. And even then that's only for non-recent drivers, so there's no problem here.
Comment 20 mwtjunkmail 2020-12-23 03:02:30 UTC
(In reply to Luboš Luňák from comment #19)
> (In reply to mwtjunkmail from comment #8)
> > NOT using Vulkan creates its own set of problems, which are still listed in
> > the bug tracker under my user name as New, like a 1-pixel line top and left
> > on black backgrounds, slow scrolling and zooming, all sorts of things. I can
> > see if life's different now, but with none of those bugs addressed, I doubt
> > it.
> 
> I am not aware of any such Skia problems, and do not see them listed in the
> #129062 metabug. Can you add them there to the dependency list, or at least
> list them here? Unless you meant 'not using Skia', which is different from
> 'not using Vulkan'.
> 

#117160
#135912
#134237
#139172

I've many more open bugs that the above that are still sitting there not picked up yet by anyone, but the above are the ones specific to the presence/lack of having the Skia option selected.

I've a total of 15 new/unconfirmed bugs reported at the moment, all against Windows version of LO Draw, Impress, or Base.
Comment 21 Luboš Luňák 2021-01-04 17:21:33 UTC
> #117160
> #135912
> #134237
> #139172

None of those appear to be specific to Skia, in fact some of them explicitly say they do not exist with Skia.