Bug 139293 - Function-focused way to add keyboard shortcuts
Summary: Function-focused way to add keyboard shortcuts
Status: RESOLVED DUPLICATE of bug 115527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-29 00:07 UTC by Dan Dascalescu
Modified: 2021-08-26 10:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Unintuitive how to add a shortcut (58.67 KB, image/png)
2020-12-29 00:07 UTC, Dan Dascalescu
Details
GNOME's way of adding shortcuts (69.03 KB, image/png)
2020-12-29 00:08 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2020-12-29 00:07:40 UTC
Created attachment 168541 [details]
Unintuitive how to add a shortcut

Tried to add keyboard shortcuts today after not doing that for several months, so I approached the task with a beginner's mind (vs. https://en.wikipedia.org/wiki/Curse_of_knowledge). The task was surprisingly cumbersome.

What I wanted to do was to assign a keyboard shortcut to formatting text as Strikethrough. Here are the steps I performed, logical in my mind:

1. Tools -> Customize -> Keyboard
2. There, I saw "Functions", which showed a helpful placeholder, "Type to search"
3. I typed "strike" and found the Strikethrough function. Great so far.

Now, how do I add a keyboard shortcut to it? The Keys pane was empty. There was no visible UI afordance to let me add a shortcut. Right clicking didn't reveal one wither. The "Modify" button was greyed out.

At that point I was stumped in frustration for a good minute.

Later I tried the task again, and looked at the Shortcut Keys list, then scrolled down for the desired shortcut, typed "strike" again, and the Modify button was enabled this time.

I think this flow is a little counter-intuitive for users who think of the function they want to assign a shortcut to first. Even if you think of the key combo first, scrolling down to it can be a lengthy process, and you don't necessarily know the order - is it Alt+Shift+X, or Shift+Alt+X?

My suggestion would be to keep the current flow for compatibility, but enable the user at Step 3 above to add a shortcut by pressing it directly, for example via an "Assign shortcut" button associated with the Keys panel. The GNOME interface offers a good example of how to do this in System Settings -> Keyboard Shortcuts. The user picks the function first, then they can simply press the desired keyboard combination.
Comment 1 Dan Dascalescu 2020-12-29 00:08:10 UTC
Created attachment 168542 [details]
GNOME's way of adding shortcuts
Comment 2 Roman Kuznetsov 2021-08-26 10:21:19 UTC
I think it's a duplicate of bug 115527

You can write your suggestion there also

*** This bug has been marked as a duplicate of bug 115527 ***