Bug 139330 - UI is unfriendly, opening a new layer instead of the last one when the layer tab list is full
Summary: UI is unfriendly, opening a new layer instead of the last one when the layer ...
Status: RESOLVED DUPLICATE of bug 56498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.1.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Layers
  Show dependency treegraph
 
Reported: 2020-12-31 01:55 UTC by DrC
Modified: 2021-01-12 17:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ScreenShot1 (167.85 KB, image/png)
2020-12-31 20:26 UTC, DrC
Details
ScreenShot2 (208.57 KB, image/png)
2020-12-31 20:28 UTC, DrC
Details
The drawing I am working on (84.10 KB, application/vnd.oasis.opendocument.graphics)
2020-12-31 20:56 UTC, DrC
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DrC 2020-12-31 01:55:50 UTC
Description:
I work with a lot of layers, sometimes too many for the window of layer tabs.
When the tab window is full, if I click on the rightmost tab it slides left and shows me a default new layer.  That's OK, but if I doubleclick on the rightmost tab, instead of opening the dialogue to let me alter its visibility or protected status, it creates and opens the default new layer.

The result is opening a dialogue for an existing layer becomes a click-pause-shiftleft-doubleclick process for the last layer in the list.

It would seem  more intuitive for the creation and renaming of a new layer to be the less convenient process of the two.

Not urgent, obviously.


Steps to Reproduce:
1.Use as many layers as will fill the tab space available
2.Right click on the right-most layer tab & protect it
3.Notice that you have just protected a brand new layer, not the one you meant to.

Actual Results:
3 above

Expected Results:
Expected the layer selected to be protected


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: DrawingDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no?  Yes it is AMD64.  Edge is lying

gerrit.libreoffice.org / core / d7547858d014d4cf69878db179d326fc3483e082
Comment 1 Regina Henschel 2020-12-31 15:28:41 UTC
I cannot reproduce such error. Right-click > 'Modify Layer' on the right-most layer opens correctly the dialog and enable 'Locked' there is correctly applied. No new layer is created.
Also protecting via Shift+Left click works without problems.
Also double-click to open the 'Modify Layer' dialog works without problems.

Tested with Version: 7.2.0.0.alpha0+ (x64)
Build ID: ad9e04321df25824d2288a2ef1f4275f070f1cf7
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

Are you sure, you click on the layer tab of the right most layer? There might be some gray area at the right side of the right most layer tab. And clicking there will open the 'Insert Layer' dialog.
Comment 2 DrC 2020-12-31 20:26:39 UTC
Created attachment 168612 [details]
ScreenShot1

Cursor on BlueTroop
Comment 3 DrC 2020-12-31 20:28:12 UTC
Created attachment 168613 [details]
ScreenShot2

After double click on BlueTroop
Comment 4 DrC 2020-12-31 20:50:02 UTC
I see your problem, and why you don't see mine.

I have upgraded to 7.1.0.1(X64) to check ongoing relevance and I see it still.

On trying to reproduce it at will I met your problem.  The display optimiser was always there before me although by changing window size (not a routine operation for me though I never use maximised windows) I could catch it unawares in a promising state.  But I never beat it.

So I reloaded the file again and got it.  (2 screen shots) The first screen shot clearly shows the display optimiser has not been invoked and the list of tabs has been truncated.  The problem is pretty well guaranteed in this situation I suspect. 

The second screen shot (this one is cropped from a full screen because otherwise Windows only screen shots the dialogue) shows the optimised has done its job in the process.

I am minded to spend a bit longer living with the issue until I can get a better handle on when it happens.  It could be a timing issue (the work is a bit heavy) or copying and pasting elements between pages or some other abominable form of user abuse.  Or it could be related to the HP laptop hardware.

I will also upload the file in case it has something stupid that breaks stuff, but at the moment I suspect it could be noise.


Thanks for being there - I really appreciate what you guys and gals do.

DrC
Comment 5 DrC 2020-12-31 20:56:10 UTC
Created attachment 168614 [details]
The drawing I am working on

This is the flie with all the layers.
Comment 6 Heiko Tietze 2021-01-12 17:59:03 UTC
Tabs have its limitations. Would prefer a solution per Navigator as suggested here [1] and resolve this ticket as duplicate of bug 56498 (having more people on CC/tickets in duplicates raises the importance). Please reopen if you disagree.

[1] https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/

*** This bug has been marked as a duplicate of bug 56498 ***