Bug 139332 - UI: Expert Configuration doesn't show Ok/Cancel button
Summary: UI: Expert Configuration doesn't show Ok/Cancel button
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.2.0 target:7.1.0 target:7.0.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-31 07:43 UTC by Jambunathan K
Modified: 2021-03-20 09:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Expert Configuration doesn't show OK/Cancel button (82.00 KB, image/png)
2020-12-31 07:43 UTC, Jambunathan K
Details
full dialog visible on Windows builds (63.06 KB, image/png)
2020-12-31 19:58 UTC, V Stuart Foote
Details
Expert Configuration OK-Cancel button is now visible.png (91.15 KB, image/png)
2021-03-20 08:13 UTC, Jambunathan K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jambunathan K 2020-12-31 07:43:25 UTC
Created attachment 168588 [details]
Expert Configuration doesn't show OK/Cancel button

The  attached screenshot shows the problem.

1) Go toTools – Options – LibreOffice – Advanced – Open Expert Configuration
 
2) search for the string 'prettyprinting' (without quotes).  You will be presented with /org.openoffice.Office.Common/Save/Document PrettyPrinting 

3) Toggle the value from 'false' to 'true', for example.  

4) Close the window.  

5) Repeat (1) and (2) above to verify if the new value is saved.  

6) Note that new changes are NOT saved.



I think there is a ok/cancel button which gets hidden the bottom panel 'gnome-panel'.  

This bug is similar to the other recently closed bug https://bugs.documentfoundation.org/show_bug.cgi?id=130275
Comment 1 Jambunathan K 2020-12-31 07:49:35 UTC
The issue is seen with

    LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb  master~2020-12-30_12.52.30_LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb.tar.gz.

I am sure that this bug is an OLD one.  IIRC, I have seen this in stable LibreOffice 7.0 builds.

~$ uname -a
Linux debian 5.9.0-5-amd64 #1 SMP Debian 5.9.15-1 (2020-12-17) x86_64 GNU/Linux


~$ dpkg -l | grep writer
ii  libreofficedev7.2-writer                           7.2.0.0.alpha0-1                   amd64        Writer brand module for LibreOfficeDev 7.2.0.0.alpha0
ii  lodevbasis7.2-writer                               7.2.0.0.alpha0-1                   amd64        Writer module for LibreOfficeDev 7.2.0.0.alpha0


~$ env | grep SESSION
SESSION_MANAGER=local/debian:@/tmp/.ICE-unix/2393,unix/debian:/tmp/.ICE-unix/2393
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
DESKTOP_SESSION=gnome-flashback-metacity
XDG_SESSION_DESKTOP=gnome-flashback-metacity
XDG_SESSION_TYPE=x11
XDG_SESSION_CLASS=user
GDMSESSION=gnome-flashback-metacity
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
Comment 2 Jambunathan K 2020-12-31 07:53:15 UTC
> I think there is a ok/cancel button which gets hidden the bottom panel
> 'gnome-panel'.  


In the attached screenshot, you can see that I have moved the bottom panel of the 'gnome-panel' to the right to see if it makes difference. 

I still see that the form is "overflowing" the laptop display, and there is NO ok/cancel button
Comment 3 Jambunathan K 2020-12-31 07:57:29 UTC
I am on a Dell laptop.

~$ lshw -c display
WARNING: you should run this program as super-user.
  *-display                 
       description: VGA compatible controller
       product: Atom Processor Z36xxx/Z37xxx Series Graphics & Display
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0e
       width: 32 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:91 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:f080(size=8) memory:c0000-dffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.


~$ dmidecode | grep -A3 '^System Information'
Command 'dmidecode' is available in '/usr/sbin/dmidecode'
The command could not be located because '/usr/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative privileges associated with your user account.
dmidecode: command not found
~$ sudo dmidecode | grep -A3 '^System Information'
System Information
	Manufacturer: Dell Inc.
	Product Name: Inspiron 3551
	Version: A05
Comment 4 V Stuart Foote 2020-12-31 19:58:37 UTC
Created attachment 168611 [details]
full dialog visible on Windows builds

Can not confirm on Windows builds.

Version: 7.1.0.1 (x64)
Build ID: b585d7d90ab863bf29b2d110c174c0c2a98f3ee4
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 5 raal 2021-01-01 23:03:07 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

bibisect-linux-64-6.4$:
e16dc96c3336de7513a0bfd7744c5abc214b59e0 is the first bad commit
commit e16dc96c3336de7513a0bfd7744c5abc214b59e0
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Oct 1 03:06:27 2019 +0200

    source sha:c6bee0aad804c32a4367adc04878648427b06b5a

https://git.libreoffice.org/core/+/c6bee0aad804c32a4367adc04878648427b06b5a
Comment 6 Caolán McNamara 2021-01-18 11:58:07 UTC
So it looks like that simply the dialog is too tall for whatever the resolution is and the "true" gtk widgets are taller than the vcl widgets rendered to look like gtk so it it not taller than it was
Comment 7 Commit Notification 2021-01-18 19:27:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aa5fae48f377449dc142f672bc0303ceb3fe371e

tdf#139332 reduce height of expert config dialog

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2021-01-18 19:35:49 UTC
done in master, backports to 7-1 and 7-0 in gerrit
Comment 9 Commit Notification 2021-01-19 10:33:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/9a98581b1379c17719f75ae85d3afe20b653c0d7

tdf#139332 reduce height of expert config dialog

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-01-19 12:28:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/19630bc71b3753cb52b7ea477c312a8bde81f61f

tdf#139332 reduce height of expert config dialog

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-01-21 19:58:13 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-0":

https://git.libreoffice.org/core/commit/0565308bbb1d654dc129f200b08e475ae3a4f97a

tdf#139332 reduce height of expert config dialog

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Jambunathan K 2021-03-20 08:10:39 UTC
(In reply to Commit Notification from comment #7)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> aa5fae48f377449dc142f672bc0303ceb3fe371e
> 
> tdf#139332 reduce height of expert config dialog
> 
> It will be available in 7.2.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Confirming that this bug is fixed in master~2021-03-18_08.37.30_LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb.tar. i.e., 


Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: c9e5640c8fcad7beb42a66f9bee0252eee9fe323
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-IN (en_IN.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-03-18_08:37:30
Calc: threaded
Comment 13 Jambunathan K 2021-03-20 08:13:14 UTC
Created attachment 170582 [details]
Expert Configuration OK-Cancel button is now visible.png

Screenshot after the fix