Bug 139361 - UI: Retrain manually set collapsed states in style inspector
Summary: UI: Retrain manually set collapsed states in style inspector
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 139037 (view as bug list)
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2021-01-01 21:21 UTC by Telesto
Modified: 2021-01-12 16:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.39 KB, application/vnd.oasis.opendocument.text)
2021-01-01 21:21 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-01-01 21:21:00 UTC
Description:
UI: Retrain manually set collapsed states in style inspector

Steps to Reproduce:
1. Open the attached file
2. Collapse Heading/Heading 1 (to inspect for DF)
3. Click somewhere else.. 

Actual Results:
Constantly expanding

Expected Results:
Case: hypothetical case: I'm hunting DF.. but this makes it hard


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4e3ce9dd6ace0b22f7b3f45cf2338b201f4dc305
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-01-01 21:21:13 UTC
Created attachment 168628 [details]
Example file
Comment 2 Telesto 2021-01-01 21:21:56 UTC
Not sure how to implement this in logical way
Comment 3 Heiko Tietze 2021-01-12 14:23:14 UTC
-1 from my side. While in general user settings should be remembered and the expansion state is often such a setting, it's not always and not in case of the SI. The purpose is to inspect text for some rare cases for own documents or more often if you receive buggy documents from different sources. But it's not to investigate just DF and to ignore other properties. Usually, the style modifies just a few attributes, which fits easily into the tree. So => WF
Comment 4 Heiko Tietze 2021-01-12 14:31:31 UTC
*** Bug 139037 has been marked as a duplicate of this bug. ***
Comment 5 Mike Kaganski 2021-01-12 15:18:23 UTC
(In reply to Heiko Tietze from comment #3)

This is useful enhancement; although its implementation is not straightforward (it needs remembering names of nodes expanded/collapsed before the change, then apply the state to the nodes re-built after the change), it's doable and welcome. The number of properties is potentially overwhelming, with unlimited number of styles showing due to inheritance and nesting, and tens of direct properties (e.g., legacy and/or created by copy/paste, import, etc.).

While I don't volunteer to implement this, IMO this should not be WFed.