Bug 139503 - No playing item in presentation mode (GDI & Skia)
Summary: No playing item in presentation mode (GDI & Skia)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-08 20:21 UTC by Telesto
Modified: 2021-10-31 09:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (786.05 KB, application/vnd.oasis.opendocument.presentation)
2021-01-08 20:47 UTC, Telesto
Details
Bibisect log (3.05 KB, text/plain)
2021-01-08 20:48 UTC, Telesto
Details
Screencast (2.60 MB, video/mp4)
2021-01-09 08:30 UTC, Telesto
Details
GPU Details (315 bytes, text/plain)
2021-10-29 07:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-01-08 20:21:25 UTC
Description:
No playing item in presentation mode (nowdays GDI)

Steps to Reproduce:
1. Open attachment 1687777 under Windows in GDI mode
2. Press F5
3. Left click to second sheet.. 

Actual Results:
Not playing video

Expected Results:
Should play.. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.2

Found in
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

but not in
Version: 6.1.0.0.alpha1+
Build ID: 3a801799536e6870f2fb111b1cc00b9575a35a39
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2021-01-08 20:47:33 UTC
Created attachment 168778 [details]
Example file
Comment 2 Telesto 2021-01-08 20:48:00 UTC
Created attachment 168779 [details]
Bibisect log

Bisected to

author	Miklos Vajna <vmiklos@collabora.com>	2019-04-17 11:38:47 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2019-04-23 10:34:23 +0200
commit 5c5eab3522368d6baa7ab6ef1b6c9f5eaaab4fad (patch)
tree 64d3d77a6ffcbadd0a03cdaaeeef67912f61c8ed
parent 9a5e5c581eaf86ce0bbf293da40ba18c72fba1bd (diff)
tdf#124756 slideshow: avoid mbPaintDisabled for media windows
Commit 3e0092031b73bad107e3122d5d4be2f5bd487744 (tdf#112318 sd opengl:
fix lack of initial animation, 2019-04-05) enabled processing of idle
events between two updates of the slideshow to help OpenGL, which
uncovered a problem with media shapes.

On one hand,
slideshow::internal::ViewMediaShape::implInitializePlayerWindow() calls
EnablePaint(false) on the media window. OTOH,
vcl::Window::ImplCallPaint() handles mbPaintDisabled by invalidating the
relevant area of the window, which causes a paint<->invalidate loop.

Fix the problem by nominally still enabling paints on the media window:
nothing will change in practice (since the actual media overlay will be
on top of it), but this way the loop goes away.

mbPaintDisabled is handled like this since the initial import, the media
window flag was added much later, so it makes more sense to adapt the
later.

(cherry picked from commit d7f4f5650dd2c7fe1ccec50efd806e695b8bc18a)

Conflicts:
	slideshow/source/engine/shapes/viewmediashape.cxx
Comment 3 Telesto 2021-01-08 20:55:42 UTC
@Miklos
Re-try on bug 128353. Bibisect was wrong.. problem still there for GDI (also present for OpenGL, but that's a different code path.. goes back to 5.0.2.2)

The video on sheet 2 will not play (use the attached file). after moving to the next slide

The video does play if the sheet arrangement is changed. Moving Sheet 2 position 1 (first sheet). Even revert of that afterwards will work properly.

So feels like some sort of 'initialization' not thing place if video being placed on sheet 2

Same issue is also present in Skia (bug 139502) It shows a still (here black screen)
Comment 4 Telesto 2021-01-09 08:30:14 UTC
Created attachment 168783 [details]
Screencast
Comment 5 Miklos Vajna 2021-01-13 14:09:30 UTC
Thanks for the report. Sadly I can't confirm it, so I assume this is somehow HW-specific. The GDI case uses the DX canvas, so it may depend on your DX driver.

I tested with the above "first bad" commit and also with current master, both working here. Windows 10, GDI, the Intel card that ships with thinkpads.
Comment 6 Telesto 2021-01-13 15:06:41 UTC
@MWT & Stuart
Some Windows testers needed.. I'm certainly not the only one (initial report was bug 128353). Codec Tweak Tool says the Microsoft Codec being used. 

I'm having this issue with GDI & Skia Raster and Vulkan. Me still on Windows 8.1

(In reply to Miklos Vajna from comment #5)
> Thanks for the report. Sadly I can't confirm it, so I assume this is somehow
> HW-specific. The GDI case uses the DX canvas, so it may depend on your DX
> driver.
> 
> I tested with the above "first bad" commit and also with current master,
> both working here. Windows 10, GDI, the Intel card that ships with thinkpads.
Comment 7 xordevoreaux 2021-01-13 15:36:37 UTC
I have two monitors. On one monitor is a static display of both slides of the attachment, and the other, a full-screen rendering of the current slide.


After hitting F5, left-clicking on the next slide did nothing, so that's a confirm, but hitting the right-arrow button did force the video to play.
Hope this helps.



Version: 7.2.0.0.alpha0+ (x64)
Build ID: 80497c7d81af36f703d122ac78baa26387a5854d
CPU threads: 8; OS: Windows 10.0 Build 21286; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 8 xordevoreaux 2021-01-13 15:38:21 UTC
(In reply to mwtjunkmail from comment #7)
> I have two monitors. On one monitor is a static display of both slides of
> the attachment, and the other, a full-screen rendering of the current slide.
> 
> 
> After hitting F5, left-clicking on the next slide did nothing, so that's a
> confirm, but hitting the right-arrow button did force the video to play.
> Hope this helps.
> 
> 
> 
> Version: 7.2.0.0.alpha0+ (x64)
> Build ID: 80497c7d81af36f703d122ac78baa26387a5854d
> CPU threads: 8; OS: Windows 10.0 Build 21286; UI render: Skia/Vulkan; VCL:
> win
> Locale: en-US (en_US); UI: en-US
> Calc: CL

And I must say, where the video played isn't where I expected it to. The full-page rendering moved to the video, but didn't play. It was on the multi-slide view on the second monitor where the video played.
Comment 9 Telesto 2021-01-14 08:33:14 UTC
(In reply to Miklos Vajna from comment #5)
> I tested with the above "first bad" commit and also with current master,
> both working here. Windows 10, GDI, the Intel card that ships with thinkpads.

Simply for to exclude.. 

* you're testing with TDF build; or own build? Debug edition or regular?
* It's needed to render the full presentation (2 sheets) with F5 not..  so not jumping to the sheet with video (start presentation from current slide). Or putting the sheet with video first
* I'm 'going to next sheet with left mouse click (but problem occurs also with enter & arrow keys in my testing)
Comment 10 Miklos Vajna 2021-01-14 08:41:14 UTC
Sure, when something is not reproducible, there are no silly questions. :-)

> you're testing with TDF build; or own build?

Own build, but --enable-symbols only, i.e. matches what TDF binaries do (no debug).

> It's needed to render the full presentation (2 sheets) with F5 not..  so not jumping to the sheet with video (start presentation from current slide). Or putting the sheet with video first

Correct, I'm aware of the catch that the first slide is a special codepath.

> I'm 'going to next sheet with left mouse click (but problem occurs also with enter & arrow keys in my testing)

Matches my experience, mouse vs keyboard makes no difference.
Comment 11 molybrown 2021-01-20 11:29:40 UTC Comment hidden (spam)
Comment 12 Aron Budea 2021-10-29 00:08:24 UTC
Telesto, what are your GPU details? Ie. cache\opengl_device.log
Comment 13 Telesto 2021-10-29 07:12:17 UTC
Created attachment 175984 [details]
GPU Details

(In reply to Aron Budea from comment #12)
> Telesto, what are your GPU details? Ie. cache\opengl_device.log

Ancient stuff..
Comment 14 Telesto 2021-10-29 07:14:42 UTC
(In reply to Aron Budea from comment #12)
> Telesto, what are your GPU details? Ie. cache\opengl_device.log

BTW, I don't think this really matters, comment 7

FWIW: you must press F5 on the first sheet. If you open second sheet with F5 directly it will work
Comment 15 Aron Budea 2021-10-29 08:59:31 UTC
(In reply to Telesto from comment #14)
> (In reply to Aron Budea from comment #12)
> > Telesto, what are your GPU details? Ie. cache\opengl_device.log
> 
> BTW, I don't think this really matters, comment 7
I don't know what matters, the only relevant detail I see mentioned in comment 7 is having two displays, do you have two displays as well?
Comment 16 Telesto 2021-10-29 10:07:36 UTC
(In reply to Aron Budea from comment #15)
> (In reply to Telesto from comment #14)
> > (In reply to Aron Budea from comment #12)
> > > Telesto, what are your GPU details? Ie. cache\opengl_device.log
> > 
> > BTW, I don't think this really matters, comment 7
> I don't know what matters, the only relevant detail I see mentioned in
> comment 7 is having two displays, do you have two displays as well?

Nope.. 

I assume you're unable to reproduce?
Comment 17 Aron Budea 2021-10-29 10:58:52 UTC
(In reply to Telesto from comment #16)
> I assume you're unable to reproduce?
Indeed, it behaves fine for me.
Comment 18 Telesto 2021-10-31 09:11:31 UTC
Well appears to be old K-Lite codec pack issue.. I updated and it's gone..