Bug 139559 - Inserting date with crtl+; inserts time in calc
Summary: Inserting date with crtl+; inserts time in calc
Status: RESOLVED DUPLICATE of bug 126085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2021-01-12 10:17 UTC by RFr
Modified: 2021-09-10 02:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RFr 2021-01-12 10:17:26 UTC
Description:
In the calculation module inserting a date should be possible by crtl+; the result of this key combination is an inserted actual time. The SW Version is 7.0.3.1

Actual Results:
Open a spreadsheet, select a cell, enter crtl + ;

Expected Results:
the actual time is inserted


Reproducible: Always


User Profile Reset: No



Additional Info:
The actualdate is expected, this is also shown in the insert menu where 'insert date' has the shortcut crtl + ,

Version: 7.0.3.1
Build ID: 00(Build:1)
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: de-DE (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.3-0ubuntu0.20.10.1
Calc: threaded
Comment 1 [REDACTED] 2021-01-12 17:37:18 UTC
This seems to be a another variant/duplicate of bug tdf#126085 - Insert date: Ctrl+; is confused with Ctrl+Shift+; on many (mostly European) keyboard layouts (de/it/et and more) https://bugs.documentfoundation.org/show_bug.cgi?id=126085
Comment 2 Peter S Anderson 2021-01-19 11:19:37 UTC
Using 7.0.3.1 with my English(Australia) US keyboard settings, the keyboard combinations   ctrl+; and ctrl+: (shift;) are inserting the date and time correctly.
Comment 3 Peter S Anderson 2021-01-19 11:58:02 UTC
I suspect that the bug behaviour may be due to the reported locale settings:
“Locale: de-DE (en_US.UTF-8); UI: en-US”

The positions of the ; and : are completely different on the US and German keyboards. Shift+: is : on a US keyboard. It would be useful to know what happens Ctrl+: is pressed on the German keyboard. Is anything inserted?

A complete list of the user locale would also be useful.
Comment 4 RFr 2021-01-19 16:27:36 UTC
CRTL+,  nothing
CRTL+; actual local time
 
 
## A complete list of the user locale would also be useful.
if I would know how to get this...
 
 
 
Mit freundlichem Gruss

R.Freitag
Comment 5 Peter S Anderson 2021-01-19 21:42:42 UTC
Many thanks for the quick response. A few things.

(1) Would you please try ctrl+:

(2) Re your locale settings, you need to run the following linux command on a Linux Terminal.

localectl status

This should display something like:

 System Locale: LANG=en_US.UTF-8
    VC Keymap: us
   X11 Layout: n/a

I suspect there will be “de” instead of “en”. If you do not feel confident to do this, do not try. 

(3) What type of keyboard do you have? German? What version of Linux are you running?

Regards…. Peter.
Comment 6 QA Administrators 2021-07-19 03:26:46 UTC Comment hidden (obsolete)
Comment 7 RFr 2021-07-19 05:56:08 UTC
   System Locale: LANG=en_US.UTF-8
                  LC_NUMERIC=de_DE.UTF-8
                  LC_TIME=de_DE.UTF-8
                  LC_MONETARY=de_DE.UTF-8
                  LC_PAPER=de_DE.UTF-8
                  LC_NAME=de_DE.UTF-8
                  LC_ADDRESS=de_DE.UTF-8
                  LC_TELEPHONE=de_DE.UTF-8
                  LC_MEASUREMENT=de_DE.UTF-8
                  LC_IDENTIFICATION=de_DE.UTF-8
       VC Keymap: n/a
      X11 Layout: de
       X11 Model: pc105


System is Kubuntu Version 20.10
Comment 8 QA Administrators 2021-07-20 03:38:26 UTC Comment hidden (obsolete)
Comment 9 stragu 2021-09-09 12:59:03 UTC
RFr, one question:

- Is your physical keyboard a German "QWERTZ" keyboard, on which you have to use the Shift key to access the ";" character?
- If it is not a QWERTZ keyboard, do you use a QWERTZ keyboard layout in Ubuntu anyway? (This is what I do: I have a physical US layout, but I use a DE software layout because it's better to write in many different languages!)

If the answer to any of these questions is "yes", I am pretty confident this is a duplicate of bug 126085. Your last comment seems to indicate the answer to the first question is "yes".
Comment 10 RFr 2021-09-09 16:40:37 UTC
Hallo,

it is a German "QWERTZ" keyboard
and I use a German "QWERTZ" keyboard.
Comment 11 stragu 2021-09-10 02:35:12 UTC
Thank you RFr, I am pretty confident this is the same issue as Bug 126085, so marking as a duplicate.
Please feel free to participate in the discussion there.

*** This bug has been marked as a duplicate of bug 126085 ***