Bug 140183 - Clear direct formatting of whole document breaks paragraph direct formatting of table styles
Summary: Clear direct formatting of whole document breaks paragraph direct formatting ...
Status: RESOLVED DUPLICATE of bug 104389
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clear-Formatting Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2021-02-05 11:07 UTC by Alkis Georgopoulos
Modified: 2022-04-21 14:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alkis Georgopoulos 2021-02-05 11:07:47 UTC
Description:
When pressing Ctrl+A to select all the document, and Ctrl+M to clear direct formatting, tables with autoformat styles get the wrong style.

Steps to Reproduce:
Create a new document with the following contents:

First line
|1|2|3|
|4|5|6|
|7|8|9|
Last line

The numbers are supposed to be a 3x3 table, formatted e.g. with "Elegant" style.
This means that the first row, "|1|2|3|", is bold.

Actual Results:
Now, press Ctrl+A to select all the document text, and Ctrl+M to remove direct formatting. The bold effect is gone.
Now, select only the table, and press Ctrl+M. The bold effect is back.

Expected Results:
This means that if I want to remove all formatting from my document, I will then need to select each table separately again in order to apply the correct format once more.


Reproducible: Always


User Profile Reset: No



Additional Info:
It's like the "apply autoformat style" function of libreoffice is also counting the lines OUTSIDE of the table in order to see what style to apply, while it should only count the lines inside the table.
Comment 1 Dieter 2021-02-20 05:53:24 UTC Comment hidden (obsolete)
Comment 2 Alkis Georgopoulos 2021-02-20 06:15:07 UTC Comment hidden (obsolete)
Comment 3 Dieter 2021-02-20 10:32:10 UTC
I confirm it with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 28555fc345ac2ccdda0e4e0f3c812c646befe68b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Related to bug 133659
Comment 4 Dieter 2022-01-04 08:10:24 UTC
Still present in

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c95415de877af1430ab5b7123e11dedd0ea622c
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

The problem I see here ist, that table style adds paragraph direct formatting to the table cells. I don't know, if this is a good solution.
Comment 5 Timur 2022-04-21 14:22:08 UTC
Let's consider a duplicate. 
Table styles should not apply direct formatting of fonts and size.

*** This bug has been marked as a duplicate of bug 104389 ***