Bug 140288 - Crash with zero-size window when running a macro
Summary: Crash with zero-size window when running a macro
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.2 target:7.0.6
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2021-02-09 09:16 UTC by Jon Rubin
Modified: 2021-03-22 18:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["ntdll.dll"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Rubin 2021-02-09 09:16:01 UTC
This bug was filed from the crash reporting server and is br-9a7dfc2e-98d2-44ba-aa4e-e91cfc0e53c9.
=========================================
Comment 1 Jon Rubin 2021-02-09 09:18:30 UTC
This happens whenever I try to run a macro that works perfectly in libreoffice 6 and earlier versions

macro can be found here:

https://forum.openoffice.org/en/forum/viewtopic.php?f=21&t=2399
Comment 2 Xisco Faulí 2021-02-09 10:01:28 UTC
I can't reproduce it in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: dc1b416c684c4e2525978e48252d55d78adcfca8
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 3 Jon Rubin 2021-02-10 01:03:17 UTC
OK, so I ran the macro in Libreoffice 7 in Xubuntu 20.04 running in Virtual Box and it ran fine.
I've had other people comment that this macro runs in Linux but wanted to make sure.
It absolutely crashes when using Windows 10, every single time -- and has in every version since 7.0.
It doesn't need a test document as it crashes with a blank new docusment.
What it needs is somebody else running Windows 10 to try it, if possible.
Comment 4 Jon Rubin 2021-02-10 02:05:03 UTC
OK, so thought I'd try the 7.2 alpha.
Installed it using the separate install gui and it runs!
Don't know what this means tbh. But, yay?

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3bc70b74befd2cad85e40c913467b60d0407fbfe
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded
Comment 5 QA Administrators 2021-02-10 04:13:11 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2021-02-10 08:58:01 UTC
Indeed, I can reproduce it in

Version: 7.1.0.3 (x86) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: es-ES
Calc: threaded

let move it to NEW, I'll investigate it a bit further.
Thanks for reporting this issue
Comment 7 Xisco Faulí 2021-02-25 09:43:51 UTC
Not happening if SKIA is disabled ( Tools - Options - View )
I bisected it and it happens since https://cgit.freedesktop.org/libreoffice/core/commit/?id=2b4f2cdd3deb9b131ea19c91ae50e2c34f35754c
Comment 8 Commit Notification 2021-03-01 14:54:19 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9d8c04d2d5529626d649af3fcebb6d4b65193b28

generic Skia workaround for VCL sending empty size (tdf#140288)

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-03-01 20:28:21 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/21305ff47a1bee1fa4787bf792fb3ecdb10d4863

generic Skia workaround for VCL sending empty size (tdf#140288)

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-03-03 08:08:06 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/f0c3eec0f26d8b71ec92b32cfa0cf5747f0702eb

generic Skia workaround for VCL sending empty size (tdf#140288)

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Jon Rubin 2021-03-22 00:34:22 UTC
I'm still getting this crash in 7.1.2 
build
fe0b08f4af1bacafe4c7ecc87ce55bb426164676

I've tried to submit a crash report, but that just stops responding.
Can still use this macro when not running Skia
Comment 12 Luboš Luňák 2021-03-22 17:39:03 UTC
Can somebody from QA please verify this?
The build id given is not a valid git commit.
Comment 13 Roman Kuznetsov 2021-03-22 18:28:13 UTC
No crash in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 07996bcca53939af02921a3d4681c6c7d62a0e40
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL

but the macro shows an error
Comment 14 V Stuart Foote 2021-03-22 18:33:22 UTC
(In reply to Jon Rubin from comment #11)
> I'm still getting this crash in 7.1.2 
> build
> fe0b08f4af1bacafe4c7ecc87ce55bb426164676
> 
> I've tried to submit a crash report, but that just stops responding.
> Can still use this macro when not running Skia

That build ID is too early, dtd 2021-02-25; commit went in 2021-03-01 against a 7.1.2 build--try a 7.1 nightly or master.