Bug 140290 - Make "Column" (or Row) a static label for quick access per keyboard
Summary: Make "Column" (or Row) a static label for quick access per keyboard
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.4.0
Keywords: difficultyMedium, easyHack, skillCpp, topicUI
Depends on:
Blocks:
 
Reported: 2021-02-09 10:16 UTC by fender
Modified: 2022-02-11 08:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sort criteria screen shot (23.39 KB, image/png)
2021-02-09 10:16 UTC, fender
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fender 2021-02-09 10:16:05 UTC
Created attachment 169609 [details]
sort criteria screen shot

hello

maybe instead of Column A, change it to A Column, so the configuration for the sorting could be done faster using the keyboard. ?
Comment 1 Roman Kuznetsov 2021-08-15 18:34:47 UTC
I don't think so

-1 from me

UX-team, what do you think here?
Comment 2 Adolfo Jayme Barrientos 2021-08-16 07:37:47 UTC
This needs a custom solution to add the keyboard functionality without changing the UI strings in a way that makes them ungrammatical.
Comment 3 Heiko Tietze 2021-08-16 08:49:56 UTC
The sort keys take the value of the first row if options > range contain column headers is checked. This allows you to use the keyboard.

The custom solution would have to consider this option. Quite some effort for not much benefit. Plus, it would be a hidden gem. Let's keep it simple.

Btw, just dropping the "Column" from the criteria string (resp. have it a constant left of the dropdown) doesn't work since options > direction allows to sort by rows. Well, the static string could adjust respectively... 

Feel free to reopen.
Comment 4 fender 2021-08-16 10:43:13 UTC
Ok, I don't understand. 
I assume the letters are variables of some sort and 'column' is a static word.
Isn't it possible to swap Column with the letters? 

Just to clarify 100% this is what I mean:
https://vimeo.com/587776354
passw: aaaaaaaaaaaa

Now, I don't know how Linux/Macos handles this, and if it's a no bc of these two OS'es sure. but if it doesn't matter anyway, might as well make it happen for Windows.
Comment 5 Heiko Tietze 2021-08-30 07:53:21 UTC
We discussed the topic in the design meeting. The static label in front of the column sounds reasonable and has also the advantage of a mnemonic (alt+C<olumn>). Alternatively, we could ignore "Column" or "Row" on keypress but this involves some effort to implement and is less elegant than the static label.

Interesting easy hack. The UI is sc/uiconfig/scalc/ui/sortkey.ui loaded in sc/source/ui/dbgui/sortkeydlg.cxx and controlled by sc/source/ui/dbgui/tpsort.cxx.
Comment 6 fender 2021-11-08 01:18:44 UTC
Hello Heiko Tietze. thanks for trying to implement this and advocating for it.

I think I have a way to make all camps happy. The ones that want to be grammatically consistent, even though I see nothing wrong here, save work for the ones that "have to" code around the 'Column A' issue and so on.

Why don't u guys reinvent the column sorting altogether. Why don't you make it sortable by simple text. Instead of doing it the old GUI way, just give the users a text field with CSV-type of separation. 

Take this short video as example. (mute for audio. I always forget to remove it)
Once I sort, I have to go through the whole process again, unless I make a macro at which point I might as well just have a text field for sorting.
ffffffff
https://vimeo.com/643321746


Now, some people might have the spatial foresight knowing how they will want to sort their columns to best fit their reading in relation to what they want to extract information-wise, but I'm certain the majority doesn't know until they start sorting.

That way folks like me, keyboard folks, don't need to use the GUI at all.

I would still prefer for it to be letter first, for the adhoc quick sorting, but that's meeting half-way.
It won't be as clean as only having to use the left hand because I will have to lift my hand off the mouse to input the comma, but it'll be manageable. Less work to implement bc no hacks needed and way easier to sort for almost everyone.

And hacking around it will be the biggest easter egg ever since it's completely unintuitive. not even the laziest keyboard users will think of using the letter if the letter isn't the first thing the line has. Unless it happens accidentally or they read it in a guide.

One of the reasons the firefox folks didn't want to implement it actually https://bugzilla.mozilla.org/show_bug.cgi?id=1701324

giving users an option to save their sort in GUI with a tickbox 'remember sort' would be great too. It seems not even google has thought of that.
Comment 7 fender 2021-11-08 01:34:15 UTC
>Why don't u guys reinvent the column sorting altogether. Why don't you make it sortable by simple text. Instead of doing it the old GUI way, just give the users a text field with CSV-type of separation. 

I obviously mean via column letters here, not labels. What you do with the labels is your guyses prerogative. I personally never use labels.
Comment 8 Commit Notification 2022-02-10 23:10:18 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/35b9e7f90ca3751d474efff7745582b4bff3e2df

Resolves tdf#140290 - Make sort keys accessible

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2022-02-11 01:22:11 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0613c89308c3d37c7631a9af3605b31abcff6980

Better SCSTR_COLUMN, SCSTR_ROW names, tdf#140290 follow-up

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.