Bug 140353 - UI: Caret merely visible in Writer, LibreOffice (Ubuntu Snap) does not use system settings
Summary: UI: Caret merely visible in Writer, LibreOffice (Ubuntu Snap) does not use sy...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Text-Cursor
  Show dependency treegraph
 
Reported: 2021-02-11 17:44 UTC by Chris
Modified: 2021-12-24 06:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2021-02-11 17:44:09 UTC
Description:
Hi,
I am new to this, so please bear with me, if I am not providing all information required for you to debug things.

I am using LibreOffice 7.0.4.2 provided by Canonical as a snap for Ubuntu 20.04.02, 64bit with Gnome 3.36.8. My screen has a resolution of 3840x2160.

I was searching for a solution on how to make the caret wider / the cursor better visible / the caret thicker, since I have a hard time to see the cursor on my screen (it seems to be 1 pix wide, or so). 

To be clear: I am not talking about the mouse arrowhead cursor, I want to discuss the "caret", i.e. the thin line, where the next letter will appear when typing. Also, please note that I am aware of Overwrite mode and Insert mode. My question is not about these modes.

As a first idea, I found the hint to add this line in ~/.config/gtk-3.0/gtk.css:
* { -GtkWidget-cursor-aspect-ratio: 0.3; }  
where larger values make the caret wider. This works for many programs, e.g. Firefox, but does not work for LibreOffice. The caret is still very thin and nearly invisible. 

Further, LibreOffice does also not seem to care about the system's accessibility settings, e.g. nothing happens if I increase the mouse cursor size in the system settings. Certainly, some settings have effects on LO, but at least, in no way I could make the caret thicker.

I also added the suggested line above also in any config file I could find in the gnome system themes in /usr/share/themes, but that did not change anything. 

I am not sure whether this has to do with the snap package. Maybe I need to change any settings directly in the libreOffice Snap?

Any help would be highly appreciated!


Steps to Reproduce:
1. Open LO Writer on a Ubuntu/Gnome system on a large screen.
2. Look at the Caret
3. The Caret is very thin on large screens. Ubunu/Gnome settings do not affect the caret width.

Actual Results:
The Caret is hardly visible.

Expected Results:
I would like to be able to modify the Caret width. 
LibreOffice should respect system accessibility settings.



Reproducible: Always


User Profile Reset: Yes



Additional Info:
Hi,
I am new to this, so please bear with me, if I am not providing all information required for you to debug things.

I am using LibreOffice 7.0.4.2 provided by Canonical as a snap for Ubuntu 20.04.02, 64bit with Gnome 3.36.8. My screen has a resolution of 3840x2160.

I was searching for a solution on how to make the caret wider / the cursor better visible / the caret thicker, since I have a hard time to see the cursor on my screen (it seems to be 1 pix wide, or so). 

To be clear: I am not talking about the mouse arrowhead cursor, I want to discuss the "caret", i.e. the thin line, where the next letter will appear when typing. Also, please note that I am aware of Overwrite mode and Insert mode. My question is not about these modes.

As a first idea, I found the hint to add this line in ~/.config/gtk-3.0/gtk.css:
* { -GtkWidget-cursor-aspect-ratio: 0.3; }  
where larger values make the caret wider. This works for many programs, e.g. Firefox, but does not work for LibreOffice. The caret is still very thin and nearly invisible. 

Further, LibreOffice does also not seem to care about the system's accessibility settings, e.g. nothing happens if I increase the mouse cursor size in the system settings. Certainly, some settings have effects on LO, but at least, in no way I could make the caret thicker.

I also added the suggested line above also in any config file I could find in the gnome system themes in /usr/share/themes, but that did not change anything. 

I am not sure whether this has to do with the snap package. Maybe I need to change any settings directly in the libreOffice Snap?

Any help would be highly appreciated!
Comment 1 Jean-Baptiste Faure 2021-04-15 20:06:53 UTC
(In reply to Chris from comment #0)
> [...]
> Any help would be highly appreciated!

This bugtracker is not an helpdesk, so I suggest you to ask for help where it is appropriate:

https://ask.libreoffice.org

and, as snap is a very particular thing:

https://ask.ubuntu.com

You could also try an installation from deb package.

Best regards. JBF
Comment 2 Xisco Faulí 2021-04-22 10:24:01 UTC
Thank you for reporting the bug.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Chris 2021-04-22 13:43:25 UTC
Hi Jean-Baptiste, Hi Xisco,
thanks for your ideas and support.

Following Xisco's advise, I installed a LO-Instance ver. 7.1.2.2 from the link provided. It is installed as a standard *.deb-install, not as a snap.

It seems that after the update, the caret is thicker than it was before. I think, LO does not follow the system's accessibility settings:
I fumbled around a bit, checked and un-checked most any settings in the system's accessibility options I could find, restarted my Linux a few times, looked through all settings in LO, but could not find an option, which would allow to make the caret e.g. 5pt wide and glowing red ;-)

At least, the caret is wider now and better visible. So, for me, it works with the thicker caret. :-)

Thanks a lot! 

Best,
Chris