Bug 140489 - FILEOPEN XLSX Chart display is incorrect
Summary: FILEOPEN XLSX Chart display is incorrect
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: bibisected, bisected, filter:ooxml, regression
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2021-02-17 21:23 UTC by Aron Budea
Modified: 2021-06-21 14:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample XLSX (31.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-02-17 21:23 UTC, Aron Budea
Details
Exported PDF (w Excel) (24.43 KB, application/pdf)
2021-02-17 21:25 UTC, Aron Budea
Details
Screenshot from Calc (220.00 KB, image/png)
2021-02-17 21:27 UTC, Aron Budea
Details
The data table of the example file in 6.2 (126.20 KB, image/png)
2021-02-18 13:37 UTC, NISZ LibreOffice Team
Details
The data table of the example file in 6.3 (113.91 KB, image/png)
2021-02-18 13:40 UTC, NISZ LibreOffice Team
Details
How it looks in LibreOffice 7.2 master (57.95 KB, image/png)
2021-04-12 16:15 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2021-02-17 21:23:57 UTC
Created attachment 169838 [details]
Sample XLSX

Open the attached spreadsheet, and check the chart.

=> It's linear, and single-colored.

It should be exponential and two-colored, see attached exported PDF.

Observed using LO 7.2.0.0.alpha0+ (cbcec4425e04e3614a2025b49fdc221216ac51d3), 7.0.0.3 / Ubuntu.
Looks different in 6.4.0.3, it has the expected two colors, but is still linear.
Looks fine in 6.2.0.3.

This is a regression that happened in two steps. First the chart became linear with the following commit. Adding CC: to Balazs Varga.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=11473832b5717cb3222ce72baee885bc9e8e2386
author		Balazs Varga <balazs.varga991@gmail.com>	2019-04-09 16:12:35 +0200
committer	László Németh <nemeth@numbertext.org>	2019-04-15 09:12:59 +0200

"tdf#114181 XLSX combined chart: fix swapped primary and secondary axes etc."

Then it lost the second color. Adding CC: to Tünde Tóth.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cbe6c4929c9da28ce5553ce31782027d5111ed16
author		Tünde Tóth <tundeth@gmail.com>	2019-11-27 10:24:50 +0100
committer	Balazs Varga <balazs.varga991@gmail.com>	2020-04-28 08:02:59 +0200

"tdf#127811 tdf#127813 Introduce compatibility key for the data series"

The spreadsheet is also available here: https://www.free-power-point-templates.com/articles/deferred-tax-rate-calculator-for-excel/
Comment 1 Aron Budea 2021-02-17 21:25:47 UTC
Created attachment 169839 [details]
Exported PDF (w Excel)
Comment 2 Aron Budea 2021-02-17 21:27:02 UTC
Created attachment 169840 [details]
Screenshot from Calc
Comment 3 NISZ LibreOffice Team 2021-02-18 13:27:53 UTC
Some problems also stem from the charts extensive use of named ranges as data sources.

For example in Excel the vertical axis is showing values in the ten thousands range, while Calc in the thousands even in 6.2.
Comment 4 NISZ LibreOffice Team 2021-02-18 13:37:37 UTC
Created attachment 169856 [details]
The data table of the example file in 6.2

In 6.2 there was a Category column imported into the data table.
Comment 5 NISZ LibreOffice Team 2021-02-18 13:40:52 UTC
Created attachment 169858 [details]
The data table of the example file in 6.3

Since the bibisected commit the Category column is missing.
Comment 6 Xisco Faulí 2021-04-08 14:28:28 UTC
I see a patch is gerrit for this issue < https://gerrit.libreoffice.org/c/core/+/113804 > but it's only distro/collabora/cp-6.4.

@Szymon Kłos, do you also plan to submit it to master ?
Comment 7 Szymon Kłos 2021-04-08 15:08:30 UTC
(In reply to Xisco Faulí from comment #6)
> 
> @Szymon Kłos, do you also plan to submit it to master ?

Yes I will push it also for master
Comment 8 Commit Notification 2021-04-12 11:41:01 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/be82f6313f298c13a2f040b218c6f2a33705ff8c

tdf#140489 fix chart display in xlsx

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2021-04-12 16:15:05 UTC
Exponential problem instead of lineal fixed in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 8043fe3e45c8999c8eaf475ba46d50b125e38b93
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Szymon Kłos, thanks for fixing this issue.

Yellow line is still missing, I'll report it in follow-up ticket
Comment 10 Xisco Faulí 2021-04-12 16:15:45 UTC
Created attachment 171132 [details]
How it looks in LibreOffice 7.2 master
Comment 11 Commit Notification 2021-04-12 16:17:16 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/0111cc1b5a0cc686b7d42f4eadabba81880d63d8

tdf#140489 fix chart display in xlsx

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2021-04-12 18:55:38 UTC
(In reply to Commit Notification from comment #8)
> Szymon Kłos committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> be82f6313f298c13a2f040b218c6f2a33705ff8c
> 
> tdf#140489 fix chart display in xlsx
> 
> It will be available in 7.2.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Done in bug 141657