Bug 140553 - FIXED Function Documentation is not up to date
Summary: FIXED Function Documentation is not up to date
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2021-02-20 12:13 UTC by Jürgen Kirsten
Modified: 2021-05-10 08:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Kirsten 2021-02-20 12:13:49 UTC
Description:
In the help page of the FIXED function, the option Decimal places is not shown as optional. How I found in OASIS Open https://docs.oasis-open.org/office/OpenDocument/v1.3/cs02/part4-formula/OpenDocument-v1.3-cs02-part4-formula.html#FIXED the second function is no longer absolutely necessary. It is conditionally optional because a default value of 2 is used here if no value is entered.
In addition, the LO help does not report the option of entering negative values to round the value to the left of the decimal point. An example should also be given.

Changes:

FIXED(Number [; Decimals = 2 [; NoThousandsSeparators]]) 

Decimals (optional – default=2) refers to the number of decimal places to be displayed. If no value is entered, 2 is used as the default value. If decimals is negative, the function rounds to the nearest 10, 100, 1000, etc. 

Example: (additional)

FIXED(1234) returns 1,234.00 as a text string.
FIXED(1234;-3;1) returns 1000 as a text string.

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Rafael Lima 2021-03-31 16:58:23 UTC
I can confirm this in LO 7.1.2.2.

The help page text/scalc/01/04060110.xhp should be updated.

Changing to NEW.
Comment 2 Commit Notification 2021-04-01 18:07:10 UTC
Alain Romedenne committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/c48d8ad018dbe18632e3b0454874d4e0b4fb1757

tdf#140553 =FIXED documentation
Comment 3 Jürgen Kirsten 2021-05-09 12:05:53 UTC
An error has crept into the new examples. Once "," was used instead of ";".

wrong:
=FIXED(12345.789,8/5)

corrected:
=FIXED(12345.789;8/5)
Comment 4 Olivier Hallot 2021-05-09 15:00:39 UTC
patch merged
https://gerrit.libreoffice.org/c/help/+/115211
Comment 5 Xisco Faulí 2021-05-10 08:22:22 UTC
(In reply to Olivier Hallot from comment #4)
> patch merged
> https://gerrit.libreoffice.org/c/help/+/115211

I guess we can close it again