Bug 140641 - Chapter Numbering dialog "forgets" a loaded Numbering in switching from Numbering to Position tab and back, if no modifications are made in Position tab
Summary: Chapter Numbering dialog "forgets" a loaded Numbering in switching from Numbe...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2021-02-24 13:30 UTC by sdc.blanco
Modified: 2021-03-09 16:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
chapter.cfg used to produce problem (8.58 KB, application/xml)
2021-03-02 15:57 UTC, sdc.blanco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2021-02-24 13:30:15 UTC
1. Tools - Chapter Numbering
(if you have not saved a numbering then first modify "Number" for one or more levels, then Load/Save, Save As, enter a name)
2. Load/Save (choose a saved entry)
3. Click on "Position" tab
4. Click on "Numbering" tab

Actual Result:  The loaded entry is gone.
Expected result:  Loaded entry remains after switching to position tab.

Additional information:

Step 3.5  Modify a value in the Position tab
4. Click on Numbering tab

Actual and Expected Result:  The loaded values remain.

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded
Comment 1 Timur 2021-02-25 11:42:23 UTC Comment hidden (obsolete)
Comment 2 Timur 2021-02-25 11:44:55 UTC Comment hidden (obsolete)
Comment 3 sdc.blanco 2021-02-25 11:46:52 UTC Comment hidden (obsolete)
Comment 4 Timur 2021-02-25 12:19:48 UTC Comment hidden (obsolete)
Comment 5 sdc.blanco 2021-02-25 14:04:31 UTC
(In reply to Timur from comment #4)
> Looks unneeded to separate to two bugs to me. 
This bug is NOT about the crash. You did not mention testing in 7.1.0.
Notice version number in comment 0. Probably you did not see the problem if you were crashing on the "position" tab. Will set this back to "Unconfirmed".
Comment 6 Timur 2021-03-02 13:48:29 UTC
No repro with master,if you mean that Numbering is gone, as Title indicates. 
I do see that value in Position is lost if not accepted with OK. 
Please review the steps.
Comment 7 sdc.blanco 2021-03-02 15:57:48 UTC
Created attachment 170181 [details]
chapter.cfg used to produce problem

Can still repro with the 7.1.0.3 identified in comment 0.

1. Start with "pre-loaded" outlines in attachment in {user profile}/config/chapter.cfg
2. Tools > Chapternumbering
   (dialog opens on Numbering tab, with cursor on Level 1)
3. Load/Save > choose "Position Centered"
   Result: Serbian numbering in level 1, notice preview has numbering up to Level 7.
4. Click on Position tab, then click on Numbering tab.

Result:  the numbering seen in the preview after step 3 is gone.

(couldn't try this before with 7.2.0.0 because of crash with Position tab),


So far, have not been able to repro with recent master -- but I also keep getting crashes in 7.2.0.0.alpha when I try to test this throughly. For example, maybe the problem is that there has to be a lot of levels saved, so I tried to make one manually for 7.2.  

1. Set the number field for level 1 through level 10
2. Choose Load/save > Save As
Crash
https://crashreport.libreoffice.org/stats/crash_details/3f5360b6-a5ad-45ba-9481-d0cb1a7283e5

I will wait until 7.2.0.0 is more stable before further testing. 

Tested with:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6fb9f368c6824a8ff7bc5bc5cf66fc2df7d055b7
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: CL
Comment 8 sdc.blanco 2021-03-06 21:27:02 UTC
Cannot reproduce with: 

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6fb9f368c6824a8ff7bc5bc5cf66fc2df7d055b7
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: CL

Also tried in 7.2 with the chapter.cfg that gives the problem in 7.1.0.3
Will close as NAB
Comment 9 Timur 2021-03-07 07:21:34 UTC
I consider this a bug, please comment :

value in Position is lost if not accepted with Ok before returning to Numbering
Comment 10 sdc.blanco 2021-03-07 08:42:54 UTC
(In reply to Timur from comment #9)
> I consider this a bug, please comment :
> 
> value in Position is lost if not accepted with Ok before returning to
> Numbering
Agree that such behavior is a bug.

But I cannot reproduce it (also tried in Safe Mode) with:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6fb9f368c6824a8ff7bc5bc5cf66fc2df7d055b7

Fwiw, I have had an impression sometimes that this (losing Position) was happening, but there are so many moving parts in this dialog, that it is hard to always notice the exact sequence to reproduce a problem.
Comment 11 sdc.blanco 2021-03-09 16:47:24 UTC
(In reply to Timur from comment #9)
> value in Position is lost if not accepted with Ok before returning to
> Numbering
I think I have found a reliable case where Position is lost in Save As.

1. Leave Numbering as "None" or choose a numbering scheme in the Number field.
2. In Position, set Numbering Alignment as "Centered" for a few levels.
3. Save as "Centered" (or whatever)
4. Set the "position" to "Left" manually.
5. Load/Save > Centered 
Result:  Position remains at "Left", the "Centered" is not saved.

Tested in Safe Mode

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 72841008bf422dfd8553240b3a78f0474d03523c
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: threaded

(but other times position is remembered, for example, when I was not working in Safe Mode. Not sure what is critical here.)

(see bug 140800 for an enhancement request for the Load/Save dialog)