Bug 140790 - Unable to change language from English-US to English-UK
Summary: Unable to change language from English-US to English-UK
Status: RESOLVED DUPLICATE of bug 133661
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-04 09:45 UTC by EasyGoingPat
Modified: 2021-06-12 10:41 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description EasyGoingPat 2021-03-04 09:45:11 UTC
Description:
If I open Libre Office parent application and change the language from En-US to En-UK, the change is remembered in Libre Office. If I create a new Writer document from the parent application, the language is correctly set to En-UK.

If I right-click a folder in Windows Explorer and create a Writer document, the language is always En-US.

If, in Writer, I change the default language to En-UK, click 'Apply' then 'Okay', the change is not remembered. The next document I create from Explorer reverts to En-US.

Steps to Reproduce:
1. Right-click in Explorer to create new Writer document.
2. Double-click the new document to open it.
3. Open menu Tools | Options | Language Settings | Languages
4. Change Default Languages for Documents from English (USA) to English (UK).
5. Click 'Apply' and then 'Okay'.
6. Close the document, saving if prompted.
7. Right-click in Explorer to create another new Writer document.
8. Double-click the new document to open it.
9. Open menu Tools | Options | Language Settings | Languages

Actual Results:
Default Languages for Documents has reverted to English (USA).

Expected Results:
Default Languages for Documents should now be English (UK).


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 Timur 2021-03-11 12:05:08 UTC
Seems duplicate. Please explain if not and write your observation there if it is.

*** This bug has been marked as a duplicate of bug 136769 ***
Comment 2 EasyGoingPat 2021-03-11 12:12:28 UTC
Yep, a duplicate. Sorry!

- Patrick
Comment 3 Mike Kaganski 2021-06-12 10:41:00 UTC

*** This bug has been marked as a duplicate of bug 133661 ***