Bug 140845 - "Contains" in Paragraph Style should identify List Style as "List Style", not as "Numbering"
Summary: "Contains" in Paragraph Style should identify List Style as "List Style", not...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
Depends on:
Blocks: Styles-Dialog
  Show dependency treegraph
 
Reported: 2021-03-06 22:22 UTC by sdc.blanco
Modified: 2021-12-07 13:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2021-03-06 22:22:48 UTC
1. Edit a Paragraph Style that has a "List Style" (e.g., a Heading N or add a List Style)

2. Organizer tab > Contains

Actual:  Numbering(name of list style)

Expected:  List Style(name of list style)


Need to change "Numbering" to "List Style" here:

https://opengrok.libreoffice.org/xref/core/sw/inc/strings.hrc?r=7838c4a9#277
Comment 1 Heiko Tietze 2021-03-09 10:25:38 UTC
(In reply to sdc.blanco from comment #0)
> https://opengrok.libreoffice.org/xref/core/sw/inc/strings.hrc?r=7838c4a9#277
That's not the correct code pointer.

It's STR_NUMRULE_ON and STR_NUMRULE_OFF (when you set list style to none and parent has some list style applied).

"List Style" for STR_NUMRULE_ON sounds good to me, and the counterpart "No List Style" in case of STR_NUMRULE_OFF is also okay since we cannot use "List Style (None)"- and it makes no sense actually since None is not a style.

I would also appreciate when we get a space after the string. It is in sw/source/uibase/utlui/attrdesc.cxx bool SwNumRuleItem::GetPresentation the first '+ "("'.
Comment 2 Commit Notification 2021-03-11 14:38:26 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f92510321dc860f43e471473db67167c0fefcbea

tdf#140845 labelling improvements for List Styles in Contains

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 sdc.blanco 2021-03-11 14:50:48 UTC
The patch moves the hard-coding of the formatting of the label over to the translators. 

The default en-US version is now:  List Style: (liststylename)
    where liststylename is the value of the List Style property in the Paragraph Style dialog (Outline & List tab). When the value is "None", then Contains shows:
                                   List Style (None)

Closing as FIXED
Comment 4 Stéphane Guillou (stragu) 2021-12-07 13:30:19 UTC
verified as fixed in:

Version: 7.2.4.1 / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded