Bug 141193 - Add barcode support into QR code dialog
Summary: Add barcode support into QR code dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Homeboy_445
URL:
Whiteboard: target:7.3.0 inReleaseNotes:7.3
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
: 67090 145075 (view as bug list)
Depends on:
Blocks: QR-code 128779
  Show dependency treegraph
 
Reported: 2021-03-23 09:22 UTC by Buovjaga
Modified: 2022-05-12 13:55 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2021-03-23 09:22:28 UTC
In bug 139778, the QR code library was switched to https://github.com/nu-book/zxing-cpp

Now it is possible to also generate classic 1D barcodes, so we should offer the functionality.

The original dialog was added with https://git.libreoffice.org/core/commit/2de42b53b7c23223c38e64a75eae248d8a0cd4ec

The new title for the updated dialog can be: QR and Barcodes
Comment 1 Samuel Mehrbrodt (allotropia) 2021-03-23 10:10:34 UTC
*** Bug 67090 has been marked as a duplicate of this bug. ***
Comment 2 Homeboy_445 2021-03-23 10:12:17 UTC
Should we inculcate the functionality within the existing QR code dialog box by adding a feature like drop-down or something where the user could select either Qr code or Bar code and generate it as it does right now or should a new dialog box be created for serving this purpose?
Comment 3 Mike Kaganski 2021-03-23 11:31:00 UTC
Creating API for QR codes should depend on this: only after implementing more formats, the API should appear and allow creation of any of those types.
Comment 4 Samuel Mehrbrodt (allotropia) 2021-03-23 14:49:15 UTC
(In reply to Homeboy_445 from comment #2)
> Should we inculcate the functionality within the existing QR code dialog box
> by adding a feature like drop-down or something where the user could select
> either Qr code or Bar code and generate it as it does right now or should a
> new dialog box be created for serving this purpose?

Please use the existing dialog and add a dropdown (or similiar) where you can chose the type (as it's written in the bug title).
Ask #libreoffice-design IRC channel if you need a mockup.
Comment 5 Telesto 2021-09-15 14:40:53 UTC
I didn't try the current commit at gerrit. However I'm asking myself:  What will the menu entry be after this gets pushed. Will Insert -> Object -> QR-code being changed into Barcode?

I personally struggle a bit with the idea of renaming QR-code to Barcode. A QR-code might be a species of the genus barcode. However I associate 'barcode' with "Linear barcodes" and less with "Matrix (2D) barcodes". Visa visa the same is 
true. QR code isn't a "Linear barcodes"

So barcode might be technically proper description. However this might be easy  misinterpreted in everyday speech.

Not that having the ideal solution here:
A) 2 entry's point to the same dialog. But well this might be seen as bloat. 
B) Calling it "QR- Barcode"
C) Barcode
D) Something else?
Comment 6 V Stuart Foote 2021-10-11 18:01:05 UTC
*** Bug 145075 has been marked as a duplicate of this bug. ***
Comment 7 ComputerHotline 2021-10-11 18:53:31 UTC Comment hidden (spam)
Comment 8 Commit Notification 2021-10-29 11:46:48 UTC
homeboy445 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d37a44a9ebdafec1435f98194417a1d8cc8208b5

tdf#141193 Added support for bar codes in qrcode dialog box[API Change].

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Adolfo Jayme Barrientos 2021-11-03 00:48:30 UTC
Verified on:

Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: f4b353c1f52fc78a102413cac94c7fb24292bec6
CPU threads: 8; OS: Windows 10.0 Build 22483; UI render: Skia/Vulkan; VCL: win
Locale: es-MX (es_MX); UI: es-ES
Calc: threaded

The menu item still needs to be renamed to match the new dialog title, and I would move the Type combo box to be at the very top of everything else, but the functionality is there and it works! Thanks a lot Akshit!
Comment 10 stragu 2022-01-25 11:25:16 UTC
Reviewing release notes.
I added a picture for this feature: https://wiki.documentfoundation.org/ReleaseNotes/7.3#Core_.2F_General
Comment 11 kabilo 2022-02-15 16:09:33 UTC
Hi. Would it also be possible to create a barcode variant with a text label? Thanks
Comment 12 Buovjaga 2022-02-15 16:12:40 UTC
(In reply to kabilo from comment #11)
> Hi. Would it also be possible to create a barcode variant with a text label?
> Thanks

Please open a new report
Comment 13 Pekka Siiskonen 2022-05-12 13:55:47 UTC
It would have been nice to know what type of barcode the:

 Insert -> Object -> QR and Barcode...

is actually inserting, as there are dozns of different barcodes and not all barcode readers can read them all:

https://extensions.libreoffice.org/en/extensions/show/barcode

https://en.wikipedia.org/wiki/Barcode#Linear_barcodes