Bug 145728 - "Insert > Object > Bar Code..." menu should be "QR and Barcode..."
Summary: "Insert > Object > Bar Code..." menu should be "QR and Barcode..."
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.0.alpha1+
Hardware: All All
: medium trivial
Assignee: Ming Hua
URL:
Whiteboard: target:7.4.0 target:7.3.0.0.beta2
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
Depends on:
Blocks: QR-code
  Show dependency treegraph
 
Reported: 2021-11-17 07:52 UTC by Stéphane Guillou (stragu)
Modified: 2021-12-02 20:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Guillou (stragu) 2021-11-17 07:52:44 UTC
Description:
LO 7.3 now allows inserting barcodes as well as QR codes.
However, the name of the menu item was changed to only "Bar Code...".
I believe it would be more informative and accurate to rename that to "QR and Barcode...".

This is because:
- it mentions both options
- it corrects the spelling from "bar code" to "barcode"
- it corresponds to the dialog's title

I could be convinced that "or" should be used instead of "and", because it is a bit inconsistent in the menu. For example, I can currently see:
- Audio or Video...
- Stars and Banners...
- Footnote and Endnote
- Footnote or Endnote...
- Header and Footer

Steps to Reproduce:
1. Open Writer/Calc/Impress
2. Open Insert menu > Object

Actual Results:
Name is "Bar Code..."

Expected Results:
Name is "QR and Barcode..."


Reproducible: Always


User Profile Reset: Yes



Additional Info:
In Version: 7.3.0.0.alpha1+ / LibreOffice Community
Build ID: eec32be26d5d5805c1cb8cb53ce9702c04829819
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 1 Heiko Tietze 2021-11-19 12:38:03 UTC
It was changed from "QR Code" to this label for bug 141193. A lot of comments on the patch but apparently none regarding the labels. Unless there was a good reason I support the request.

It would be .uno:InsertQrCode and .uno:EditQrCode in officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu. The "Edit Bar Code..." could become "Edit QR/Barcode" or "Edit QR- or Barcode" otherwise.
Comment 2 Buovjaga 2021-11-19 12:42:31 UTC
Just a couple of notes, not saying I'm against this change:
1. Bar code is correct spelling alongside barcode
2. QR code is a subtype of barcodes: https://en.wikipedia.org/wiki/Barcode#Matrix_(2D)_barcodes
Comment 3 Heiko Tietze 2021-11-19 13:21:24 UTC
(In reply to Buovjaga from comment #2)
> 1. Bar code is correct spelling alongside barcode

Looking forward Adolfo's input now.
Comment 4 Ming Hua 2021-11-19 14:12:57 UTC
(In reply to Buovjaga from comment #2)
> 2. QR code is a subtype of barcodes:
This point was also raised in https://bugs.documentfoundation.org/show_bug.cgi?id=141193#c5 , and is probably (part of) the reason "Insert > Object > QR Code" menu was changed to "... > Bar Code".

(In reply to Heiko Tietze from comment #1)
> It was changed from "QR Code" to this label for bug 141193.
Regarding to UI strings, that commit was an inconsistent mess.

In addition to the "QR Code" to "Bar Code" change mentioned in comment #0, there are also (in cui/uiconfig/ui/qrcodegen.ui):
- the title of the code generator dialog is "QR and Barcode"
- the extended tooltip for the URL/Text input box is "The text from which to generate the QR code." which I assume also applies to bar codes.  This was from the old QR-code only days and wasn't touched by the commit (and should be).

As a non-native speaker I don't really have a preference.  But this inconsistency is really annoying.
Comment 5 V Stuart Foote 2021-11-19 16:04:45 UTC
At present just two barcodes types from the latest ZXing based zxing-cpp lib [1] are being used--'QR Code' (aka "Quick Response code"), and 'Code 128'.  

But recent work expanding barcode framework will allow additional changes to the LibreOffice UI (and API/IDL) to use all supported barcode formats.

While the current "Bar Code..." label incorrectly splits the noun, it also looses the object recognition of including "QR".

The "QR code" moniker is synonymous to Matrix, or 2D, barcodes. 

It would be just as correct to insert label as "Matrix or 1D Barcode..." or "2D or 1D Barcode..." or even just "Barcode..." but keeping the "QR code" provides marketable recognition. 

Best to simply relabel Insert -> Object -> as "QR and Barcode..." and match the dialog title.

=-ref-=
https://github.com/nu-book/zxing-cpp
Supported Formats
1D product      1D industrial      2D
UPC-A           Code 39            QR Code
UPC-E           Code 93            DataMatrix
EAN-8           Code 128           Aztec
EAN-13          Codabar            PDF417
DataBar         ITF                MaxiCode (beta)
                DataBar Expanded	
Note: DataBar used to be called RSS.
Comment 6 Heiko Tietze 2021-11-22 12:01:10 UTC
(In reply to V Stuart Foote from comment #5)
> Best to simply relabel Insert -> Object -> as "QR and Barcode..." and match
> the dialog title.

And how about the edit command?
Comment 7 Adolfo Jayme Barrientos 2021-11-22 13:57:08 UTC
Yep, please do as Stuart says, and in addition, the strings:

* Generate QR Code for any text or URL.
* The margin surrounding the QR code.
* Error Correction:
* The type which is to be generated.
* Bar Code

should be changed, respectively, as follows:

* Generate 1D and matrix codes for any text or URL.
* The margin surrounding the code.
* Error correction:
* The type of code to generate.
* Barcode

Would do it myself but currently have issues updating my git clones.
Comment 8 V Stuart Foote 2021-11-22 14:44:32 UTC
(In reply to Heiko Tietze from comment #6)
> 
> And how about the edit command?

The barcode object can be edited when focused from its context menu, relaunching the "QR and Barcode..." dialog.  The menu label is the same incorrect split-noun "Edit Bar Code..."

For brevity we can probably drop the 'QR' here, and make the label "Edit Barcode..." IIRC the context menus can have different labels for controls to regular menus.
Comment 9 Stéphane Guillou (stragu) 2021-11-26 01:59:35 UTC
Just to add to the reasons for changing the name:

- Not many people know that a QR code is a subset of bar codes
- I would expect LO users to be more likely to use QR codes than bar codes nowadays
- Losing the "QR" word in the menu when updating to LO 7.3 would make people feel like the feature was removed from LO
- Searching for "QR" in the Search Commands HUD does not yield a result
Comment 10 Michael Warner 2021-11-26 17:05:28 UTC
https://www.merriam-webster.com/dictionary/barcode calls "bar code" a less common variant of "barcode", but the two examples cited at the bottom (one from Forbes, the other from the New York Times) both use "bar code". So I would  say that both "barcode" and "bar code" are correct.
Comment 11 Ming Hua 2021-11-26 17:45:01 UTC
(In reply to Adolfo Jayme from comment #7)
> Would do it myself but currently have issues updating my git clones.

The UI freeze for 7.3 is near, and I assume Adolfo is still having problem with his git or occupied by other responsibilities.  So I'm taking the initiative and will try to submit a patch for review this weekend.

Meanwhile others can keep discussing the best wording choices like "barcode" vs. "bar code".
Comment 12 Ming Hua 2021-11-26 22:01:35 UTC
Patch in Gerrit:
https://gerrit.libreoffice.org/c/core/+/125925

Made changes to the main menu and context menu, as well as the labels and tooltips in the dialog, according to Adolfo's and Stuart's suggestions in comment #7 and #8.

With my translator's hat on, I personally would like to have the context menu .uno:EditQrCode to be "Edit QR and Barcode..." instead of just "Edit Barcode...", because in simplified Chinese, the word for "barcode" has a strong implication of being one-dimensional, and nobody expect it to also include the 2D QR code.  But that's a minor issue, as I can always change the Chinese translation to be more verbose and explicit.
Comment 13 Buovjaga 2021-11-27 06:48:22 UTC
(In reply to stragu from comment #9)
> Just to add to the reasons for changing the name:
> 
> - Not many people know that a QR code is a subset of bar codes

To make it clear what this is all about: https://en.wikipedia.org/wiki/Mind_share

Quote:

'A legal risk of such popularity is that the name may become so widely accepted that it becomes a generic term and loses trademark protection. Examples include "escalator", "panadol", "chapstick", "tupperware", and "bandaid". Companies will often attempt to prevent a product name from becoming generic to avoid losing trademark protection. Xerox Corporation attempted to prevent the genericization of its core trademark through an extensive public relations campaign advising consumers to "photocopy" instead of "xerox" documents.'

So it's the same as when people talk about excels when they mean spreadsheets and powerpoints when they mean presentations.

Despite what is implied in comment 3 and comment 11, nobody in this report is arguing against changing the strings. It is just good to have a record of why we are making a choice.
Comment 14 Heiko Tietze 2021-11-27 07:11:21 UTC
(In reply to Adolfo Jayme from comment #7)
> * Generate 1D and matrix codes for any text or URL.

I stumble over the "1D" and suggest to use just "bar" instead.
Comment 15 Commit Notification 2021-11-28 18:33:51 UTC
Ming Hua committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cf6823ea07047ad7681262e94721f88e768f5845

tdf#145728 Update UI Strings about QR and Barcode

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2021-11-28 20:42:53 UTC
Ming Hua committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/81b26582ed62db40e2be701ddefede7d8230d0d2

tdf#145728 Update UI Strings about QR and Barcode

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2021-11-29 09:26:52 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/fe3d13ce1750ba2cd5bc64ff76d20a11e93e446e

Related: tdf#145728 Update help strings for QR and Barcode dialog
Comment 18 Ming Hua 2021-11-30 02:52:02 UTC
Thanks Heiko and Adolfo for the review!

I wonder if the help documentation changes mentioned in comment 17 should be backported to 7-3 branch as well?
Comment 19 Commit Notification 2021-12-02 11:13:57 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/help/commit/aab06144bd2b80cffc77df8ebb8b58ffc89468cb

Related: tdf#145728 Update help strings for QR and Barcode dialog
Comment 20 BogdanB 2021-12-02 20:11:41 UTC
Thanks for fixing this, I also noticed this bug.

Verified with
Version: 7.3.0.0.beta1+ / LibreOffice Community
Build ID: 81b26582ed62db40e2be701ddefede7d8230d0d2
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded