Bug 141249 - VIEWING: Navigating through a Writer document using pg-up and pg-dn keys is unpredictable.
Summary: VIEWING: Navigating through a Writer document using pg-up and pg-dn keys is u...
Status: RESOLVED DUPLICATE of bug 81829
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2021-03-25 15:41 UTC by P Cunningham
Modified: 2021-03-25 16:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description P Cunningham 2021-03-25 15:41:40 UTC
Description:
I am a writer. I need to read Writer documents easily, but if I use the pg-dn and pg-up keys they do not behave as expected, and their behaviour is inconcistent. In 'Normal' view, I am looking at an 8-page document, a chapter in a book. The chapter title is styled 'Heading 2', the first paragraph is styled 'First paragraph' - I don't know if this has any bearing.

With the cursor in the first paragraph I press 'pg-dn'. The page view moves only to the beginning of the third paragraph/7th line, not, as I would expect, to 2 or 3 lines before the end of the page, which would give an overlap which would allow my brain and eyes to continue reading without a pause. Instead I have to search for my place on the page.

If I place the cursor in the second paragraph, the page view starts five lines further down in the text. The exact position in the text that the view moves to seems to be dependent on which line the cursor is positioned on. If I position the cursor on the penultimate line, then the view moves to one line below, ie a single line overlap.

If I place the cursor on the first line and press pg-dn twice, the second screen change takes me to a position where there is a negative overlap of 2 lines, ie two lines of text appear neither at the bottom of the 'second' page nor at the top of the 'third' page.

The behaviour of these keys is inconsistent. Another incosistency is that if I press pg-dn and then pg-up I do not return to the same place, which is what I would expect and what happens in other programmes.

If I click in the scroll bar, below the handle, the behaviour is more consistent, with a consistent overlap of six lines. This overlap is too much for me to be able to read without interruption; I have to pause to find my place on each page.

I am viewing the document at 100%.

Steps to Reproduce:
1. Open a multi-page document
2. Press pg-dn key
3. Press pg-dn key again, or pg-up

Actual Results:
See description above

Expected Results:
pg-dn should move the page view to start with an overlap of one, two or three lines


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: threaded
Comment 1 V Stuart Foote 2021-03-25 16:39:27 UTC
The pg-dn and pg-up keys are scrolling controls, for selection or view port movements within a document.

Specific scope of the movement is os/DE dependent, and current zoom level of document canvas.

And as with dupe, this remains => WF and would waste dev effort for "taming" the variability by os.

Otherwise for bug 105776 at LO 7.1.0 we implemented full page movements & selection with the
.uno:GoToStartOfNextPage
.uno:GoToStartOfNextPageSel
.uno:GoToStartOfPrevPage
.uno:GoToStartOfPrevPageSel

assigned <Alt><pgDN|pgUP> and <Shift><Alt><pgDn|pgUP>

*** This bug has been marked as a duplicate of bug 81829 ***