Bug 81829 - VIEWING: Can't page down accurately in "Entire Page" view
Summary: VIEWING: Can't page down accurately in "Entire Page" view
Status: VERIFIED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-28 06:07 UTC by Warren Mars
Modified: 2016-10-12 11:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bad alignment in "Entire Page" mode (224.21 KB, image/png)
2014-07-30 00:33 UTC, Warren Mars
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Warren Mars 2014-07-28 06:07:40 UTC
Problem description: It is not possible to use Writer to read a long document properly because it does not align pages properly when page down pressed.

Steps to reproduce:
1. Open a large document in Writer under Windows 7.
2. Select "Entire Page" from View/Zoom
3. Press page down.

Current behavior: Page down will align the document so that the interpage break is roughly in the middle of the viewing area. The top of the area will show the end of the previous page and the bottom of the area will show the start of the current page. Continued pressing of page down will continue to align the page break in the approximate centre of the viewing area.

Expected behavior: Page down should align the document so that the top of the page is at the top of the viewing area and only that page should be visible. Continued pressing of page down should display each successive page taking up the entire viewing area.

Further information: This is the same bug that was listed earlier as FDO#65885 and wrongly closed by James a year ago with WORKSFORME when he used LO 4.1.0.1 on OS X 10.8.4.

This is a Windows Bug and should not be closed by an Apple user.

              
Operating System: Windows 7
Version: 4.2.5.2 release
Comment 1 tommy27 2014-07-28 10:32:16 UTC
hi Warren,

James said:

> Setting to WORKSFORME.
> 
> If this problem persists with the latest release, please re-open this bug.


so my suggestion is to close this bug as a duplicate of Bug 65885 and reopen that one as well.

was it you that opened the original report or another user?
Comment 2 Warren Mars 2014-07-28 22:29:33 UTC
I think it best to use this thread and leave the other closed for now.
The other was opened by mangled_us@yahoo.com, not by me.

Now if someone is interested in fixing this bug that would be great!
Comment 3 tommy27 2014-07-29 05:37:34 UTC
@Warren
ok. post a screenshot showing exactly the page down issue.

@mangled_us@yahoo.com
I put you on CC list. are you still reproducing this issue?
Comment 4 Warren Mars 2014-07-30 00:33:46 UTC
Created attachment 103661 [details]
Bad alignment in "Entire Page" mode

Here is the symptom. If you want any more screen shots just ask.
Comment 5 tommy27 2014-07-30 05:00:34 UTC
I confirm issue under Win7x64 using 4.2.5.2, 4.0.6.2 and 4.4.0.0.alpha0+
Build ID: 9f803ee4b64e11e481ae9bf92ffac7cbf568675a
TinderBox: Win-x86@42, Branch:master, Time: 2014-07-28_06:27:11

same issue in AOO 4.1. hence bug is inherited from OOo
Comment 6 Owen Genat (retired) 2014-08-01 00:45:00 UTC
Also confirmed under GNU/Linux for v3.5.7.2 through v4.3.0.3. Platform set to All/All. Summary edited to remove Windows reference.
Comment 7 QA Administrators 2015-09-04 02:48:16 UTC Comment hidden (obsolete)
Comment 8 Warren Mars 2015-09-10 04:13:20 UTC
Bug remains. This doesn't surprise me as it is clear that no one much is doing any work on this project. I'm giving up on LibreOffice and looking for something that works properly.

Libre Office v5.0.1.2
Windows 7
Comment 10 QA Administrators 2016-09-20 10:29:24 UTC Comment hidden (obsolete)
Comment 11 Warren Mars 2016-09-20 23:57:54 UTC
Bug remains under v5.2.1.2.
This does not surprise me as virtually no bugs are ever fixed here. It's a shame that there is no such thing as a good word processor anymore but that's the idiot world that we have built for ourselves. As for Libre Office: "If you pay peanuts you get monkeys."
Comment 12 Heiko Tietze 2016-10-11 14:06:14 UTC
You are looking for a different function. Page up/down was never meant to scroll to a particular position. 

You may either use the Navigator (F5) with its 'previous/next page' buttons, or you assign shortcuts to the function "to beginning of next/previous page" (tools > customize: category Navigate), where you may also choose Page up/down. (See also bug 101211.)

WORKSFORME, but feel free to reopen again.
Comment 13 Warren Mars 2016-10-11 22:42:32 UTC
I think we can do without pests like you Heiko, coming along and removing bugs with a simple "works for me". It doesn't work, it IS a bug, and kindly mind your own business next time.
Comment 14 tommy27 2016-10-12 04:01:17 UTC
@Warren
Heiko was polite. He expressed his opinion about the bug. right or wrong? I don't care... he even told that you were free to reopen if you did not agree.

so your reaction seems completely out of place and offensive.
this attitude is 10% wrong and not tolerated here.

think about it.
Comment 15 jani 2016-10-12 08:04:29 UTC
May I please ask to keep the tone polite. Heiko has the right (like everybody else) to have an opinion, which he expressed rather politely.

Furthermore (which you Warren) might not be aware of, Heiko has UI as his prime responsibility in his work for TDF. 

We both close/change bugs everyday as part of our job, if you disagree with Heiko and sees this a bug, then contact the UI team, who have the final say about how the UI works (Heiko is part of that team).
Comment 16 tommy27 2016-10-12 08:16:38 UTC
(In reply to tommy27 from comment #14)
> @Warren
> ...
>
> this attitude is 10% wrong and not tolerated here.
> 
> ...

I meant 100% wrong and also comment 11 was unrespectful and offensive towards the LibO project.
Comment 17 Warren Mars 2016-10-12 10:34:03 UTC Comment hidden (abusive)
Comment 18 tommy27 2016-10-12 11:11:18 UTC
you are a troll.